This discussion is archived
2 Replies Latest reply: May 10, 2011 3:28 PM by TEXAS10950 RSS

Evo4G does not see SD card

bombay6760a Newbie
Currently Being Moderated

My Evo4G does not see the sd card anymore.  It was fine one minute and then I looked at the screen when I was trying to take a picture and now it says to insert an sd card. I removed and reinstalled the battery and sd card already and restarted the phone. The same issue exists. In the settings menu under sd card; it indicates that it is unavailable. What is going on?

  • 1. Evo4G does not see SD card
    rexcanis Bronze Expert
    Currently Being Moderated

    It is possible the card is corrupted. Have you tried putting it into another phone or into a computer?

  • 2. Evo4G does not see SD card
    TEXAS10950 Newbie
    Currently Being Moderated

    The same thing happed to me on this past Saturday. It was working fine Saturday morning and then I tried to download an application andit said insert SD card.I tried removing it and re-adding it, it did not work. Even tried using an adapter and put it in my computer. My pc would not recognize it. Basically, the SD card is no longer working. I called in and they put a ticket in for me at the closest repair shop. They had to replace me SD card. Needless to say, I lost everything on my card: pictures, videos, apps I downloaded, documents, etc. From now on, fair warning, always back up the stuff on your phone.

More Like This

  • Retrieving data ...

Legend

  • Correct Answers - 4 points
  • Helpful Answers - 2 points