This discussion is archived
14 Replies Latest reply: Mar 23, 2012 10:25 PM by DarkZrobe RSS

Epic only plays Voice Mail on speaker

CarrieElmore Newbie
Currently Being Moderated

Since the update I have 2 Epics that will only plaback voice mail on speaker

  • 1. Epic only plays Voice Mail on speaker
    robbiedoo2001 Bronze Expert
    Currently Being Moderated

    Uncheck the selection in the Settings of the Voicemail program regarding the speaker choice.

  • 2. Epic only plays Voice Mail on speaker
    DarkZrobe Regular Visitor
    Currently Being Moderated

    I am also having this problem. I cleared the cache with the program with no luck. Also the setting for the speakerphone was selected as off. I Tried it both enabled and disabled and the voicemails still come out of the back speaker. If you tell the message to go to the speaker it just gets louder. I think this started with the EL30 Update but it may have been earlier. I would prefer not to reset the entire device.

  • 3. Re: Epic only plays Voice Mail on speaker
    qcs2u Newbie
    Currently Being Moderated

    I am having the same issue with the EL30 Voicemail application (T.5.2.0.24) on the Epic 4G where -- most of the time -- voicemails are only playing back through the speakerphone even though I have the Voicemail Setting -> Speakerphone unchecked (says Speakerphone is automatically off).  When you play the messages, clicking the speakerphone button only causes a click to occur - sometimes the icon changes to the mute icon and sometimes the icon automatically changes back to speakerphone.  Either way, it does not switch the output to the earpiece - it stays in speakerphone mode.  What is strange is that occasionaly when I go in to the Voicemail application, everything will work properly, but most of the time it will only play out of the speakerphone.

     

    This does not happen every time (that is why I said most of the time above).  Once it does starts happening, the Voicemail app stays messed up until I re-boot the phone.  Then things will start working properly again; but not for good. I have tried all kinds of things including killing the app, changing settings and exiting and then coming back in, re-booting and leaving new messages, etc. but I can't replicate the pattern that causes it.  It just happens.

  • 4. Re: Epic only plays Voice Mail on speaker
    KAYLANIK Newbie
    Currently Being Moderated

    I just had to fix this on my husbands Epic...go into voicemail settings and change to speakerphone, save, go back to home, go back in and turn it back off, and save and it will work correctly again...I can't be positive, but I may have done a full shut down and restart in between.  You can also try shutting down, the removing battery and removing the sd card.  Restart with the sd card out.  Completely shut down, put sd card back in, and restart again. 

  • 5. Re: Epic only plays Voice Mail on speaker
    qcs2u Newbie
    Currently Being Moderated

    Thanks for the recommendation, KAYLANIK.  Unfortunately for me, I have tried that and it only works temporarily.  Eventually the voicemail ends up always coming through the speakerphone, regardless of the setting.

  • 6. Re: Epic only plays Voice Mail on speaker
    coasterphotos Bronze Expert
    Currently Being Moderated

    This problem appears to be occuring with the last update to the voicemail app. I had to restore my phone a few days ago and voicemail worked perfectly with the older voicemail version, even after EL30...until the voicemail app updated to the latest version.

  • 7. Re: Epic only plays Voice Mail on speaker
    Texyy Regular Visitor
    Currently Being Moderated

    Mine is playing through speaker as well. I have done everything I have read to do, and it is still doing it. I do not believe when an upgrade is sent out to your phones, you should have to do a "full restore" or any other major things with your phoine in order for it to work. I can't tell you how many things I have had to fix since this upgrade. Seems Everytime i get one problem fixed another one crops up. I want my voicemail off speaker, and it is not checked off under the settings either.

  • 8. Re: Epic only plays Voice Mail on speaker
    coasterphotos Bronze Expert
    Currently Being Moderated

    Texyy wrote:

     

    Mine is playing through speaker as well. I have done everything I have read to do, and it is still doing it. I do not believe when an upgrade is sent out to your phones, you should have to do a "full restore" or any other major things with your phoine in order for it to work. I can't tell you how many things I have had to fix since this upgrade. Seems Everytime i get one problem fixed another one crops up. I want my voicemail off speaker, and it is not checked off under the settings either.


     

    Read what I posted above what you just posted...

  • 9. Re: Epic only plays Voice Mail on speaker
    Texyy Regular Visitor
    Currently Being Moderated

    So your saying I need to "restore" the phone?

  • 10. Re: Epic only plays Voice Mail on speaker
    coasterphotos Bronze Expert
    Currently Being Moderated

    No, what I'm saying is that it is most likely the voicemail app causing the problem, not the EL30 update.

     

     

    If you want to see if the voicemail app is causing your problem, go to manage applications, select the all tab, find the Voicemail app and it is probably version T.5.2.0.24. Tell it to uninstall updates and it will go back to the previous version (the version before they added the ability to restore deleted voicemails and to be able to save them to sd card). See if the problem is fixed. If it is, then it was nothing to do with the EL30 update, but the voicemail app which came out around the same time

  • 11. Re: Epic only plays Voice Mail on speaker
    Firehawk_1066 Valued Member
    Currently Being Moderated

    My Epic is also having the same issue.  I tried KAYLANIK's suggestion and while it did seem to work at first it only lasted a day or two and now its back to only playing voicemail through the rear speaker. Toggling the button which is supposed to switch between ear speaker and loud speaker does nothing and voicemails play only through the rear loudspeaker. 

     

    I tried coasterphotos's suggestion but nothing changed, same problem.


    Sprint, please look ingo tthis asap.  I cannot check voicemails anywhere in public or at work because then everyone will hear my messages.  I have zero privacy right now and it is terribly inconvenient. 

  • 12. Re: Epic only plays Voice Mail on speaker
    Texyy Regular Visitor
    Currently Being Moderated

    You do not have to do a restore. It is very easy (trust me If I can do it, you can do it) Under Voicemail where you have comments you can send to someone calling in that says "in a meeting" "Out of the office" etc.... You need to delete those and the speaker issue will stop.

  • 13. Re: Epic only plays Voice Mail on speaker
    DefZenMaster Regular Visitor
    Currently Being Moderated

    As strange as it sounds, I fixed mine by changing the incoming call ringtone. Not the voicemail notification, but the main incoming call ringtone.

     

    Discovered this accidentally when I downloaded a new ringtone and the voicemail out of speaker problem ceased.

     

    I don't know if just changing the ringtone to another stock one will do it, or if all of them were corrupted by the EL30 update (that's when my problem started), because like I said, I downloaded a completely new one off the internet and all is well now.

  • 14. Re: Epic only plays Voice Mail on speaker
    DarkZrobe Regular Visitor
    Currently Being Moderated

    Still cant get mine fixed. Anyone from spring have any suggestions? Or is this not a problem but a "feature"...

More Like This

  • Retrieving data ...