14 Replies Latest reply: May 24, 2013 10:59 AM by MarkC50 RSS

WI-FI Keeps turning itself on

tucsonarizona Regular Visitor
Currently Being Moderated

Has anybody else noticed that with Wi-Fi turned off, it turns itself back on after a while? I have gone into the advanced wi-fi settings and checked the "keep wi-fi on during sleep ONLY when plugged in" but the problem still occurs (with the phone unplugged).

 

As some of you have probably noticed ..even with ECO mode turned on, the battery life is not that great and its crucial that everything unecessary is turned off

  • 1. Re: WI-FI Keeps turning itself on
    Sprint Employee
    Currently Being Moderated

    Go to setting-wireless and networks-mobile networks  .. automatic connections...should be right in there somewhere and have an option to check or uncheck it.

     

    Larry ~ OKIESTRO

     

    Sprint Social Care Team

    Oklahoma City

    Hours Monday- Friday 6am - 3pm

    https://network.sprint.com/   THE SPRINT NETWORK OF THE FUTURE IS UNDER WAY

  • 2. Re: WI-FI Keeps turning itself on
    jmorris2208 Regular Visitor
    Currently Being Moderated

    Yes, I have noticed this happening several times in the past month, but not in the past week. I don't think it had anything to do with my settings, which I had not changed.

  • 3. Re: WI-FI Keeps turning itself on
    tucsonarizona Regular Visitor
    Currently Being Moderated

    Ok, I think I have the culprit .."Connections Optimizer" under Mobile Networks. For some reason, Sprint in its infinite wisdom thought it was a good idea to continously scan for open wi-fi networks..even after the user turns wi-fi off??????

     

    Now the problem is, even after I disable this useless option, it still shows under my Running Apps....!

  • 4. Re: WI-FI Keeps turning itself on
    _DePaul Social Care
    Currently Being Moderated

    Hi tucsonarizona,

     

    I understand that you are having an issue Wifi turning itself on. I believe that may be due to the Sprint Wifi Optimizer. Your phone will automatically detect and connect you to Wifi. This is an option on your device because when your phone is connected to Wifi it helps to conserve battery life. You can modify this specific setting by completing the following steps: Press MENU>>SETTINGS>>MOBILE NETWORK>>CONNECTION OPTIMIZER and choose to disable the Sprint Connection Optimizer.

     

    Please let me know if this helped.

     

    Thanks for your Community Post.

     

    Yahkie W.

    Social Media Care

  • 5. Re: WI-FI Keeps turning itself on
    tucsonarizona Regular Visitor
    Currently Being Moderated

    Yahkie- I had already noticed that, but thanks for your quick response.

     

    However, it does not seem that this app can be disabled even after unchecking its enabling box. I have unchecked the box, restarted the phone and lo- the app is still under my running apps.

     

    I did a little test to see if the option can REALLY be disabled. I unchecked the option, went back and clicked on Connections Optimizer, got presented with legal terms and with options to agree or more information- ignored both and clicked back..and what do you know...the option somehow got checked again!!!!

     

    Now the legal terms mention of information being relayed back to Sprint, and I am wondering if somehow this is why I cannot apparently be able to disable this even though Sprint says otherwise...

     

    Could other users please confirm this issue?

  • 6. Re: WI-FI Keeps turning itself on
    _DePaul Social Care
    Currently Being Moderated

    tucsonarizona,

     

    I noticed the same issue occurring on my device as well. After you have selected Turing off the Sprint Wifi Optimizer, you may still have to go into  your Wifi settings, and make sure you've turned Wifi off. While you are in Sprint Wifi Optimizer, please make sure the check box to the the right, is unchecked. Confirm that Wifi is turned off by simply going to MENU>>SETTINGS>>WIFI>>OFF. Once Wifi is completely turned off, check your device settings throughout the day to ensure that remains off.

     

    Thank you,

     

    Yahkie W.

    Social Media Care

  • 7. Re: WI-FI Keeps turning itself on
    tucsonarizona Regular Visitor
    Currently Being Moderated

    Yahkie-

     

    The issue is not with the wi-fi being completely off (which I had turned off btw..hence the frustration with this optimizer nonsense that turns it on back again)- its with this connections optimizer that miraculously keeps turning itself back on..it still shows under my running apps, and is still checked even after I uncheck and reboot the phone..anyway I can uninstall it?

  • 8. Re: WI-FI Keeps turning itself on
    _DePaul Social Care
    Currently Being Moderated

    tucsonarizona,

    I totally understand your concern. I just checked on my device, and although Wifi is turned off, the Optimizer is still running in the Applications Manager. This program will continue to run on your device, and unfortunately it is not able to be uninstalled.

    Thank You

    Yahkie W.

    Social Media Care

  • 9. Re: WI-FI Keeps turning itself on
    tucsonarizona Regular Visitor
    Currently Being Moderated

    So we have a useless app that we do not need, and apparently cannot disable either, and eating up the battery from the background.

     

    Another forum user here had posted concerns about the Android OS consumption being a little higher than normal, I think I know why now. So Sprint advertises a phone with a large battery capacity, then for some reason decide to sabotage the very same capacity by forcing on us features that I really cannot see how they are useful expect to Sprint for its information gathering...

  • 10. Re: WI-FI Keeps turning itself on
    YCHO1979 Regular Visitor
    Currently Being Moderated

    It's not just sprint it's the actual OS. For some reason Google allows third parties like Samsung, LG, and a host of others to add bloatware and useless apps that hog memory and eat battery life.  Just turn the Connection optimizer off.  I find this annoying too.  That is why I was a little disappointed when the Nexus 4 (uses the pure untouched version of JellyBean 4.2), which is made by LG, is only available for T-mobile.  I assumed because the original Nexus was available to Sprint that it would carry on with the Nexus 4 which is basically the Optimus G with JellyBean 4.2 but without 4G lte, 13mp camera, 32GB of storage and all of the bloatware.  I sent my Optimus G back to wirefly.com and am waiting for my replacement. Hopefully my battery issue and rebooting will not be present in my replacement. I'm thinking that we got a bad batch of phones since there are not of user complaints or maybe people think this is what is normal for this phone and if it is then I guess we are stuck with this issue for another two years or until they patch it with an update. To be honest, I like the simplicity of my HTC EVO 4G but my only two complaints is the processor speed and battery life of my old EVO. Hopefully they fix this issue when the update for JellyBean comes out next month or when ever they decide to send out the update. Just know that there are other people out there that are experiencing the same issue as you.

  • 11. Re: WI-FI Keeps turning itself on
    cezeOne Product Ambassador
    Currently Being Moderated

    I force stopped the app and have no issues with it. Even after a reboot. Hopefully this will help you out. I just got my phone yesterday so I can't make any judgements on battery quite yet.

  • 12. Re: WI-FI Keeps turning itself on
    NYHusker Regular Visitor
    Currently Being Moderated

    If you are rooted, use Titanium Backup to backup Sprint Connections Optimizer and then, after backup complete, uninstall it.  That's what I did!

  • 13. Re: WI-FI Keeps turning itself on
    Sonadora17 Newbie
    Currently Being Moderated

    Yes, I have a similar issue.  First off it irks me that I get sold "unlimited data" and there's an app on the phone that does whatever it can to keep me off the data network I'm paying for.  Secondly, the connections optimizer consistently interrupts what I'm doing and pops up some sort of useless error screen saying something is blocked or some sort of wifi sign in screen when I'm not interested in using wifi.  At first I thought that I would be able to change the settings in the optimizer app to at least asking me if I'd like to connect before popping up the screen but apparently it only turns on and "off".  Being interrupted like that is extremely annoying!!

  • 14. Re: WI-FI Keeps turning itself on
    MarkC50 Regular Visitor
    Currently Being Moderated

    My phone has a check box under WiFi settings that says something like "Notify me when launching apps if WiFi is available."  I leave this unchecked and don't get notified.  The "Optimize Wifi usage" item in the Settings has a couple of check boxes too (if you tap it) that can uncheck if you don't want to use Wifi by default for known networks if it's turned off or for downloading large files.