2 Replies Latest reply: Dec 16, 2012 9:59 PM by blakebaa RSS

Moto Photon call/text issues

ASHLEY_9005 Newbie
Currently Being Moderated

My Moto Photon is not receiving calls or texts in a timely manner.  I have talked to multiple tech support people, supervisors and Sprint Cares representatives. They don't care. People cannot get in touch with me as my phone does not even ring and I receive texts days later. It is absolutely ridiculous that we are paying for a service that we are not receiving. I have had 2 replacement phones with no help. I am told that everything is great in my area and they cannot see problems on their end. I am TIRED of the text not sent red x and having to take my battery out and 3-5 times a day to see if I have missed something important. I keep getting credits and "It's not our problem." I tried to get out of my contract and they said it would be the full $350 which I think is RIDICULOUS. I have lost all faith in Sprint and would not recommend their services to anyone. They simply don't care about us.  Has anyone been able to get a solution for this?  I saw a forum on here where several of you were experiencing this same issue.  It would not let me post this in that chat. 

  • 1. Re: Moto Photon call/text issues
    MiaAMontana8973 Newbie
    Currently Being Moderated

    I'm having the exact same problem! I had to use my neighbors phone two weeks ago to call 911 for a man in my backyard. They don't care and all I ever get is a call back, that I miss, and they just say "ok we'll keep the ticket open." They haven't so much as waived my bill or even a discount even though I' cant use the service I pay for. I'm ready to leave sprint after 8yrs. I also have a Photon. I just posted a dicussion BTW

  • 2. Re: Moto Photon call/text issues
    blakebaa Regular Visitor
    Currently Being Moderated

    I have had this problem with my Photon before as well, and the only thing that fixed it we restarting it. If that doesnt work, follow these steps:

     

    1. Go to: Settings<Wireless networks<Mobile network settings<Network mode< and make sure it is on "Any CDMA"

    2. If that doesn't work, go to: Battery and data manager<Battery mode< and select "Performance mode"

    3. If THAT doesn't work, go to: Location and security settings and check "Use wireless networks"

More Like This

  • Retrieving data ...

Legend

  • Correct Answers - 4 points
  • Helpful Answers - 2 points