This discussion is archived
1 2 3 4 Previous Next 46 Replies Latest reply: Apr 7, 2012 3:45 PM by Shane_M RSS

4.67.651.3 Broke Evo 4G Wifi

sharies79 Regular Visitor
Currently Being Moderated

It will connect to wireless router but then hang at obtaining an ip address and eventually error out and keep trying over and over again. If I Restart the router it will work for a little while then eventually go back to constantly connecting and trying to obtain ip address. Has done this on 2 different routers. It can't be the routers because it worked fine before the update.

 

SO when are they releasing an update to fix this update? Or is there a way to go back to the previous version?

  • 1. 4.67.651.3 Broke Evo 4G Wifi
    lilgeekygirl Bronze Expert
    Currently Being Moderated

    sharies79, I'm sorry for any inconvience and fustration this may be causing you. Have you tried a factory reset on your device? A factory reset will erase all information store to the device anything stored to the memory card will be saved. Usually a factory reset will fix any bugs a software update creates but does not remove the update from the device, there is no way to revert back to a previous version. If you wish to perform the reset here are the steps

    1. From the Home screen tap Menu

    2. Go to Settings then tap SD & Phone Storage

    3. Tap Factory Data Reset and then tap Reset Phone

    4. On the following screen tap Erase Everything to confirm your action

    1. With the device turned off, press and hold the Volume Down button (located at the right panel of the device), and then press the Power button

    2. When the device’s display turns on, release the Volume Down button

    3. Use the Volume buttons to select CLEAR STORAGE, and then press the Power button. (All data will be deleted from the device.)

    1. From the Home screen tap Menu
    2. Go to Settings then tap SD & Phone Storage
    3. Tap Factory Data Reset and then tap Reset Phone
    4. On the following screen tap Erase Everything to confirm your action

    or

    1. With the device turned off, press and hold the Volume Down button (located at the right panel of the device), and then press the Power button
    2. When the device’s display turns on, release the Volume Down button
    3. Use the Volume buttons to select CLEAR STORAGE, and then press the Power button. (All data will be deleted from the device.)

    If you would like to back up your contacts, go to your contacts press the menu key select import/export and export to sd card then phone. If you do not feel comfortable performing these steps or if it does not correct your issue please visit a Local Sprint services and repair store. You can locate one by following this link www.sprint.com/storelocator

  • 2. 4.67.651.3 Broke Evo 4G Wifi
    lilgeekygirl Bronze Expert
    Currently Being Moderated

    Have you deleted and readded the wireless connection?

  • 3. 4.67.651.3 Broke Evo 4G Wifi
    sharies79 Regular Visitor
    Currently Being Moderated

    Yep tried that. Also tried different types of encryption wpa wep etc..

  • 4. 4.67.651.3 Broke Evo 4G Wifi
    fireguy_6364 Master
    Currently Being Moderated

    to be honest this is only the second time i have heard of anyone having this issue. aside from that no problems so far. the factory reset should be your last resort..especially since it deletes ALL your information and takes you back to factory settings on your phone.

  • 5. 4.67.651.3 Broke Evo 4G Wifi
    sharies79 Regular Visitor
    Currently Being Moderated

    A hard reset did not fix the problem.

  • 6. 4.67.651.3 Broke Evo 4G Wifi
    JKEARNS97062 Newbie
    Currently Being Moderated

    You are not the only one. Just installed it and it broke it for me.

  • 7. 4.67.651.3 Broke Evo 4G Wifi
    glimothy Newbie
    Currently Being Moderated

    ive done everything from standard battery pull to hard reset w/ going into bootloader and clear storage... im not rooted. and still stupid wifi will disconect every 2-3 minutes. really annoying.

  • 8. 4.67.651.3 Broke Evo 4G Wifi
    MrClarenceCat Newbie
    Currently Being Moderated

    You are not the only one.  While it is not common, there are several other people having the same issue (including me).  Factory setting is apparently not working and this is not a router issue as I was having issues at my friend's house.

  • 9. 4.67.651.3 Broke Evo 4G Wifi
    sharies79 Regular Visitor
    Currently Being Moderated

    Took the phone to Best Buy. Apparently it is a known issue. The only work around fix is to go into wireless settings then under advanced set it to use static ip, without fililng out any of the ip or other info under it. Which seems to have worked, for now.

  • 10. 4.67.651.3 Broke Evo 4G Wifi
    MrClarenceCat Newbie
    Currently Being Moderated

    Thank you sharies79!!!  I called Sprint and took my phone to the Sprint store - and both said that they had never heard of this issue but it was probably a HTC issue.  I would have to wait until HTC issued a revised update (which will never happen as the Evo4G was just added to the HTC EOL list).

    I am glad you and your Best Buy people at least found a work around.

  • 11. 4.67.651.3 Broke Evo 4G Wifi
    c_h Newbie
    Currently Being Moderated

    Getting odd issues as well.  Local tower is flaking out, and called Sprint Cust Care to report it.   In the process they requested me to pull battery and try Update Profile.  It never connects.  They asked what software version.  I told them 4.67.651.3 and she said I would need to talk to her supervisor and ... I've now been on hold for over 1 hour.  Phone unable to text, data, or make calls.  Now Saying temporarily disconnected.... ugh.

  • 12. 4.67.651.3 Broke Evo 4G Wifi
    glimothy Newbie
    Currently Being Moderated

    I tried making the ip static, but still drops every 2-3 min.... called sprint and trying to see if since it is a software issue, if they will replace device with 3d... its worked in the past

  • 13. 4.67.651.3 Broke Evo 4G Wifi
    sharies79 Regular Visitor
    Currently Being Moderated

    Mine runs in G and N modes

  • 14. 4.67.651.3 Broke Evo 4G Wifi
    sharies79 Regular Visitor
    Currently Being Moderated

    I was also playing around with my router because the dropping every 2-3mins came back even with static ip. My router is a wireless n and under it's wireless setting I can have it broadcast in 20/40hz or just 20hz. When I had 20/40 hz on it would do the dropping then unable to get an IP on reconnect, when I switched it to 20hz it would obtain IP. It still seems to look for ip often but it's obtaining it now.

1 2 3 4 Previous Next

More Like This

  • Retrieving data ...