This discussion is archived
7 Replies Latest reply: Aug 25, 2012 3:39 PM by 14KNIGHT RSS

"Account not authorized to make calls"!!!!!

K_Cameron94 Newbie
Currently Being Moderated

This morning, my iphone 4s was working perfectly (was texting, making calls, using the web browser, blah blah). But at around 11 am, when I was trying to text a friend, none of the messages were being delievered. So I just shrugged it off, and tried to call instead. But the problem is whenever I try to make a call, it rings for a couple of seconds and then I keep getting this recorded message "your account is not authorized to make calls to this phone number. If you would like to have additional capabilities added to your account.....". And this happens whenever I call ANY number. I've tried to get through to customer service, but couldn't. Now I'm really stressing out and would like to have this problem fixed since I go away to college in TWO days. What can I do to fixed this issue?? Please help!!! Any help would be greatly appreciated.

More Like This

  • Retrieving data ...


  • Correct Answers - 4 points
  • Helpful Answers - 2 points