cancel
Showing results for 
Search instead for 
Did you mean: 

Evo 4G email setup

Patron

Evo 4G email setup

First, I apologize if this is a repeated declaration that so many others have made in the past weeks but first hand, I can attest to how frigging awesome the Evo 4G is turning out to be.  It's absolutely amazing how many gadgets and cool customization choices there are on this thing.

The only problem I'm having is minimal (aside from leaving the Sprint store without full connectivity to the internet confirmed due to the system backlog the entire network experienced), is not being able to get the email server to communicate with the hand held device.  (By the way, the connectivity issue was resolved within an hour after I got home from the store.  I put the device on the wall charger and a pop-up appeared asking me to allow a system download due to a new version of something being detected so I allowed the download, allowed the system to reset and voila!  The 3G symbol popped up and I was ready to go!)  It's worked fine since then.

Here are the settings and since I've set up four hand held devices in a similar manner, I'm pretty sure I'm doing the correct steps.  It's rather simple but I must be missing something.

POP (Incoming settings)

Username <mine>

Password <mine>

POP Server:  comcast.net

Security Type:  SSL

Port:  (a number the system filled in for me)

A warning pops up at the end after Verifying accoung information...  It says:

Warning

Cannot connect to the mail server to verify your account information.  Your server is not responding.

So I changed my Server Timeout setting on my Outlook account on the computer, from 1:30 to 3:00 and the warning still pops up.

Does anyone know what's going on?  I hope I'm missing something really simple.  Thanks in advance.

**** UPDATED June 6th, 2010:  After I followed the instructions Levi4u posted and was able to get one of my 3 POP email accounts to work, I forgot to mention that the steps have to be taken from the very beginning without using the 'back' command to make changes to the data entry fields.  Something happens to the device where the circular animated icon that indicates communication is happening between the device and the server where the icon doesn't animate.  When I first tried Levi4u's suggestion, it didn't work but the animated icon wasn't animating.  I started over again from scratch and entered all information, first time through and when the animated icon animated, that's when I got the email setup to work.  I can send and receive now from my comcast account.

Message was edited by: sbutler210

16 REPLIES
Sprint Product Ambassador

Re: Evo 4G email setup

Enter mail.comcast.net as the Incoming Server and smtp.comcast.net as the Outgoing Server.

See if that works...

More mail setup help at:

http://customer.comcast.com/Pages/FAQListViewer.aspx?topic=Internet&folder=ddba9bd7-b0bb-4b4f-9cee-6ebf83b77523

Product Ambassador, long time Sprint employee
Highlighted
Patron

Re: Evo 4G email setup

Hello, thanks for the suggestion.  The setup screen doesn't have Incoming and Outgoing fields.  It has a label at the top of the data entry area and I guess I'd call it a header label for the entry screen where I typed exactly what you see in my original post.  I would have expected and Incoming and Outgoing entry area but there's only one of them which says Outgoing so I tried the combinations with and without the 'smtp' letters before the 'comcast.net' piece of the entry fields and the same error occurs.  I haven't tried it again today.  I'm wondering if maybe Comcast was having a quirky day.  It happens sometimes with Comcast.

I'll post if I get the setup to work.  I should say, 'when' I get it to work.  I'm going to keep at it until I do.

Thanks again!

Journeyman

Re: Evo 4G email setup

I'm having the same problem.  I left the store unable to set up my comcast.net e-mail account.  They told me there is a problem with the Hero and the EVO not being able to connect to Comcast.  If this persists, I may have to take the phone back.  What's the point of all the bells and whistles if I can't do something as simple as access my e-mail?????

--J.

Master

Re: Evo 4G email setup

Starting from the begening, From the

"Choose a Mail Provider" screen choose "Other(POP/IMAP)

"New Account" screen enter your email add and password, Click Next.

"Incoming Settings" screen, Go down to the "POP server" box and enter pop.comcast.net, Click Next

"Outgoing Server Settings" screen, Go down to "SMTP server" box and enter smtp.comcast.net, Click Next

"New Account" screen, Check "Make This My Default" if you wish, Finish set up.

Master

Re: Evo 4G email setup

The correct settings for Comcast are

Incoming POP

server: mail.comcast.net

SSL enabled

Default port (can't remember the number)

Outgoing SMTP

server: smtp.comcast.net

SSL enabled

Default port (again can't remember the number)

The username is going to be the first part of your email address before the @ symbol.

The password is your regular email password.

I haven't had any issues with these settings for years on multiple phones, Windows Mobile, WebOS and Android.

Patron

Re: Evo 4G email setup

Levi4u - I tried your suggestion and filled in the fields like this and it worked!

email settings:

POP (Incoming)

Username <mine>

Password  <mine>

POP Server:  pop.comcast.net

Security Type:  SSL

Port:   (a number the system filled in for me)

I hit <continue> then a second data entry window popped up that looked similar but it was for Outgoing, not Incoming so I filled in 'smtp.comcast.net' and hit <continue>.  There was an indication that the phone and server were communicating via 3G for about 15-20 seconds and voila!!  It worked!  I can both send and receive emails now with my primary comcast email address.

All other hand held devices I've done this with didn't use 'pop.comcast.net' it was instead, 'mailhost.comcast.net' and I have to admit I was a little skeptical that it would work but I tried your suggestion anyway and I'm so glad I did.  Thanks!!

I've got 2 other email accounts with Comcast but I'm having a difficult time with those.  I think it's becuase I don't have the correct password.  We'll see.

When I loaded the shortcut onto one of my personalized screens, the shortcut name changed to my comcaast UserID.  It's easy to tell which icon to go to now.  That's a neat feature I didn't expect, though I wonder if there's a way to rename these.  Perhaps a question for another thread.

Thanks again!

Edited Sunday June 6th - I am now fully up and running with my 3 Comcast email accounts thanks to a fellow Sprint user.  The only problem I had other than having to use the word 'pop' in place of 'mailhost' for the server setup is remembering my passwords which are automatically entered in my Outlook setting when I use Outlook on my computer.  I didn't write them down anywhere but after a few hours of trial an error, I remembered what my password was and voila!  The last account is now set up!

Now on to figuring out bookmarks...  I'm not sure how to rate this thread for question answered but I'd like this one to be marked DONE with a happy face!

Message was edited by: sbutler210

Patron

Re: Evo 4G email setup

halcyoncmdr117 - thanks for your suggestion.  What you've described is how I had previously set up email accounts on both hand held devices and computers and it's the reason I was so puzzled on why it wasn't working.  The kicker in the case of the EVO is that you have to replace 'mail' in the server address, with the word 'pop'.  I think the programmers messed this one up since it doesn't follow the standards we've used before but I guess that goes to show how some things just aren't 'standard'.  Thanks for taking time to make your suggestion!  Your suggestion works on most devices but not the Evo 4g unfortunately.

Journeyman

Re: Evo 4G email setup

Thanks. Worked great.

Patron

Re: Evo 4G email setup

This forum is great!  I'm glad it helped you figure out how to get email working.  I'd probably still be fumbling around with it.  I wouldn't have thought of using 'pop' in the server field.

Journeyman

Re: Evo 4G email setup

Grrr. I've tried everything posted here, and everything posted for the same issue with moto droid without success. Does anyone know what the problem is between Android and Comcast? It's there some server setting on the Comcast side that gums up the works?  I'm able to configure other POP3 mail providers with no problem at all. I've tethered the phone to my laptop and am able to send/receive from Comcast's POP/SMTP servers without issue - so, I think I can rule out any network "weirdness" between Sprint and Comcast...

I am new to Android, and I like it alot - more than the OS, I like the Evo. If it were not for these two things, I'd call this a deal-breaker and find another phone. I do not want to use push/forward from Gmail. That's a pain and shouldn't be necessary.

Patron

Re: Evo 4G email setup

rshelton1973:  Did you get your email setup working?  If you didn't, then you might want to make sure you went to the POP setup and not the Exchange setup - the input screens look different.

Also, I had a problem with 2 of my 3 Comcast accounts - the problem was that I was using the wrong password.  Double check your password.  Once I had the correct password, the instructions I wrote above worked immediately.

This is the entry that is different from the way you've set up other devices in the past.  If you don't use 'pop' in place of 'smtp', it won't work.  It's pretty irritating actually since the people who wrote the code didn't follow the norm.  I won't go so far as to call it a standard but other hand held devices use 'smtp' which several of us expected to do with the setup on the EVO.

POP Server:  pop.comcast.net

Message was edited by: sbutler210

Community News

This is a PUBLIC ARCHIVE board, all artciles are read only.

Please click here to search the Active Community.