cancel
Showing results for 
Search instead for 
Did you mean: 

OS5 needed for Bridge, required for using my Blackberry phone with the Playbook

Highlighted
Journeyman

OS5 needed for Bridge, required for using my Blackberry phone with the Playbook

Hey Sprint,

I see that all of the other carriers that still sell (and support) the Blackberry 8300 series have released an OS5 upgrade for their phones. You have not. I realize that you are the last carrier to release an update for whatever reason, but it has been over a year. Plenty of time for you to quality check and tweak the OS for us loyal Sprint customers. Now that the Playbook is being released, it would be a perfect time to put on the cape and save the day for us 8330 users that NEED OS5 to install Blackberry Bridge to make use of the email, contacts, calender, etc on our new devices. Please, pretty please tell me that you're ready to release an operating system with your seal of approval on it so that I don't have to buy a NEW phone or switch to a NEW carrier. That would be wonderful.

Yours truly,

Jason

A Loyal Sprint (Premiere) customer.

2 REPLIES 2
Journeyman

Re: OS5 needed for Bridge, required for using my Blackberry phone with the Playbook

As far as I know, the big four US carriers have not issued a single official OS 5 update for any 83xx device apart from Sprint with the 8350i.  The reason is linked to each device's specs; the 8300, -10, and -20, have just 64 MB of on-device RAM, while the 8330 has 96 MB; and the 8350i has 128 MB.  Even a barebone OS5 footprint would take something like 85 MB, gobbling the earlier Curves and leaving just 11 MB for scratch on the 8330.  The 8350i is also the only model currently in production, in part because of its status with Nextel as the brand's only BlackBerry device. 

As near as I can tell, the 8350i is Nextel's most capable device based on features and OS.  The Moto i1 may have access to more apps, but its lack of a real OS upgrade from Android 1.5 limits that range of apps. 

In almost all other cases but Nextel's, the 85xx has supplanted its 83xx counterpart and should be considered in lieu of the 83xx.

Nate

Journeyman

Re: OS5 needed for Bridge, required for using my Blackberry phone with the Playbook

What I don't understand is why RIM would release an OS update for the 8330 and none of the carriers (save Boost Mobile) officially support it. It is an official update from the manufacturer of the device, so why not let the people using the devices decide. I can't even get the Boost Mobile version to install through the new apploader. (yes, I've deleted the vendor.xml)

Community News

Sprint S.M.A.R.T Agents
Sprint S.M.A.R.T Agent are here to help Monday through Sunday 6:00 AM CT - 6:00 PM CT. If you need to speak to an agent outside of these hours, please visit Sprint Chat