cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to update apps and YouTube doesn't work at all

Journeyman

Unable to update apps and YouTube doesn't work at all

I've tried looking on this and many other forums to find out how to fix these issues to no avail. This has been an ongoing issue since before the Jellybean update. I thought the update might fix the isue. I tried resetting the phone back to factory settings. No dice. I removed and added my account. That worked for two days and then I was back to square one. I am beyond frustrated. Any help that can be provided would most certainly be appreciated. I'm sure more detail would help. The error that I get for the apps is "App" could not be downloaded due to an error. (495). For YouTube I get "Connection to server lost Touch to retry".

8 REPLIES 8
Journeyman

Re: Unable to update apps and YouTube doesn't work at all

Oh! My device is a Samsung Galaxy S III.

Master

Re: Unable to update apps and YouTube doesn't work at all

Do you have allot of apps installed? How long did you run it in stock form prior to installing the 3rd party apps?

I'm thinking it's a 3rd party app or a combination of 3rd party apps that may be the culprit. Unfortunately, there is only one sure fire way to test, which is to revert back to stock (hard reset) and run it in stock form without 3rd party updates. If it stops working again in that form, then you know it's the phone, however if it continues to function normally then you know it was a 3rd party app or a combination of 3rd party apps.

However, if you have an idea of the last several apps you installed, you could try to uninstall them, see if that helps. Not sure how far back you would need to take it, but uninstall the apps, try the phone. Doesn't work, uninstall some more. This is why sometimes just doing a Hard Reset is easier. 

You could also try booting to Safe Mode, see if that helps as it prevents 3rd party apps from launching during boot.

To boot to Safe Mode, restart your phone. At the first Samsung boot screen, press and hold the Menu button until fully booted. You should see the words Safe Mode in the bottom left corner. Usually to exit, you just reboot the phone.


--
If my post or someone else's answered your question please mark it an Accepted Solution.

Keep in mind, like you, I am a Sprint subscriber. I am in no way employed by Sprint in any sense. I just know stuff.
Journeyman

Re: Unable to update apps and YouTube doesn't work at all

I got the phone when the phine first came out. This started a couple of months ago. When you say hard reset, is that the same as reverting back to factory settings? As I mentioned, I've tried the factory settings several times. I will try safe mode as well. Could I possibly have a virus? Either way, thank you for responding. I do appreciate it.

Re: Unable to update apps and YouTube doesn't work at all

Thank you for coming to us with your issue. I will be happy to help you out with these issues. Please go to your Settings and Manage Apps. Clear the cache on the Google Play app and any other apps that are giving you issues. Let me know how this works out for you.

Thanks,

Ivan

Journeyman

Re: Unable to update apps and YouTube doesn't work at all

Thank you Ivan. Cleared cache and restarted. Problem persists. Any other suggestions?

Journeyman

Re: Unable to update apps and YouTube doesn't work at all

I've also done the same thing.  It happens on EVERY SINGLE one of my Sprint phones, that is 4 phones here at my house.  I don't know if it's related to my newest Airrave 2.5 box I received or not, as I didn't realize until a few days ago that something was wrong.

It only happens when I am connected to my wireless network at home, if I go onto 3G/4G it's fine. My router is same router I have had for 6 months, same internet connection. I even hard reset my router thinking it was something with that, but still nothing.

Here is what I have to do to get it to work, and then it only works until after I reboot my phone or leave my wireless network at home and come back on it. 

I took my phone to another wireless network and it downloads fine with youtube. As soon as I hit my wireless at home, same issue comes up.  I have played with settings and here is what I have to do to make it work:

"forget" network.  Re-add the wireless network back in.  Let it get IP address.  I then go in and edit network settings and change to fixed ip and not using DHCP.  I then change DNS to either the OPENdns servers or Google servers(as listed above). It then works fine. BUT, if I reboot my phone, or if I leave the house(so it disconnects from router), then I come home and re-connect back up, it will not work again!  I then have to manually do as I describe and each time I can get youtube videos to play. Also note that when youtube quits working, I also can't update my google apps in the google play store.  As soon as I change the wireless settings as I describe above, I can then connect to youtube and also google apps will update(and I can download new ones as well).

Journeyman

Re: Unable to update apps and YouTube doesn't work at all

Thanks Craig but mine doesn't work at all with 3G/4G or WiFi.

Journeyman

Re: Unable to update apps and YouTube doesn't work at all

okay some more details.

I had my friend stop by who has a iphone and it's with a different mobile provider.  With him hooked onto my wireless network at home, his youtube app streams videos fine. So I don't know if this is just an issue with Android youtube app/routing issue or it's a Sprint issue(since he is with a different provider).  I am going to see if I can find some others with Android but different providers hook onto my wireless network and see if they have any issues..

Community News

Sprint S.M.A.R.T Agents
Sprint S.M.A.R.T Agent are here to help Monday through Sunday 6:00 AM CT - 6:00 PM CT. If you need to speak to an agent outside of these hours, please visit Sprint Chat