cancel
Showing results for 
Search instead for 
Did you mean: 

Sprint - Incoming Call Disconnect After Answer - Google Voice User

Journeyman

Sprint - Incoming Call Disconnect After Answer - Google Voice User

Thought I would post to keep current information out there and help anyone in my shoes as the last post I found on this was months and years old. Issue - after getting my bright and shiny new Galaxy S8+, I set everything up on the phone and reconnected Google Voice. Everything appeared to be going swimmingly. Calls out? Check. Voicemail? Check. Calls in? Problem. I would get a call into my phone, answer it, and the call would immediately terminate. Did not matter where I was physically, what I was doing at the time, or who was calling. Same behavior every single time. Called Sprint "technical support". After being bounced around to several people and ever increasing levels of tech support capability, I had spent over an hour on the phone and no fix. The Tech eventually said I would need to take the phone into the local Sprint Store to have it examined and fixed or swapped out. I was almost positive this was related to my Google Voice Integration, so I was not happy with that answer and did a lot of digging. Eventually I found that if I messed with a bunch of the settings, things would begin working. Was not sure which settings (in Google Voice) worked, but eventually I hit the right combination and the problem went away. Until this week. Same exact problem. Called Sprint Tech support again, and got an even worse and more worthless experience this time through. Back to the internet. This time I found a post that seemed to fix people with my same problem. Tried it, and *poof* problem resolved. I could change the setting back and recreate the problem and fix it again when reapplying the setting. Here it is for any of you in the same predicament (and it sounds like this affects more people than just those with S8's): Go to Google Voice on the web. Click the three vertical dots on the right side under the message, calls, and voicemail icons. Click Settings. Scroll down to Incoming Call Options and switch them to "On". Problem should be fixed. One person reported that this did not work for them unless they used the Legacy Google Voice Site. If the above does not fix the problem for you, try using the Legacy Google Voice site. To do that, you select Legacy Google Voice underneath settings after clicking the three vertical dots. Once there, you click the Gear icon at the upper right of the screen. Click Settings. Click Calls at the top menu choices. Then make sure the box next to Call Options is checked. (If it is already checked, uncheck it, then recheck it - you will see a message at the top of the screen saying the change was saved). You should be good to go after all of this. Hope this helps you guys who get no help from tech support.
5 REPLIES 5
GrandMaster

Re: Sprint - Incoming Call Disconnect After Answer - Google Voice User

nice snag. this will help a TON of people im sure.
*********************************************************
I like many others come onto this site for assistance and to help others. Marking a reply as helpful or correct helps others with like issues when they try to search the site for assistance. I do not work for Sprint and my suggestions and or opinions are my own. *************************************************************************************************************
Community Manager

Re: Sprint - Incoming Call Disconnect After Answer - Google Voice User


@hshendon wrote:
Here it is for any of you in the same predicament (and it sounds like this affects more people than just those with S8's): Go to Google Voice on the web. Click the three vertical dots on the right side under the message, calls, and voicemail icons. Click Settings. Scroll down to Incoming Call Options and switch them to "On". Problem should be fixed. One person reported that this did not work for them unless they used the Legacy Google Voice Site.
If the above does not fix the problem for you, try using the Legacy Google Voice site. To do that, you select Legacy Google Voice underneath settings after clicking the three vertical dots. Once there, you click the Gear icon at the upper right of the screen. Click Settings. Click Calls at the top menu choices. Then make sure the box next to Call Options is checked. (If it is already checked, uncheck it, then recheck it - you will see a message at the top of the screen saying the change was saved). You should be good to go after all of this. Hope this helps you guys who get no help from tech support.

Just want to be sure I've got the gist here, @hshendon.  Is this what fixed your issue?  Also, did this start occuring before you got your new phone or only after?  Asking so that I can turn this into a Tribal Knowledge Base article which can help others having similar problems.

 


SeaWolf
Sprint Community Manager & Customer Advocate
Captain of the Vicious Cream-puff
I encourage you to post your questions on the community, give Kudos when earned and always mark the correct answer as "Accepted Solution".


Journeyman

Re: Sprint - Incoming Call Disconnect After Answer - Google Voice User

This only happened AFTER I got the new phone.  Not sure why, but I suspect it has something to do with reconnecting Google Voice...

Sprint Social Care

Re: Sprint - Incoming Call Disconnect After Answer - Google Voice User

Good morning hshendon.

Please let us know if the steps provided by seawolf help resolve the issue.  


Juan
Sprint Social Care
Journeyman

Re: Sprint - Incoming Call Disconnect After Answer - Google Voice User

The steps I listed in my post fixed the issue...
Community News

This is a PUBLIC ARCHIVE board, all artciles are read only.

Please click here to search the Active Community.