cancel
Showing results for 
Search instead for 
Did you mean: 

HTC EVO 4G LTE Connection Issues & more......

Highlighted
Journeyman

HTC EVO 4G LTE Connection Issues & more......

I traded in my Blackberry 9650 on Saturday, its been all down hill from there.  When I arrived home the phone immediately lost 3g signal.  We do not have 4g wi-max in our area but the 3g signal has always been good.  My wife has the Samsung Epic and it runs fine.  My Evo immediately started timing out and the signal strength is low.  I ran a PRL update and made sure the 4g option was disabled.  My wife can be three songs into Pandora before my first song finishes buffering.  Web pages load extremely slow or eventually time out.  I took the phone in yesterday and they couldn't explain it.  They told me I may want an Airwave booster.  I told them after 14 years with Sprint I don't believe that is necessary.  I've never needed it before.  Today was the big test, my drive to work.  I say that because I loose the Sprint Network and move to roaming signal a few miles out of town.  It has never been an issue in the 13yrs that I've worked here.  I currently have "No Service" sitting on my screen.  I called technical support and they can't explain it.  I've done everything they recommended.  I think there is a major problem with the LTE phones trying to connect with the 3g network and forget moving onto a roaming signal.  I can't be the only one having this problem.  I will be taking the phone back today as it amounts to a paper weight at the moment.  Very disappointing.  Anyone relate?

72 REPLIES 72
Highlighted
Journeyman
Journeyman

Re: HTC EVO 4G LTE Connection Issues & more......

I had 3g issues with the EVO 4G LTE as well.  My Optimus worked great in my house, but the EVO would barely load a basic web page.  Lot's off connectivity issues with that phone, and it's slow on 3g even when it does connect.

Highlighted
Journeyman

Re: HTC EVO 4G LTE Connection Issues & more......

Went back to the store.  They sent me to a different location. The techs at the other store can't figure it out either.  They said my phone showed a different PRL update then their system showed.  They uninstalled/reinstalled all the network software. I took screen shot of the phone being out of service and when it showed a no 3G message screen. Guy told me to try it one more time.  If it doesn't work he said to take it back to the Longview store. It works well in town, get a few miles out and it quits.  CDMA enabled, 4G off and current PRL installed. If this doesn't work, I'll take it back and try the S3.

Highlighted
GrandMaster

Re: HTC EVO 4G LTE Connection Issues & more......

if it works great in town but quits a few miles out then either the phone is locking onto a single tower and not switching automatically or there is a tower issue in the othe area. if the bad tower is having a issue the phone will search out the better connection...even if its a much further out tower..might be your issue

SECaggies wrote:

Went back to the store.  They sent me to a different location. The techs at the other store can't figure it out either.  They said my phone showed a different PRL update then their system showed.  They uninstalled/reinstalled all the network software. I took screen shot of the phone being out of service and when it showed a no 3G message screen. Guy told me to try it one more time.  If it doesn't work he said to take it back to the Longview store. It works well in town, get a few miles out and it quits.  CDMA enabled, 4G off and current PRL installed. If this doesn't work, I'll take it back and try the S3.

*********************************************************
I like many others come onto this site for assistance and to help others. Marking a reply as helpful or correct helps others with like issues when they try to search the site for assistance. I do not work for Sprint and my suggestions and or opinions are my own. *************************************************************************************************************
Highlighted
Journeyman

Re: HTC EVO 4G LTE Connection Issues & more......

The software reinstall didn't work.  I have no service again today.  Last night, at home, my wife had great network connection with her Samsung Epic.  My EVO LTE would barely open a web page and continued to show a disconnect under the network.  Tech support doesn't have an answer, especially with the Samsung working fine.  Phone going back today.  I'll try the S3 and hope for better results.  Otherwise back to the Blackberry, which I really can't stand but, it works.

Highlighted
Master

Re: HTC EVO 4G LTE Connection Issues & more......

Silly question. By chance did someone remove the cover to install an SD Card at some point? Maybe the antennae's got tweaked.


--
If my post or someone else's answered your question please mark it an Accepted Solution.

Keep in mind, like you, I am a Sprint subscriber. I am in no way employed by Sprint in any sense. I just know stuff.
Highlighted
Sprint Employee

Re: HTC EVO 4G LTE Connection Issues & more......

Hello SECaggies, depending on the Region you use your phone, your account type, the NPA - NXXX of your phne number, and other factors you will have a different PRL than others, this is normal in most parts the most current PRL ends with 87, I would be happy to assist you, please send me a private message. Thank you, Chris

No longer working Community Response.
Highlighted
Journeyman

Re: HTC EVO 4G LTE Connection Issues & more......

I'm having similar issues. I used to get 3G 3-5 bars in my house and now I get zero to 1 bars if it's not roaming. Did the PRL and profile update, same result. I just got the phone today, so I really hope this issue resolves itself via an update before long. It appears that this is a fairly common problem. I wonder if there was a bad batch with some poor antennas or something.

Highlighted
Journeyman

Re: HTC EVO 4G LTE Connection Issues & more......

Well, I must say, I am having very similar issues with cell connectivity as well.  I love the screen, camera, and processor speed on this phone but the data connectivity is a serious issue.  My WiFi connection is flawless, never have had an issue.  Regular 3G CDMA connectivity is very hit or miss.  My Pandora will buffer for like over a minute and then I just give up.  Facebook will not load.  Web pages do not load.  Often I find myself having to completely shut the phone down and then turn back on, or restart it to get connectivity at all.  Sometimes turning airplane mode on for like a minute and then off fixes it.  It's so very frustrating.  I used the EVO LTE in the same places that I have used all of the other Sprint phones that I have had.  Hero, EVO 4G, Nexus S 4G, Motorola Photon, and the Galaxy S2.  I live in Minneapolis and work in downtown Minneapolis and 3G CDMA data connectivity on Sprint has never been an issue till I got this phone.  I updated PRL and profile more than once on this thing.  I have also made sure that the phone is set to CDMA only.  I am worried that there's something going on with the device.  I just don't know.  Works great on WiFi but I did not get a fancy cell phone to use it on WiFi.

So please, any help, tips or ideas are greatly appreciated!  I only have till Friday to return this thing and I really, really don't want to.  Thanks!

Highlighted
Journeyman

Re: HTC EVO 4G LTE Connection Issues & more......

I just finished returning the phone.  You can tell by my profile that I don't post often. After 14yrs with Sprint, this was my worst upgrade experience ever.  I understand the product is new, however, that doesn't excuse Sprint from having not educated employees about the phone.  I spent 3 1/2 days trying to get this fixed. I went to the Longview store multiple times and finally ended up in Tyler so I get a technician.  Not only did I follow all instructions, Sprint employees handled the phone multiple times running updates, reinstalling software etc.  The kicker in all of this? Upon returning the phone tonight they actually told me it wasn't capable of ROAMING!  I started laughing out load.  I told them no one at Sprint knew what they were doing. It doesn't matter if you go online, in the store or call technical support.  After he said that I pressed them further and they admitted several phones had been returned since Saturday.  I'm telling you it doesn't matter how many PRL or software updates you do, the phone will not work any better.  I've had everything under the sun done to mine.  Sprint has a big problem IMO, whether they know or will admit it.  Chris I appreciate the offer for help, however, I don't think I could stand anymore help from Sprint. Bad experience, for sure.

Highlighted
Journeyman

Re: HTC EVO 4G LTE Connection Issues & more......

Sorry I'm a little frustrated.  Let me add one thing.  Obviously you have 14 days to return the phone.  Since no one is sure what's wrong, very few people will be able to hold out waiting for a patch.  In my case it was easy, I had no service from my house all the way to the office.  The few times it was connected at home, the 3G connection speed was .04/Kbps!  As I reminded each Sprint employee my wife's Samsung Epic was working just fine.  They didn't have an answer after that. Oh well, perhaps the S3 will work properly.  Good luck everyone.

Highlighted
Sprint Employee

Re: HTC EVO 4G LTE Connection Issues & more......

I was hoping that we could work through this together, But I understand where you're coming from. I agree that it really has more to do with which PRL version you have, not as many times as it's been updated. our billing system, and a few other governing forces determine which PRL is loaded into your phone when you update PRL from system updates. I feel this may be pertinent to discovering the reason for the problem. Usually in this situation, especially during the introduction of a new phone reports like this are taken very seriously, we would normally send something like this back to developers to try to duplicate or work through, I'm sorry for the trouble, please let me know if I can help in any other way. Thank you, Chris.

No longer working Community Response.
Community News

Our Community is BACK!!
Hours of Operations are 7AM - 8PM CST. Please try Searching the Community, we have many questions already answered, you can also check out the Knowledge base
If you need immediate assistance after hours please visit Sprint Chat