cancel
Showing results for 
Search instead for 
Did you mean: 

My HTC EVO 4G LTE is slow to load texts, send texts or load phone book or phone history, any one knows a fix?

Highlighted
Journeyman

My HTC EVO 4G LTE is slow to load texts, send texts or load phone book or phone history, any one knows a fix?

My HTC EVO 4G LTE is slow to load texts, send texts or load phone book or phone history, any one knows a fix? I have had this phone for about a year and it should not be this slow... it can take up to a minute sometimes for the phone to open a text or load my phone book or phone history. other application run pretty fast...

5 REPLIES 5
Highlighted

Arash135,

Hey there! It sounds like you maybe running low on memory. This can cause the device to slow down. Have you tried deleting all of your text messages and removing apps that you no longer use?

-William

Highlighted
Master

Or set it to delete the oldest messages. Default when initialized is to keep the last 200 SMS and 20 MMS per sender based on a FIFO system. Helps allot.


--
If my post or someone else's answered your question please mark it an Accepted Solution.

Keep in mind, like you, I am a Sprint subscriber. I am in no way employed by Sprint in any sense. I just know stuff.
Highlighted
Journeyman

Arash135 wrote:

My HTC EVO 4G LTE is slow to load texts, send texts or load phone book or phone history, any one knows a fix? I have had this phone for about a year and it should not be this slow... it can take up to a minute sometimes for the phone to open a text or load my phone book or phone history. other application run pretty fast...

I was having this same issue but did not accrue till after I downloaded the 2.13.651.1 OTA update now that I completed the 3.15.651.16 OTA update the issue is resolved.

Highlighted
Journeyman

My experience was very much like yours, jimmbbo. In fact, I started a thread on the subject of slow loading and was able to get the problem reduced somewhat by junking several of my third-party apps (Chomp SMS and DW Contacts/Dialer) and using the stock apps. But I never got the loading speeds that I had when I first got the phone. The recent Jelly Bean update seems to have solved the problem. I have even been able to restore the third-party apps.

Highlighted
Journeyman

Did you update to the Jelly Bean (4.1) yet? I was having the same issue and that did the trick for me.

Community News

Our Community is BACK!!
Hours of Operations are 7AM - 8PM CST. Please try Searching the Community, we have many questions already answered, you can also check out the Knowledge base
If you need immediate assistance after hours please visit Sprint Chat