cancel
Showing results for 
Search instead for 
Did you mean: 

Per-contact ringtones not working after MR2

Highlighted
Journeyman

Per-contact ringtones not working after MR2

Per-contact ringtone selections no longer working. Selection is stored but on incoming call only default, system-wide ringtone plays, regardless of contact setting. Tried built-in and sdcard-based ringtones, no difference.

Is there some other setting I'm missing? Not 100% positive but pretty sure this worked fine before the MR2 update.

32 REPLIES 32
Wizard

Re: Per-contact ringtones not working after MR2

Aardgeek,

Just informed that this is a known issue with the recent MR and will be addressed in the next maintenance release.

Markie_B

Journeyman

Re: Per-contact ringtones not working after MR2

That's encouraging. Thanks for checking!

Wizard

Re: Per-contact ringtones not working after MR2

Aardgeek,

No problem.

Markie_B

Journeyman

Re: Per-contact ringtones not working after MR2

Do you have any information about how soon they will put out a maintenance release that restores the individual ringtones? In just about every other respect, it seems that the recent release has improved performance, but having every call ring the same way is a problem for me. I had set ringtones for every number in my dialing directory (easy enough to set a whole bunch of them to a certain group ringtone with the dialer app that I use) and I always knew if it was a likely spam caller when I heard the default ring. Now I have to look at the screen every time anybody calls.

Journeyman

Re: Per-contact ringtones not working after MR2

Set it and restart the phone it works then for me.

Journeyman

Re: Per-contact ringtones not working after MR2

I've restarted my phone 3 times and still every call rings the default ringtone, ignoring the individual settings. Still looking for a solution.

Wizard

Re: Per-contact ringtones not working after MR2

I apologize frailer, at this time we do not have an estimation on when the next maintenance release will be issued to resolve this.  As soon as information is available, a blog will be posted with the details.

Journeyman

Re: Per-contact ringtones not working after MR2

I don't understand. U all kno how to fix it bit yet u r not doing so.  It would b like us going in and purchasing a phone yet telling u all we will have the money but we just don't kno when. These phones aren't cheap therefore all the features r expected to work yet it's a huge disappointment when they don't. Yet we r mandated to pay for service just as if all features r working fine or our service gets disconnected.  We have to hold up our end y don't u.  Sorry I don't mean to sound rude but I am very disappointed in sprint at this time cuz I am not getting any help w this matter and I c a bunch of others that r in the same boat

Wizard

Re: Per-contact ringtones not working after MR2

TammyL73,

I certainly understand your position.  Please understand that Sprint is working with HTC to resolve any 'bugs' as quickly as possible, but it is not something that can be addressed overnight.  Software developers need to re-code, test, debug, test again and determine that the MR is deployable.  I'm sorry if you are disappointed, but with any software driven technology, bugs will create issues, but they definitely aware of this and are working to get this working properly again as quickly as possible.

Journeyman

Re: Per-contact ringtones not working after MR2

Software developers need to re-code, test, debug, test again and determine that the MR is deployable

How about field testing before releasing more bugs to the entire userbase???

Wizard

Re: Per-contact ringtones not working after MR2

Don't shoot the messenger. Please open up a trouble ticket with HTC. Ask THEM directly why those bug appeared when in the previous MR it did not. the Mods here can only do so much and they do not have all the answers.

MR's sometimes break other things. its happed across ALL platforms and even on desktop software. Things happen, that why there are MR's in the first place!

Coding an OS is extremely demanding and the engineers have deadlines to repair/patch things and get them sent out for their clients (Sprint in this case with the 4g lte). Its even possible they knew about the bug but could not go back in and repatch it due to time constraints. 

I am an early adopter of electronics and I have seen devices launched with bugs off the bat, with a MR shipped almost a day or so after the device launch.

In the meantime and between time, you can install a 3rd party ROM and reclaim the feature (and add even more)...

Community News

Sprint S.M.A.R.T Agents
Sprint S.M.A.R.T Agent are here to help Monday through Friday 6:00 AM CT - 6:00 PM CT. If you need to speak to an agent outside of these hours, please visit Sprint Chat