cancel
Showing results for 
Search instead for 
Did you mean: 

Tulsa OK Dropped Calls

Highlighted
Journeyman

Tulsa OK Dropped Calls

I am having continuous problems with dropped calls. 1 ring or maybe 5 seconds and gone. Tulsa OK

17 REPLIES 17
Highlighted
Master

Have you updated your PRL and Profile? Have you tried a SimPull? Any tower issues in your area? Also, there's an update just released this morning for the LTEVO, see if it helps with connectivity,

Settings > System Updates > HTC Software Updates


--
If my post or someone else's answered your question please mark it an Accepted Solution.

Keep in mind, like you, I am a Sprint subscriber. I am in no way employed by Sprint in any sense. I just know stuff.
Highlighted

Can you please provide us with an address or cross streets close by including zip code so I can look at the towers and see if there is anything going on?

Thanks,

Ray

Highlighted
Master

Alright, Ray is joining in. I've been PMing Shane and Knight a heads up when users are posting connectivity issues, I'll start including you on those PM's so your aware.


--
If my post or someone else's answered your question please mark it an Accepted Solution.

Keep in mind, like you, I am a Sprint subscriber. I am in no way employed by Sprint in any sense. I just know stuff.
Highlighted

Thanks

Highlighted
Journeyman

I'm having this problem as well, found this therad by searching 'tulsa'.   Zip is 74135.  Locations - I'm having dropped calls everywhere, but mostly on Harvard between 5th and 35th, and about a block east of 35th & Harvard.   Seriously unusable - it's been going on for months but in the past few weeks it went from annoying to "don't even bother trying to call".

Highlighted
Master

I sent a PM to Ray, so hopefully he'll pop back in here and help you out.


--
If my post or someone else's answered your question please mark it an Accepted Solution.

Keep in mind, like you, I am a Sprint subscriber. I am in no way employed by Sprint in any sense. I just know stuff.
Highlighted

Thanks for the cross streets. I was able to use 35th and harvard and looked at the towers and the towers do not seem to reading anything out of the ordinary. Do you know if other Sprint users are having the same issues or is it just you? Have you tried to update your PRL on your phone?

Ray

Highlighted
Journeyman

Wife is having same issue - she's on the original EVO.

It's not the phone because I was having this issue, though not as bad, with my original EVO, then it actually got worse when I bought the new 4g lte EVO.  I've hit up 'update prl' and profile etc. 

Symptoms: I see one or even three bars of signal, then when I hit Call after the first ring it drops to 0 bars/no signal.   Third or fourth time is usually the charm, and people I call have sort of gotten used to having 3 'hangup' calls in a row from my number.   If doesn't get better soon I'm going to have to go with someone else.

Highlighted
Master

Be sure to PM Ray above with your Zip and nearest main cross streets as well.


--
If my post or someone else's answered your question please mark it an Accepted Solution.

Keep in mind, like you, I am a Sprint subscriber. I am in no way employed by Sprint in any sense. I just know stuff.
Highlighted
Journeyman

i'm also having some dropped calls lately, 5-7 times a week, been going on for month of july.

Highlighted
Master

I would do the same thing, PM Ray above with a description of your problem and include the nearest main cross streets and zipcode to the area your having the problem.


--
If my post or someone else's answered your question please mark it an Accepted Solution.

Keep in mind, like you, I am a Sprint subscriber. I am in no way employed by Sprint in any sense. I just know stuff.
Community News

Our Community is BACK!!
Hours of Operations are 7AM - 8PM CST. Please try Searching the Community, we have many questions already answered, you can also check out the Knowledge base
If you need immediate assistance after hours please visit Sprint Chat