cancel
Showing results for 
Search instead for 
Did you mean: 

not getting my email notifications and whatsapp notifications and google talk notifications promptly.

Highlighted
Journeyman

not getting my email notifications and whatsapp notifications and google talk notifications promptly.

Hey so i noticed that I'm not getting my notifications for whats app and google talk and my email rightaway. instead I get them whenever I turn the phone on and not when the phone is sitting on my desk and not being played with. anyone know how to fix it.  my background processes is set to standard limit.

17 REPLIES 17
Highlighted
Master

Are you referring to Gmail or Mail? The Gmail app should update as soon as emails are received by the server the Mail app only updates based on the set interval.

For Google Talk, have you tried unchecking the Away When Screen Off option?

Not familiar with the WhatsApp messageing configuration, so hopefully someone who's using it can chime in.


--
If my post or someone else's answered your question please mark it an Accepted Solution.

Keep in mind, like you, I am a Sprint subscriber. I am in no way employed by Sprint in any sense. I just know stuff.
Highlighted
Journeyman

ok i just checked off the away when screen is off option, lets see how it works out.  and yes i was referring to gmail. i've just noticed it once or twice as i dont get many emails.  when i get a beep that i have mail and i check the time it seems my email arrived 15 mins ago and i JUST got the notification that i have an email... sometimes longer.

Highlighted
Master

Hmm, yeah, that does seem a long time to be notified. I'll have to pay more attention to mine but I'm pretty sure my LED starts flashing within seconds of the Gmail website displaying my email on the computer.


--
If my post or someone else's answered your question please mark it an Accepted Solution.

Keep in mind, like you, I am a Sprint subscriber. I am in no way employed by Sprint in any sense. I just know stuff.
Highlighted
Journeyman

yes i've also noticed that my led... doesn't keep flashing... just stops flashing after like a minute...

Highlighted
Journeyman

i just sent myself an email from a different email address... been 2 mins so far an no notification or anything.

Highlighted
Master

Did the same on my end, the LED started flshing not long after the message showed on the computer, probably 5 seconds.


--
If my post or someone else's answered your question please mark it an Accepted Solution.

Keep in mind, like you, I am a Sprint subscriber. I am in no way employed by Sprint in any sense. I just know stuff.
Highlighted
Master

Could be releated to your data coverage. You in an area that has poor 3G signal?


--
If my post or someone else's answered your question please mark it an Accepted Solution.

Keep in mind, like you, I am a Sprint subscriber. I am in no way employed by Sprint in any sense. I just know stuff.
Highlighted
Journeyman

Yea im in strong coverage area...even at home when im on wifi...my emails are ALWAYS 10 ish minutes late...whatsapp msgs only come up if the phone is active...someone said its a forced kill feature in the evo but idk y emails are delayed...

Highlighted
Master

You may want to check in with Sprint and explain the problem. They shouldn't take that long.

Couple options. Simulate a battery pull by holding the Power button for 10+ seconds. It should start flashing the capacitive buttons and then turn off. Then power back up.

Make sure your PRL and Profiles are current.

Try one or the other or both and see if it helps any.


--
If my post or someone else's answered your question please mark it an Accepted Solution.

Keep in mind, like you, I am a Sprint subscriber. I am in no way employed by Sprint in any sense. I just know stuff.
Highlighted
Journeyman

I had the same issue, only got my emails when I opened gmail app an refreshed. was driving me nuts.Go to gmail, settings, click on your account name, and make sure under the word USAGE that gmail sync is on. if you click on auto sync it will bring you into screen with all the updatable apps on phone. just enable google account. fixed my issue. must default to off.

Highlighted
Journeyman

good catch, i actually did make sure my account gmail mail sync was on beforehand.  the problem it appears is that it only happens when the phone is asleep... just on my desk and im not playin with it... if i am on the phone whether on the internet or on gtalk... i get my emails instantly.  and i have only noticed this happening while im at home and on a wifi connection.  i've also noticed that whenever i  wake the phone up at home, i have no wifi signal until the phone is awake, so im thinking the problem lies with my wifi connection losing when the phone is asleep.  i went and checked the wifi settings in advanced section of the menu and under KEEP WIFI ON DURING SLEEP is on "ALWAYS".  so i dont understand why i lose my connection to the wifi network when the phone is asleep, i truly beleive that is the cause of my delayed email notifications. any advice how to fix the wifi settings? its already on always on when phone is asleep, idk wht else it could be.

Community News

Our Community is BACK!!
Hours of Operations are 7AM - 8PM CST. Please try Searching the Community, we have many questions already answered, you can also check out the Knowledge base
If you need immediate assistance after hours please visit Sprint Chat