cancel
Showing results for 
Search instead for 
Did you mean: 

Photos GONE! What happened?

Highlighted
Journeyman

Photos GONE! What happened?

ALL my photos have gone missing. It says I need to insert an SD card...um, I've never even had one. Where are my photos?

6 REPLIES 6
Highlighted
Master

Sorry for the inconvenience. I would suggest you to take the card out and put the SD card back into the phone and check if you can find your pictures in Gallery. If you cannot find the pictures in Gallery, hook your device to pc via USB cable and go to computer- check the drives (Mass Storage) to find your phone, double click on the drive- check for DCIM folder –double click on DCIM folder to find your pictures. Let me know.

Thanks

Abe

Highlighted
Master

The EVO 4G requires an SD card to take any photos. It came with an 8GB card out of the box.

I would recommedn taking out the card from under the battery and reinserting it. If you have another card available to try, try putting that in the phone to see if the SD card slot went out on the phone, if it reads another card then it is likely that your card is bad.

Highlighted
Journeyman

Okay, I've taken out the 8gb card and replaced it. Nothing happened. Then I tried a different micro card....still nothing. Do you think this means something is wrong with my phone?

It won't even let me take photos now.

Highlighted
Master

Most likely. If multiple sd cards aren't working then likely something happened wit hthe SD slot on the phone itself. I woul dsuggect taking it into a Service and Repair store and having the technicians take a look at the device. As long as the phone doesn't have any liquid damage or physical abuse they should be able to get it replaced for you.

Highlighted
Journeyman

Thank you for your help. I'll take it asap. Bummer! Very disappointed in this phone.

Highlighted
GrandMaster

actually put your sd card into a computer/laptop and see if you can pull up your photos and info that way..if you STILL cant then the issue might be with the sd card itself.. is the other sd card that you tried a new sd card or old one? also when you removed the sd card and put it back in..did you hit the unmount button before removing it and then remount button when you put it back in?

*********************************************************
I like many others come onto this site for assistance and to help others. Marking a reply as helpful or correct helps others with like issues when they try to search the site for assistance. I do not work for Sprint and my suggestions and or opinions are my own. *************************************************************************************************************
Community News

Our Community is BACK!!
Hours of Operations are 7AM - 8PM CST. Please try Searching the Community, we have many questions already answered, you can also check out the Knowledge base
If you need immediate assistance after hours please visit Sprint Chat