Sprint Community is Read Only. Please use the My Sprint app or Sprint.com to manage your account. If you need assistance, please visit Sprint.com/chat or visit community.t-mobile.com
Sprint Community is Read Only. Please use the My Sprint app or Sprint.com to manage your account. If you need assistance, please visit Sprint.com/chat or visit community.t-mobile.com
Sprint Community
cancel
Showing results for 
Search instead for 
Did you mean: 

HTC Hero 2.1 Update Problems/Issues since update:

Journeyman

HTC Hero 2.1 Update Problems/Issues since update:

I just wanted to post a couple of issues that I've noticed with my HTC Hero by Sprint since updating to the new Android 2.1 RUU issued by Sprint on May 19, 2010. Since the update, the following problems have arisen:

1. When opening any number of different apps from the Android Market and/or apps that were included with the update, the phone will reboot itself automatically.

2. When receiving calls, there is a long lag between when the other party hears their phone ringing and when I actually receive the call on my Hero. Sometimes its only 3-4 rings before it registers on my phone. Other times, it's 5-6 or sometimes I won't even receive the call at all and will eventually get a notice that I missed a call and that I have a voicemail.

3. When opening the Sprint Navigation app, intially (prior to opening it following a reboot/turn on) the app will get to the point where it needs to contact the server for sign-in (or something) and then the phone will automatically reboot itself. Following the reboot, the phone will turn on, but the network is unavailable. When opening the Sprint Nav app after automatic reboot (caused by the app in the first place) then the app runs to the point where it tries to sign in, but said that 'Sprint navigation is not available'. Also, the network does not work for any other programs on the device. The only way to correct this problem, is to reboot the phone again manually. Then, if you try to open the Sprint Nav app again, the problem starts over from the beginning again, resulting in another automatic phone reboot.

4. There is still lag when programs are open (of course, probably due to the hardware specs or the lack there of =D ).

If anyone else has noticed any additional problems, please continue this discussion so as to bring these issues to Sprint's attention. Hopefully, they'll hear their customers and have some type of solution for them. Thanks guys!

197 REPLIES 197
Journeyman

Everything seems to be working well now.  No reboots in the last two days.  And I've tested some of the location-dependent aps others have mentioned.  Incidentally, I have location by wireless networks turned off (for battery life as suggested frequently) but leave location by mobile network and GPS on.

For two days in a row, I've achieved ~ 26 hrs before needing to recharge (not as good as OS1.5 as there seem to be more system tasks running in the background; awake time is running about 15% of total, up from 8% or so with OS1.5 with essentially same settings and killing of aps).  I guess that's acceptable; I'd prefer more safety margin, particularly for heavy talk days, but it's OK I guess.  This is with VERY light phone usage but moderate internet usage, mostly via wifi.  I'm now letting Mail, Messages, Gmail, and Google Talk run in the background as they wish, but I'm still auto killing most other non-system tasks with the Rhythm Task Manager.  Free memory tracking around 50MB most of the time. Battery usage stats are Cell standby 52%, Phone idle 30%, Wi-Fi 12%, and Display 6%. I'm not totally sure what modes Cell standby and Phone Idle really represent or whether there's opportunity to make them more efficient. This house is in an area with weak/intermittent Sprint phone and network coverage. Having WiFI on most of the time takes the mobile network out of contention though I think.

I've read about aps which allow you to slow down the processor when the phone is in various idle states.  That would seem desirable for battery life too (unless OS2.1 already does some of that) but these seem to require the phone to be rooted.

With OS1.5 I was very happy with the automatic screen brightness, never feeling a need to adjust it, but under 2.1 it appears brighter across the spectrum.  I found an ap called Brightness Profiles which allows you to tailor a Low, Normal, and High setting.  I have "Calibration" (of lowest level) set to 36, and Low, Normal, and High adjustments set to 0%, 10%, and 20%, which correspond to nice levels for dark room, normally lit room, and hopefully outdoors (but I haven't tested outdoors yet so don't know if 20% is the right setting for High.  This is the nicest of the brightness aps I was able to find. I would have preferred a bias setting to adjust the automatic brightness back to where it was in OS1.5. Does anyone know if that's adjustable?

Journeyman

Not sure if i'm mistaken or not! But isn't "FriendStream" supposed to be on 2.1? Maybe im just losing it! But i 've been goin nuts lookin for it lol! I know for a fact that it's on the 2.1 for the EVO!

Journeyman

I hate my Hero....This wasn't the phone that I wanted but when I purchased the phone I did want at Best Buy they had a "bad batch" of the other phone and I had no choice but to get another phone.  Everyone said it wa a great phone and that I would love it......they were wrong......This phone is horrible!!!!

Journeyman

Wishful thinking, but you must be living in a fairytale if you think they are gonna give us 2.2 on a Hero. I can tell you that will never happen. Look at what we had to go through to get 2.1. You better start saving for the EVO.

Journeyman

K well these are the problems im having txting is still lagging plus during internet searches the suggestions boxs that android gives dont complete they lock up and do not move so the whole time im on the net i see little green boxes the phone sometimes does a wierd like ui reset i have lost evdo connection alot for some reason the phone ask me to insert my number when i try and use the web i have been having voicemail connection data and call errors since the update plz someone hlp have no clue what to due have done the take the battery out for an hr and restart nothing same thing.

Journeyman

Hello All,

this is the issue that I am having. Whenever I get an unidentified call on my Hero it shows up as this one person from my Facebook. If I have facebook disabled on the phone it still shows up as this person. I Don't even have this person's phone number. I even checked her page and her phone number isn't listed. I went to the extent of deleting the person as a friend on facebook and still when i get a call from an unknown number it shows up as this person. I have tested this repeatedly using the phones at my work to verify that the problem is persisting. When the call comes in it shows as unidentified but when I check my call history it shows as this person. Is there anything I can do to resolve this issue? I don't want to disable facebook but at the same time I don't want this random person showing up in my call history all the time.

thanks all

-S

I am not sure if this will help but....do you have your contacts backed up in Gmail? If you do, go to gmail and your contacts. You will see all contacts and my contacts. Click on all contacts and then put your cursor in the search space and click on the space bar. Now click on the search and you should get all results separated into my contacts and all contacts. Scroll down to the end of My contacts and there should be a section for all contacts. You can choose to keep them or delete them but I am wondering if a contact was made with the "unidentified" and this number is then showing??? Just a thought. Good luck

Journeyman

Conradmr1,

Sorry but that didn't work. there is no contact in my google contacts or on my phone as "Unknown Number" or Unlisted." Its a really wierd issue but when I pull up, "People" -> "Call History" it shows fine, Unkown. No picture nothing. But when i press the Talk button that shows my favorites and recent callers the unknown number is listed as this person, to simplify her name is Danyal.

Thanks though,

-S

smfick - sorry that didn't work. Maybe one of the experts will have a solution for you - hope so. Good luck.

Also wondering if you have "save to contacts" checked in the phone settings (this adds unknown numbers to People after call. Just in case you need - go into Phone, Menu, Phone settings)

Message was edited by: conradmr1

Journeyman

Ok, I gave my Hero the 2.1 update the other day and came across some problems. I took the phone to sprint and they took about 4 hours messing with it. The fixed most of the bugs but the biggest one was they could not successfully link my contacts with Facebook. Has anyone found a resolution to this problem? I see other people are having it to. Well instead of Sprint fixing it, they gave me a brand new Hero with the 1.5 update. I'm not exactly sure what to do... HAs anyone found the resolution to the Facebook linking problem? Should I try the update again and see it if will work on a brand new phone? Thanks

Journeyman

I having problems as well with the delay on the phone and i cant stand when it keeps rebooting. My phone is now a big issue for me seeing its not really reliable it just turns off then back on for no reason when whenever it wants to. Very disappointed

Journeyman

Has anyone had awake time issues since the update?

Community News

Sprint Community is Read Only. Please use the My Sprint app or Sprint.com to manage your account. If you need assistance, please visit Sprint.com/chat or visit community.t-mobile.com
Please try Searching the Community, we have many questions already answered, you can also check out the Knowledge base
If you need immediate assistance after hours please visit Sprint Chat