cancel
Showing results for 
Search instead for 
Did you mean: 

STOP HTC ONE FROM CONNECTIONG TO WIFI!!!!

Go to solution
Highlighted
Journeyman

STOP HTC ONE FROM CONNECTIONG TO WIFI!!!!

This is driving me crazy.  I've asked around on other forums, and everyone says this is NOT default Android behaviour, and say SPRINT must be doing this.  Here are the facts"

I have an HTC One M7.

In my area, finally this last year or so, I have GREAT 4G speeds, so I really never need to use wifi.  At hotspots, my 4g is a LOT faster than the shared wifi.  So I want to use 4g almost all the time.

I go into Starbucks, or a client with an "open" wifi, or some other place with "open" wifi.  And I try to access email, or listen to music, or do ANYTHING online.  Soon after I get there, while I'm doing whatever online using 4G, the phone AUTOMATICALLY switches to wifi.  I have no choice.  Even if I have previously BLOCKED that connection, it still automatically switches to wifi.

So what's the problem here?  Besides the slower speed of these shared wifi connections, I was IN THE MIDDLE of doing something, and when it switched automatically to wifi what I was doing STOPS! Mail quits, music dies, all online stops.  Why you ask?  because nearly all "open" wifi HAS A LANDING PAGE.  So now, right in the middle of email, or my favorite streaming music, I have to either go to settings-wifi and manually turn it off, or I have to go to a web browser, load a HTTP type page (which can be difficult because the phone looks for a M.xxx page, and those don't trigger the signin).  When I find a page, then I get the landing page, click ok to the terms, and then go back to CONTINUE WHAT I WAS ALREADY DOING!

A real pain, since I'm out and about all day and this happens a lot.

So, how do I prevent the phone from switching automatically to wifi?  I have ALL wifi options unchecked, so There's nothing else in wifi I can turn off.

VERY annoying.

47 REPLIES 47
Highlighted
GrandMaster

yah if im thinking right the high accuracy mode is going to pull out all the stops and tricks to make sure your location is dead on accurate..so pulling the info from the towers as well as any GPS that is available if it must.

*********************************************************
I like many others come onto this site for assistance and to help others. Marking a reply as helpful or correct helps others with like issues when they try to search the site for assistance. I do not work for Sprint and my suggestions and or opinions are my own. *************************************************************************************************************
Highlighted
Master

dwbydesign,

As long as the connections optimizer is disabled, your device should not auto-connect to wifi. I am glad you were able to find the appropriate solutions. Please, let us know if you need any additional assistance.

Keith
Sprint Social Care
Highlighted
Master

smotrs,

If you have any other questions, feel free to reach out to us again.

Keith
Sprint Social Care
Highlighted
GrandMaster

lol

*********************************************************
I like many others come onto this site for assistance and to help others. Marking a reply as helpful or correct helps others with like issues when they try to search the site for assistance. I do not work for Sprint and my suggestions and or opinions are my own. *************************************************************************************************************
Highlighted
Master

ROFLMAO

Way too funny.


--
If my post or someone else's answered your question please mark it an Accepted Solution.

Keep in mind, like you, I am a Sprint subscriber. I am in no way employed by Sprint in any sense. I just know stuff.
Highlighted
Journeyman

Ok, I've been looking at this for a few weeks now, and here's what I found.  High-Accuracy mode is definitely the culprit.  Turning Connections Optmizer off didn't help. Nothing else seemed to help. 

Under Location there are three choices:  High-Accuracy Mode, Battery Saver Mode, and Device Only.  If I set it to Battery Saver or Device only, it does not automatically switch to Wifi.  It does still find the Wifi, and sometimes notifies me it's there, and may even turn it on.  But it does not switch from 3G/4G to Wifi.  So I don't get booted out of my session to a wifi landing page.

The moral of this story:  Don't use High Accurracy mode if you use 3G/4G a lot, because it will highjack your session!

View solution in original post

Highlighted
GrandMaster

glad it was figured out.

*********************************************************
I like many others come onto this site for assistance and to help others. Marking a reply as helpful or correct helps others with like issues when they try to search the site for assistance. I do not work for Sprint and my suggestions and or opinions are my own. *************************************************************************************************************
Highlighted
Journeyman

Worked like a charm.. thanks alot guys!!!!!

Highlighted
Journeyman

Worked like a charm... thanks guys!!!!

Highlighted

I was really hoping this was going to be it. My WiFi is turning on by itself constantly and I've tried everything! I set mine to device only and 5 minutes later it's back on WiFi....
Highlighted

Let's try this: You'll need to go to setting, then under Wireless and network, click More settings, then scroll down to Mobile networks, then click Automatic Connections. Now un-click Sprint automatic connection. That will stop wifi from trying to automatically connect to a wifi network. There is one more step you can take after that, which will help with battery life. Go to >settings>Application manager> choose Running, then stop Sprint Optimizer.

 

Juan

Sprint Social Care


Juan
Sprint Social Care
Highlighted

there is one final possibility if turning off the connections optimizer. originally when you set up the phone google asked about location settings and if im remembering right one of the options for the best location gathering was for the phone to use network, GPS AND wifi..which if im remembering right can turn on wifi at times as well. for sure start with the optimizer just in case
*********************************************************
I like many others come onto this site for assistance and to help others. Marking a reply as helpful or correct helps others with like issues when they try to search the site for assistance. I do not work for Sprint and my suggestions and or opinions are my own. *************************************************************************************************************
Community News

Our Community is BACK!!
Hours of Operations are 7AM - 8PM CST. Please try Searching the Community, we have many questions already answered, you can also check out the Knowledge base
If you need immediate assistance after hours please visit Sprint Chat