Sprint Community is Read Only. Please use the My Sprint app or Sprint.com to manage your account. If you need assistance, please visit Sprint.com/chat or visit community.t-mobile.com
Sprint Community is Read Only. Please use the My Sprint app or Sprint.com to manage your account. If you need assistance, please visit Sprint.com/chat or visit community.t-mobile.com
Sprint Community
cancel
Showing results for 
Search instead for 
Did you mean: 

Error-Moisture detected cant charge

Go to solution
Journeyman

Error-Moisture detected cant charge

Keep getting erroneous message water detected in usb port charging blocked. Phone has never gotten wet since purchased July 2017. The only work around is I bought a generic  wireless charger. Diesnt fsst cgarge but can use phone. I cleared cache, rebooted, did fictory reset data wipe. Still get message unless charge with power off. But then phone powers back on after a minute or so.

1 ACCEPTED SOLUTION

Accepted Solutions
GrandMaster

if you have another wall adapter plug your original charging wire into it and try that..if it works then its the wall adapter that came with the phone..if it doesnt work then its more than likely the cable. since another cable worked but didnt fast charge its almost a safe bet its the cable or adapter and not the phone itself.
*********************************************************
I like many others come onto this site for assistance and to help others. Marking a reply as helpful or correct helps others with like issues when they try to search the site for assistance. I do not work for Sprint and my suggestions and or opinions are my own. *************************************************************************************************************

View solution in original post

11 REPLIES 11
GrandMaster

if you have another wall adapter plug your original charging wire into it and try that..if it works then its the wall adapter that came with the phone..if it doesnt work then its more than likely the cable. since another cable worked but didnt fast charge its almost a safe bet its the cable or adapter and not the phone itself.
*********************************************************
I like many others come onto this site for assistance and to help others. Marking a reply as helpful or correct helps others with like issues when they try to search the site for assistance. I do not work for Sprint and my suggestions and or opinions are my own. *************************************************************************************************************

View solution in original post

I tried a different wall adapter and still had same deal, I also bought a cord and still had no fast charge. I am going to go with your response and think my original wallplug and or cord is bad. Hopefully store will exchange. Thanks fir the reply. The good thing out of this is I do think the wireless charger is pretty cool. Just wish would do fast charge.

that would be my guess. the new charger you purchased. is it a all in one deal or can you remove the cord from the adapter itself? also if you have an old phone around you can use that wall adapter part of it to test with your G6 cord. if you have a corporate repair store near by take the cord and cable in and they might be able to test them.

i believe Samsung made a quick charging wireless charger.. @Dj_Damjano didnt you say they had one? or do you remember who made the quick charging wireless charger?
*********************************************************
I like many others come onto this site for assistance and to help others. Marking a reply as helpful or correct helps others with like issues when they try to search the site for assistance. I do not work for Sprint and my suggestions and or opinions are my own. *************************************************************************************************************

were you able to get another wall adapter and cord to test against?
*********************************************************
I like many others come onto this site for assistance and to help others. Marking a reply as helpful or correct helps others with like issues when they try to search the site for assistance. I do not work for Sprint and my suggestions and or opinions are my own. *************************************************************************************************************

In my case it was the USB cable that was bad
*********************************************************
I come here trying to help people and I'm NOT employed by Sprint, so If my reply helped you or if you get an answer to your question from other users, PLEASE mark it as solved.

it happened to you too?
*********************************************************
I like many others come onto this site for assistance and to help others. Marking a reply as helpful or correct helps others with like issues when they try to search the site for assistance. I do not work for Sprint and my suggestions and or opinions are my own. *************************************************************************************************************

Yeah with an old car charger, I believe there is a cross over on the cable when it's bad and since the phones can tell if the power is good or not, they think it is water due to shortage in wires.
*********************************************************
I come here trying to help people and I'm NOT employed by Sprint, so If my reply helped you or if you get an answer to your question from other users, PLEASE mark it as solved.

thats what it sounds like. wires inside frayed at some point and were touching causing a short.
*********************************************************
I like many others come onto this site for assistance and to help others. Marking a reply as helpful or correct helps others with like issues when they try to search the site for assistance. I do not work for Sprint and my suggestions and or opinions are my own. *************************************************************************************************************
Journeyman

Im having the same issue right now. Can someone help me resolve this problem?

I've tried everything but still no good.

Have you tried a new cable. Not a different old one but a new one.
*********************************************************
I come here trying to help people and I'm NOT employed by Sprint, so If my reply helped you or if you get an answer to your question from other users, PLEASE mark it as solved.

once you test against a different cord make sure to test against a different wall adapter so you fully rule out the cord and adapter as being the culprit.
*********************************************************
I like many others come onto this site for assistance and to help others. Marking a reply as helpful or correct helps others with like issues when they try to search the site for assistance. I do not work for Sprint and my suggestions and or opinions are my own. *************************************************************************************************************
Community News

Sprint Community is Read Only. Please use the My Sprint app or Sprint.com to manage your account. If you need assistance, please visit Sprint.com/chat or visit community.t-mobile.com
Please try Searching the Community, we have many questions already answered, you can also check out the Knowledge base
If you need immediate assistance after hours please visit Sprint Chat