cancel
Showing results for 
Search instead for 
Did you mean: 

LTE Not working on the LG G2

Journeyman

Re: LTE Not working on the LG G2

I can relate!  I just bought two LG G2's (one for myself and one for my son) and our LTE 4G is non-existent, despite what the maps say.

At home I am primarily on Wi-Fi so I don't really notice or care (zip 27529 - Garner NC)

At work, though, the maps say I should be at least "Fair" on LTE/4G coverage.

I upgraded from a Samsung Galaxy S2, which at work got 1 bar 3G and 1-2 bars 4G.

I get NO bars of either at work maybe 15 feet from the windows, which is zip code 27560 (Morrisville, NC), cross streets Innovation Ave at Pleasant Grove Church Rd and approx. 5 miles from the nearest tower.

Screenshot_2013-12-06-12-09-07.png

sprint4gcoverage.bmp

sprinttowermap.bmp

Journeyman

Re: LTE Not working on the LG G2

Sprint please read this!  This is Mark from Woodland Hills, CA 91364, and I have created other threads on this topic.

This is a HUGE problem BUT it is unique to the LG G2.  Several responders to my other threads have noted that their previous 4G LTE phones worked just fine on the 4G LTE network before changing to the LG G2.  I unfortunately do not have another Sprint 4G LTE device to test this.

However the users with problems are all over the US - one user is in Roseville, CA, perhaps 300 miles from me, another user in Pittsburgh, thousands of miles away, and even my most recent Sprint tech support person Becky, is in Texas, again a 1000 miles away from me.

The commonality in all of this is the LG G2.

And it does not matter if you replace one LG G2 with another, its specific to every LG G2.

Someone from Sprint, please elevate this issue and help us resolve it or send us another phone comparable to this LG G2 but without these problems and of course free!  But then why did we purchase these LG G2s which we thought were some awesome???

Journeyman

Re: LTE Not working on the LG G2

This is most likely the problem you are experiencing (see link below). I had this as well the first week of the LG G2 release. The G2 is not the only phone affected. Any Tri Band phone will experience this as well.  My area is served by Shentel. Shentel did an outstanding job of quickly updating the system so that Tri Band phones are compatible.

Nexus 5 and LG G2 experience temporary Sprint LTE connectivity issues due to Circuit Switched Fallba...

Journeyman

Re: LTE Not working on the LG G2

I am very familiar S4GRU's article.  However so far I have not found anyone else posting an issue with the new tri-band phones except for the G2 - I have googled extensively, checked other forums, and so far - and I could be wrong - so far the issues seem to lie with the G2 exclusively.

I have spoken with Sprint Tech Support several times over the last 4 days - speaking with the same rep each time - and asked if they had any other callers with similar issues to what we are experiencing - this tech support rep has the identical issue on her G2 at her home - and she cannot recall anyone having this issue with any other new tri-band phone.  Now I realize this is a limited amount of data but there is a significant number of G2 users having this issue all over the US - so I have to discount the network issue as the primary issue because the variety of locations coast to coast with these issues must have a variety of service providers rather than just one, such as the one you mention that was so helpful.  The significant commonality is the G2, at least in my humble opinion.  I do understand the fallback issue and the simultaneous voice and data issue and whereas these must be addressed, that so many of us are unable to use 4G LTE even in areas where previous 4G LTE phones worked flawlessly, has to be something other than the inherent issues in these new tri-band phones.  If someone reading this has another phone with the same issue, I would like to know also!

Journeyman

Re: LTE Not working on the LG G2

I miss my evo! I'm frustated that the store staff kept saying the g2 was the best phone, but I can't even look at my emails in my own home without waiting for a long download time. My husband finally switched to sprint after many years and now he's regreting it. I love the capacity the phone has, but it doesn't matter if I can't connect to several apps. I had 4g on my evo all the time, but only once on the g2.

Journeyman

Re: LTE Not working on the LG G2

After some online research I've learned that the LG G2 phones come with only 1 of the 3 available radio bands enabled by default (bands 26 and 41 are disabled). However it's a relatively simple matter to enable the other bands manually. By enabling the other bands (band 41 in particular) the phone seems to be more able to tap into the full LTE signal. For anyone interested I recommend reading through the information provided in the following link: http://forum.xda-developers.com/showthread.php?t=2527617&highlight=band+41

Master

Re: LTE Not working on the LG G2







Baltoboy64,


Thanks for the post. I am aware that you have others complaining of the same issue but I would like to have a look at he service in your area. Please provide me with your zip and cross streets so I can rule out the network as an issue. Thanks!



Sean L
Social Care




Master

Re: LTE Not working on the LG G2







anon002,

Thanks for posting this. I would recommend using caution when attempting to change anything from factory settings as it can cause damage to the software of the phone, leading to loss of all device information.

*Andi R.
Sprint Social Care Team




Journeyman

Re: LTE Not working on the LG G2

Hi Sean,

My nearest cross streets are Costanso Avenue and Alhama Drive, in Woodland Hills, CA 91364.

Anything you can do to help me understand the source of the problem and what likelihood there is that the problem will be addressed and resolved in the near future would be enormously appreciated.

I have left my G2 on LTE/CDMA as the network BUT have unchecked Connection Optimizer.  I have almost no bars showing on the phone but seem now to be able to receive calls and data (although I have WiFi on when at home so data is coming through WiFi I would assume).  However when a call comes in, I get full bars showing.  I believe these are 3G bars, as when I am in a 4G LTE area, the notification area shows 4G LTE and the strength of the reception.   In other areas close to home, the 4G LTE signal seems quite strong, and while running errands today I ran speed tests several times in areas where 4G LTE signal appeared, and speeds ranged from 3 Mbps - 9 Mbps down, 2-4 up.   If I could receive the 4G LTE signal with this speed at home, it would be just great.

I have been told my another Sprint tech support rep that the towers I use the most have all been upgraded, work completed a few days ago, and if I haven't seen marked improvements now or soon, then its not likely I will see any better 4G LTE reception at home.  That of course is not good news.

There are patches of 4G LTE within a few minutes of my house with blazing speeds - at my barber 27 Mbps down, 9 Mbps up - so there is a glimmer of hope that similar speeds will appear here.  Maybe.

Master

Re: LTE Not working on the LG G2







Baltoboy64
Thank you for the info. I checked out that area and I do see that we have some LTE activated towers nearby, but the 2 closest towers servicing that location are not activated with the LTE upgrades quite yet. We have these upgrades on schedule in the coming months. This would explain why you are seeing some slower speeds in that area. It would appear that your device is trying to pull the LTE data from a further tower.
-Patrick
Sprint Social Care




Journeyman

Re: LTE Not working on the LG G2

Not sure how many times I have to post my 4G LTE issues in these forums. But here I go again my crossroads are High Road and Goforth Road in just east of Kyle, Tx 78640. I gonna be staying with Sprint so it would be great to have 4G LTE on constantly .

Journeyman

Re: LTE Not working on the LG G2


JB027 wrote:



Not sure how many times I have to post my 4G LTE issues in these forums. But here I go again my crossroads are High Road and Goforth Road in just east of Kyle, Tx 78640. I gonna be staying with Sprint so it would be great to have 4G LTE on constantly .



@JB027

At that location there's a fair LTE signel east in Picture 2.  I bet your connected to that one and they might be doing some sort of upgrades.

More to the NW and SW sprint LTE towers with good signal but for your location on High Road and Goforth more LTE tower should be coming in a couple months which should boost your LTE coverage at that location. In Picture 1 your 3G should improve after a couple months.

This picture is from using sensorly app and there's no data speed testing using this app yet. You should try it out.

Oh and If you can screen shot your RSRP signal strength at that location it might show if the readings are too low which could give you the sudden drop of data speed either 3G or LTE.

Note: I'm not a sprint Rep just helping out.

Picture 1 Below:

Screenshot_2013-12-17-14-19-15.png

Picture 2 Below:

Screenshot_2013-12-17-14-19-32.png

Community News

Need Help? 
Please try Searching the Community, we have many questions already answered, you can also check out the Knowledge base.
If you have an account question you can create a post and one of our Social Care Agents will help you.
If you need immediate assistance please visit Sprint Chat