cancel
Showing results for 
Search instead for 
Did you mean: 

What is draining my battery?

Go to solution
Highlighted
Journeyman

What is draining my battery?

One evening last week, my LG G3's battery was down to 5%.  I re-charged it to 100%.  The next morning when I tried to turn the phone on, I got a message that the battery was at 0%.  When it charged enough to show notifications, it showed that Wifi was on even though I had turned it off the night before.  This morning, I found that the battery was down to 25% and wifi was turned on even though I had turned it off.  I've been re-charging when the battery reaches 50%, so I've never seen numbers this low before.

1. How is Wifi getting turned on?

2. What could be using so much power that it is draining the battery?

3. How do I get this stopped?

I've only had a smartphone for two months, so I'm not up to speed on a lot of these things.  Any help would be appreciated.

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Journeyman

It resets and defaults to on if you go back to the settings for it. If you uncheck the box it should stay off. Unfortunately we just have to take Sprint's word for this as it turns itself back on if you try to check it. It's a bad setup for a bad application.

View solution in original post

5 REPLIES 5
Highlighted
Journeyman

Sprint's "Connection Optimizer" is likely the problem. This thing is supposed to help by finding you the best connection possible, but in reality all it seems to do is keep dropping connections, switching services, turning wi-fi on randomly and sucking the battery life out of your phone.

To turn off go to Settings:

Select More under Wireless Networks

Select Mobile networks

Select Connections optimizer

Uncheck the Sprint Connections Optimizer checkbox

Turn your phone off and back on

Highlighted
Journeyman

Thank you for the information.  I followed the steps as suggested.  The first time, I simply re-booted.  When I went to the Connections Optimizer settings, the check mark had re-appeared.  I unchecked it; but this time I turned phone all the way off and then turned it back on.  Again, the check mark had re-appeared.  I went off to do something just leaving the phone on.  When I came back, I went to the connections optimizer settings and the check mark was back again.  I, also, have navigated away from that page repeatedly and every time, the check mark has come back.

Are there other steps that I can take?

Highlighted
Journeyman

It resets and defaults to on if you go back to the settings for it. If you uncheck the box it should stay off. Unfortunately we just have to take Sprint's word for this as it turns itself back on if you try to check it. It's a bad setup for a bad application.

View solution in original post

Highlighted
Journeyman

Thank you for your response.  It makes more sense than other suggestions that I've seen.

Last night, I turned the phone all the way off before I went to bed.  When I turned it on this morning, everything was fine.

I have noticed that when I go to wi-fi, it keeps searching and searching for a connection even though it already has the best one.  It stops searching for about 8 seconds and then starts again.  I've started keeping wi-fi turned off unless I am actually using it.

I went to settings >> More (under wireless networks) >> Mobile networks >> Connections optimizer and turned it off for one last time.  Now if I can just keep myself from going back there to check on it 🙂

I'll post back when I see how it does.

Highlighted
Journeyman

I changed my rating from helpful to correct.  Thank you, so much!  I have managed to not go back to that settings page, and everything has been fine!!  Again, thank you!

Community News

Our Community is BACK!!
Hours of Operations are 7AM - 8PM CST. Please try Searching the Community, we have many questions already answered, you can also check out the Knowledge base
If you need immediate assistance after hours please visit Sprint Chat