Sprint Community is Read Only. Please use the My Sprint app or Sprint.com to manage your account. If you need assistance, please visit Sprint.com/chat or visit community.t-mobile.com
Sprint Community is Read Only. Please use the My Sprint app or Sprint.com to manage your account. If you need assistance, please visit Sprint.com/chat or visit community.t-mobile.com
Sprint Community
cancel
Showing results for 
Search instead for 
Did you mean: 

Poor 3g connection speeds

Go to solution
Journeyman

Poor 3g connection speeds

I just upgraded to the LG Optimus G from an EVO 3d.  I love my new phone but I notice that my 3g connection speed is pretty slow.  When I run Tunein Pro as I always do at work, it buffers every 10 seconds.  I used to do this on my Evo 3d at the same location with no problems.  I changed the buffer setting to allow for smoother playback but no luck.  I checked the speed of the 3g and it is around 150kbs.  On my old phone I would at least get over 500kbs.  I was just streaming Tunein Pro to my phone on Friday before I got this new phone and no problems..  I am not sure what is going on but it seems like this is an issue with the LG. 

Has anyone noticed this from this phone yet?

1 ACCEPTED SOLUTION

Accepted Solutions
Wizard

I am sorry to hear that you are having issues with your 3G data connection. 

Go into settings<under wireless and network select more< then mobile networks< and ensure network mode is set to LTE/CDMA.

Then go into settings<system updates<update PRL and profile

View solution in original post

7 REPLIES 7
Wizard

I am sorry to hear that you are having issues with your 3G data connection. 

Go into settings<under wireless and network select more< then mobile networks< and ensure network mode is set to LTE/CDMA.

Then go into settings<system updates<update PRL and profile

View solution in original post

Journeyman

I do not have that phone, but I get EXTREMELY poor 3G speeds. I am talking .05 mbps download. My town is AWFUL with sprint. But, sprint has been having problems with their 3G speeds. Just be patient to see if the problem gets resolved.

Journeyman

Thanks a lot. That worked. My connection speed it's back where it was.

Wizard

Awesome, glad to hear.

Journeyman

I keep losing 3G altogether. The symbol disappeares until I reboot. This is in NYC. It didn't happen on my EVO 4g.

Wizard

STEVENNYC71,

I am sorry to hear that you are having issues with your 3G data connection. Can you please be a little more specific with your location?

Journeyman

Well it happens in Queens and Brooklyn.  Its not specific to any area.  So far it has happened at least 10 times.  My wife has the iphone 5 and although her 3G symbol does not dissapear she will have all her apps give a "no connection detected" message until she reboots.  If my optimus G the symbol the dissappears and i have no data connection at all until i reboot the phone.  Any suggestions?

Community News

Sprint Community is Read Only. Please use the My Sprint app or Sprint.com to manage your account. If you need assistance, please visit Sprint.com/chat or visit community.t-mobile.com
Please try Searching the Community, we have many questions already answered, you can also check out the Knowledge base
If you need immediate assistance after hours please visit Sprint Chat