cancel
Showing results for 
Search instead for 
Did you mean: 

LG Optimus S phone mass storage dilemma

SOLVED
Highlighted
Journeyman

LG Optimus S phone mass storage dilemma

LG Optimus S phone.   Trying to view the mass storage device on my home computer and when I plug in the USB cable it does not recognize the device and it does not prompt the screen on the phone to allow me to select mass storage device.   How do I get the phone to give me a menu of options when I plug in the USB cable?   I have a new computer running windows 7 and the phone will not display when I view my computer even though it is connected with the USB cable.  

4 REPLIES

Re: LG Optimus S phone mass storage dilemma

You need to check to make sure you have USB debugging unchecked on your device.  You do this by going to the home page on device, menu, applications, development and make sure USB debugging is unchecked.  After that plug the device back into PC and see if you get the notifications.

Journeyman

Re: LG Optimus S phone mass storage dilemma

I am having the same problem and this solution did not help.

Wizard

Re: LG Optimus S phone mass storage dilemma

If you made sure that USB debugging is disabled, and you still don't get the notification on your phone to activate the mass storage option, then you may want to check your cord.  Make sure the cord is truly a micro-USB cord, and not a $1 charging cable from eBay.

Journeyman

Re: LG Optimus S phone mass storage dilemma

I had the same EXACT problem and am also running Windows 7.  I searched and searched and found that all of the responses, like you found, didn't work for me either.  You know what I did to finally get it working?  I reformatted my SD card.  Yep, that's what I said...REFORMATTED my SD Card.  First, I moved everything that I know I use from my SD card (microSD that is) to my computer.  Then I reformatted it using my LG Optimus.  Once I put it back into my computer to copy everything back over to the card, Windows 7 prompted me to format the card before I could use it, so I did.  I copied everything back after that, crossed my fingers, put the card back in my phone and booted it up.  Guess what?  It WORKED!  If you haven't found a solution as of yet, give this a try, but PLEASE make sure you COPY EVERYTHING from your card to your computer before doing this.  That is, copy what YOU WANT TO KEEP (e.g., pics, videos, apps you moved to your card that were d/l from the market, etc.).  Otherwise, you'll lose all of this.

I hope this helps and for anyone else having this problem.  Debugging, installing a Mass Storage app, everything else DID NOT WORK.  Only FORMATTING my microSD Card worked.  Glad I could find a solution that may help others as it finally solved my problem!   Oh and btw, it had NOTHING TO DO WITH any cables, either.  Just thought you should know!