cancel
Showing results for 
Search instead for 
Did you mean: 

Overdrive 100% signal, not connected - in limbo

Journeyman

Overdrive 100% signal, not connected - in limbo

I became a Sprint customer for the first time in late December when I bought an Overdrive to use with my Laptop. iPad and iPhone when traveling.

I've been disappointed with the Overdrive recently as it frequently won't connect, the screen on the unit AND the unit's admin page show 100% 4G coverage but status is not "connected" nor is it "dormant" nor "Not Connected" its just blank.

I've attached a screen shot from my iPhone

Has anyone else had this issue?

Is there a workaround other than pulling battery and / or pushing reset button?

Pete

6 REPLIES 6
Highlighted
Journeyman

Re: Overdrive 100% signal, not connected - in limbo

You can try to update the device by going to http://overdrive in your browser and log into the admin page. Go to Advanced Settings > WAN (tab) > Update 3G Profile (button) then hit save.

If this doesn’t work you will want to check your firewalls and the following for your browser configuration:

Internet Explorer: Tools> internet options>connections> verify Never dial a connection is selected or that the Sprint PCS connection is set as the default> verify no proxy information is listed by clicking settings, verify use a proxy server for this connection is unchecked.

For Mozilla Firefox:Tools>options>general>connections settings> verify Direct connection to the Internet is selected

Last is to reset the device to original settings: Go to http://overdrive> access the admin page> Advanced settings> device> about> reset device to factor defaults> confirm you want to do this by selecting yes> unit will reboot, you will need to reaccept the terms and conditions and redo your security settings if you had them prior> try to establish a connection to the internet and browse sites

Did this help? If so please rate this posting to help other find it easier.

Message was edited by: DenverLindsey

Highlighted
Journeyman

Re: Overdrive 100% signal, not connected - in limbo

Lindsey

Thanks for those suggestions I checked everything on my system in Win 7 and the settings were correct.

I activated my Overdrive today and after the first 20 mins when things seemed to be impressive it has now been HOURS of trying to resolve connectivity issues. Most of which seem directly related to any attempt to use this as a WIFI hotspot.

I am able to connect to the internet so long as I am using the the desktop this device is tethered to but/unfortunately without moving this device and in a line of sight to the nearest cell tower which is maybe a block away my signal without moving the overdrive will vary from poor (zero bars) to Good (60%)

I have internet access with the desktop but only 'periodic' with a laptop or iPod Touch via wifi

this is ridiculous actually 'pathetic' would be more accurate ... I took the 'word' of a tech at a retail location who lives only a few miles from me and swore this was a great setup. For the last two years I have been using a sierra data card routed through a wireless router and located in the exact same part of the house as the overdrive is placed and without an incident now have NO reliable internet connection

One other interesting aspect is after years as a Sprint customer I can't begin to tell you how disappointing CS has been today.

At one point I had a Rep trying to tell me that it was impossible to run the Overdrive while tethered and still receive wifi ... I found that humorous as I was reading the user manual as she attempted to tell me this and proceeded to tell me I was wrong.

After being a Sprint user for 8 years this has been the Worst customer service experience (at one point being on and off hold for OVER AN HOUE without resolution just bounced from rep to another) even if I have to go back to the old setup it will take a min of two days to resort the office and just to get back to what was a marginally to slow data rate to begin with ... I am at a point of ditching Sprint all together.

It's 9:20 pm locally I started working on this around 2:30 this afternoon ... very very very frustrating (to say the least)

Highlighted
Journeyman

Re: Overdrive 100% signal, not connected - in limbo

Just a post script

in addition to just the 'basics' of internet access

the Internet Radio we've been enjoying is completely useless with this device

Sprint needs to go back to school and get this POS corrected ASAP

Highlighted
Journeyman

Re: Overdrive 100% signal, not connected - in limbo

I would like to see this resolved for you. If you like, please send me your contact number in a Private Message and we can look into this and find you a resolution.

Highlighted
Journeyman

Re: Overdrive 100% signal, not connected - in limbo

It is very frustrating that I have a 60% singal and get 4G Connection Error (4) all the time while I am in Hartford. This has been happening for 2 weeks now. At first the reset Profile would work now that will not work and lately I am finding that place it worked prior will no longer work on 4G. Any help would be great on this.

Highlighted
Journeyman

Re: Overdrive 100% signal, not connected - in limbo

Lindsey

That was a kind offer however this morning I opted to just give up instead. No one at Sprint tech support had any answers what so ever on top of which this morning the device quit 'charging' while tethered via USB to the desktop and since no wireless devices would connect it had No devices accessing it ... sure it might have been just a faulty device but I work out of my home and 24 hours of down time is unacceptable while no one lifts a finger to help.

So I went back to my old Sierracard but to add insult to injury I had an unlimited data plan at $59 a mo and when the Overdrive was activated I was told via phone that I needed a new data account established when I was having the old account reinstated this morning I was informed that the unlimited plans at that rate no longer apply and since I changed it I lost it and now am stuck with the 5 GB and overage/roaming charges in order to get my old card back.

So that's what Sprint did to me after 8 years as a customer. Ok for now but I am going to return the $50 reward from November and the 2 yr contract and begin shopping for all new provider. This treatment of a loyal customer was simply inexcusable.

You guys just succeeded in making ATT look good and you'll never know how much screwing up that took.

Community News

Need Help? 
Please try Searching the Community, we have many questions already answered, you can also check out the Knowledge base.
If you have an account question you can create a post and one of our Social Care Agents will help you.
If you need immediate assistance please visit Sprint Chat