Sprint Community is Read Only. Please use the My Sprint app or Sprint.com to manage your account. If you need assistance, please visit Sprint.com/chat or visit community.t-mobile.com
Sprint Community is Read Only. Please use the My Sprint app or Sprint.com to manage your account. If you need assistance, please visit Sprint.com/chat or visit community.t-mobile.com
Sprint Community
Showing results for 
Search instead for 
Did you mean: 

Program your Sprint 3G/4G USB Modem 250U by Sierra Wireless for Mac


Program your Sprint 3G/4G USB Modem 250U by Sierra Wireless for Mac

So, I just purchased a new MacBook Pro (15-inch, Early 2011, Sandybridge Core i7 2.3 GHz with Snow Leopard) and I get everything nice and installed and expect everything to work nearly as expected as on my old MacBook (13-inch, Aluminum, Late 2008, Core 2 Duo 2.4GHz with Snow Leopard).  When I launch SmartView for the first time I get the following dialog.

Just for reference

Old: Darwin Zim.local 10.6.0 Darwin Kernel Version 10.6.0: Wed Nov 10 18:13:17 PST 2010; root:xnu-1504.9.26~3/RELEASE_I386 i386

New: Darwin TheMassive.local 10.7.1 Darwin Kernel Version 10.7.1: Mon Jan 31 14:55:53 PST 2011; root:xnu-1504.10.48~4/RELEASE_X86_64 x86_64

no 64-bit support.png

Ok, only a slight difference, this shouldn't be too bumpy a ride.  MacOS has been 64-bit for years now and Snow Leopard is the second release of it.  The fact there's this kernel difference (10.6 to 10.7) shouldn't be too gating a factor after all it's still Snow Leopard and it's been out for 6 minor releases, mainstream.  Sprint has been doing 4G for quite some time, albeit in limited scope.  The installer never warned me of any problems and so everything should be good, right?

Before I continue, I should mention that I am a technical professional, I'm not exactly new to being an "Early Adopter" and at the time of this posting I've already tried several permutations of trying to "just make it work".  These include starting off by just installing the latest and greatest from sprint.com/downloads, Sierra's own driver set, starting at the CD and upgrading through the patch levels.  I also looked at the Linux instructions which only provide 3G connectivity for this 4G (although the support document made available states that it was updated to include support for this 4G device) which only supports customers on the 3G network for the 4G device.

I am able to get a 3G connection on my 4G modem just fine (this is because it's MacOS X Core handling a pretty standard device, a USB modem using a PPP interface) but no WiMax (4G).  Several hours into this discovery, I'm starting to get pretty upset because this not working greatly affects my workflow.

I suppose I should get to the point.  Is anyone else having this problem?  Has anyone solved it yet?  Maybe I should ditch Sprint and go with a provider dedicated to supporting viable technologies and futures.  I did the same with AT&T and their failure of a 3G rollout.  Is it time to call Sprint's 4G rollout a failure?  Here I thought these guys were turning around.

Sprint Product Ambassador

Thanks for the post -- I've moved your post to our Mobile Broadband space.  I've also reached out to the product owner for the Smartview software.

Congrats on the new Mac laptop!


Product Ambassador, long time Sprint employee

I have the same issue and spoke to about five reps about this issue only to come to one rep that was willing to take the time out and help find an answer for me. seem that Sprint have to wait until Apple approve the Sprint SmartView software for the mac 64-bit. spent countless amount of time on the phone just to be turned around. I was also told that I have to keep checking the site to see if an update have been post. Like seriously? How come I have to take time out my busy day to check for a software that should have already been tested and released prior to the new macbook refresh? Why isn't there a sign up page for new software updates so all customer can stay informed? Sprint have been good to me but this is pushing it.


I had the same problem with my new macbook pro 2011. Turns out that for what ever reason the smartview software will not work at this time. duh! I spent many hours with Apple and the sprint techs (on the phone and in person) What I did was cradled the card and bypassed the smartview. Works great now. Of course you will have to spend money but after I spent over 2K on a machine I would had done about anything to get it running correctly. The other solution is to wait until the drivers are updated. I hope this helps....


Wow, are you kidding me!?!?  I've been experiencing the same thing (new MBP 2.3 i7 mid-March 2011 15" model)... Did a fresh install and used the CD that came with my card to install Smartview.  Got the same error message on startup and have been unable to connect to 4G.

Just formatted the computer and figured I'd download the most recent software from sprint.com/downloads instead of the CD and try again... some problem.

What's the deal here Sprint/Apple?  Any timeline on when this will be fixed???  Is this an issue with this "older" 4G USB card from Sierra Wireless only?  Do the other/newer Sprint 4G cards not have the same experience?

I'm glad I was finally able to find others online with the same frustrating experiences...



My macbook is a little over a year old now and even this thing wont connect to 4G using the Sierra Smartview app. It will connect to 3G just fine and doesn't even bother connecting to the 4G. It always tells me I have either no signal or 1 or 2 bars but it won't connect anyway. I am using the USB U600 and it works just fine on my Windows Desktop. In fact it runs like a breeze on Windows. When I hook it up to my Mac I'm lucky to even get a connection. I had to buy a cradlepoint router just to be able to get my macbook online. This is rediculous how could Sprint release software that does not work. I have only had Sprint for about 2 and a half months and I already want to cancel.

P.S. When it does connect it doesn't stay connected for longer than 5 minutes at a time and then it takes like another 20 minutes to connect. I have never fiddled with any settings so it can't be my fault.


Sprint refuses to acknowledge there is a problem. I spent 4 hours (yes, 4 hours today) trying to resolve this issue with Sprint. Spent an hour at a Sprint technical repair center (the gold standard of Sprint care). The rest of my time was spent on the phone with 5 different technical/customer service reps. The tech at the Sprint repair center could not make the 4G connection work with the modem (the repair center is in a 4G area). He told me that Sprint is not selling the 250U Sierra Wireless modems for Macs any longer as they do not work with the new Macs. In fact, the 250U is no longer carried on Sprint website. The last update to the Mac Snow Leopard software on the Sprint site is 1/25/11.

Every tech I talked to wanted to "troubleshoot" the problem. They insisted the problem is with my "new" computer. Actually the problem is with Sprint's "old" software. No one I talked to (and I talked to 5 supposed supervisors) would acknowledge that Sprint was selling a product they represented would work on a Mac with Snow Leopard 10.6.7 but in reality, does not work with the latest Core i7 Macs released in Q1 2011. If they did acknowledge this, they would be liable for reimbursing customers for each month of service customers paid for without access to the 4G network. That would be a pretty big $$$ number. They are, in effect, charging Mac customers for a product that does not work.

The stonewalling I received was unbelievable. Several reps were downright rude when i specifically told them what I wanted to remedy the situation. In all fairness, two of the reps were trying to be helpful but offered no information. The fact is, until Sprint releases appropriate software that will make their products actually work, it appears they are going to stonewall knowledgeable customers who press the issue.

I would like to hear from ANY person using a Sprint 250U with Snow Leopard on a new MacBook Pro Core i7 machine. My guess is there are none. You can email me at: RI@TDS.NET. The fact is if you do have it working you know something everyone reading this post wants to know and everyone at Sprint needs to know.


Yep, same problem.   When I absolutely HAVE to use the Sprint card natively I boot to 32 bit mode, but have a hotspot (from Cradlepoint) that I use when I can to prevent me from having to boot into 32 bit mode.   If they have not fixed this by the time Lion shows up I will likely switch providers to someone that actually supports the Mac environment....


I know that most posters are looking for updated software but I was able to help one of my users (I am Telecom where I work) with a new Mac Powerbook over come this issue by getting him this, Overdrive Pro 3G/4G Mobile Hot Spot by Sierra Wireless.  It sends a wireless signal, the laptop found it no problem.  Perhaps if you are near the end of your contract on your current WiFi stick you can leverage this as your next upgrade at a reduced cost.


Yeah, good suggestion carallen.   I already have a PHS-300 cradlepoint, which essentially turns my 250u into an Overdrive.   Works great, just want to be able to whip out the 250u and plug it in instead of finding multiple components.   Would REALLY like Sprint to address this issue.  I expect they will have to address it when Lion comes out and the Apple install base all starts to become 64 bit, or they will start losing their Apple customers.    Somehow I think that 'changing your device' is not a good answer for a company that is already having a hard time keeping their customers....


What a disappointment.  Booting into 32 bit mode is an unacceptable solution.  Customers should be informed up front that this will simply not work for new macbook pros.  Good thing I'm still within my 30 day cancellation window.


Hey all,

     I have been testing this out on early '11 MBP Sandybridge i7 QuadCore and I can confirm this does appear to be a legitimate issue, I'm still testing it out. I can confirm with original poster you can get the 3G connection to work just fine by creating a manual connection via network and preferences as a work around, I know that doesn't help anyone living in a 4G area but if anyone wants those steps I can post them, but I'm still trying to find a solid way of getting the connection to work via Sprint Smart View in order to use the 4G connection.

Community News

Sprint Community is Read Only. Please use the My Sprint app or Sprint.com to manage your account. If you need assistance, please visit Sprint.com/chat or visit community.t-mobile.com
Please try Searching the Community, we have many questions already answered, you can also check out the Knowledge base
If you need immediate assistance after hours please visit Sprint Chat