Sprint Community is Read Only. Please use the My Sprint app or Sprint.com to manage your account. If you need assistance, please visit Sprint.com/chat or visit community.t-mobile.com
Sprint Community is Read Only. Please use the My Sprint app or Sprint.com to manage your account. If you need assistance, please visit Sprint.com/chat or visit community.t-mobile.com
Sprint Community
Showing results for 
Search instead for 
Did you mean: 

Program your Sprint 3G/4G USB Modem 250U by Sierra Wireless for Mac


Program your Sprint 3G/4G USB Modem 250U by Sierra Wireless for Mac

So, I just purchased a new MacBook Pro (15-inch, Early 2011, Sandybridge Core i7 2.3 GHz with Snow Leopard) and I get everything nice and installed and expect everything to work nearly as expected as on my old MacBook (13-inch, Aluminum, Late 2008, Core 2 Duo 2.4GHz with Snow Leopard).  When I launch SmartView for the first time I get the following dialog.

Just for reference

Old: Darwin Zim.local 10.6.0 Darwin Kernel Version 10.6.0: Wed Nov 10 18:13:17 PST 2010; root:xnu-1504.9.26~3/RELEASE_I386 i386

New: Darwin TheMassive.local 10.7.1 Darwin Kernel Version 10.7.1: Mon Jan 31 14:55:53 PST 2011; root:xnu-1504.10.48~4/RELEASE_X86_64 x86_64

no 64-bit support.png

Ok, only a slight difference, this shouldn't be too bumpy a ride.  MacOS has been 64-bit for years now and Snow Leopard is the second release of it.  The fact there's this kernel difference (10.6 to 10.7) shouldn't be too gating a factor after all it's still Snow Leopard and it's been out for 6 minor releases, mainstream.  Sprint has been doing 4G for quite some time, albeit in limited scope.  The installer never warned me of any problems and so everything should be good, right?

Before I continue, I should mention that I am a technical professional, I'm not exactly new to being an "Early Adopter" and at the time of this posting I've already tried several permutations of trying to "just make it work".  These include starting off by just installing the latest and greatest from sprint.com/downloads, Sierra's own driver set, starting at the CD and upgrading through the patch levels.  I also looked at the Linux instructions which only provide 3G connectivity for this 4G (although the support document made available states that it was updated to include support for this 4G device) which only supports customers on the 3G network for the 4G device.

I am able to get a 3G connection on my 4G modem just fine (this is because it's MacOS X Core handling a pretty standard device, a USB modem using a PPP interface) but no WiMax (4G).  Several hours into this discovery, I'm starting to get pretty upset because this not working greatly affects my workflow.

I suppose I should get to the point.  Is anyone else having this problem?  Has anyone solved it yet?  Maybe I should ditch Sprint and go with a provider dedicated to supporting viable technologies and futures.  I did the same with AT&T and their failure of a 3G rollout.  Is it time to call Sprint's 4G rollout a failure?  Here I thought these guys were turning around.


This is old news, it has not worked on macs for months and there is no sign that sprint is even trying to update there software. That's where the problem is. (smartview). The solution is to cradle it, by doing this you will bypass the software that sprint provides and it works just fine. I have been using it on 4g for months now. hope that helps you.

P.S. there is no need to research this issue, the smartview software does not work on Mac OSX 10.6.7.  That's a fact....


Yes, it is a fact.  And sales people need to stop telling people 4g will work on a new macbook pro with one of these devices.  Everyone understands that sometimes software is late or slow to roll out, but telling customers it will work when it simply will NOT is very bad business.


Hello all,

     Just wanted to give everyone an update let you know I haven't forgot about this issue, I'm hopeful I should have an update for everyone soon on a resolution.


I am also having this issue.  Very disappointed in the service provided through sprint.


Sprint has been slow to deal with this. Months have gone by. Many of us actually need to run our Macs in 64 bit mode for the work we bought the Macs to do, so rebooting into 32 bit mode is not going to cut it. I do use a Cradlepoint when I have to, but like others, there's reasons to want to just plug in directly at times. More than that, there's a desire to see that the carrier to whom we give lots of money is willing to support the product and service.

I am trying out a Verizon 3G/4G solution as an alternative. The 4G speed, in the few places where available, is good. On 3G, the Sprint performance is better (but requires a Cradlepoint). If Verizon can fix their issues, Sprint loses my business. It's that simple.


Hey everyone,

     I understand this is frustrating and I know it's very inconvenient. After escalating this issue through the proper channels, I have learned we are working on an update to resolve this issue and it should be ready soon. I'm sorry for the lack of communication and service due to this issue.


Now that I'm running FileVault on Lion, it's extremely inconvenient to switch to 32bit mode. I have to do this from the commandline, since holding 3 and 2 at boot doesn't seem to work.

It's been months, guys, get it together.


I'll add a pointer here for the folks following this thread.

Sprint is behind the curve here, Clear has posted a beta version of their connection manager that contains the necessary kext to make 4G work on 64-bit Snow Leopard and Lion. I've tested it on the U600, but it looks like just about all the USB WiMAX modems use the same BCSM250 chipset.

Post in another thread here: http://community.sprint.com/baw/message/316836#316836

Post at EVDOforums with more detail: http://www.evdoforums.com/viewtopic.php?p=85948



     Thank you for the great post. I've sent this information to the proper channels to get this information out there in order to help other customers experiencing these issues. Hopefully this may help us update our Sprint SmartView software faster too, thanks again!


I'll join in as another with the same problem. I have a one-month-old MacBook Pro with Leopard 10.6.7 and I recently got Sprint's U600 device. I work on the road and 3G has come in great every place I've tried it so far, but 4G didn't work in Cincinnati, Nashville or Atlanta. I went to a Sprint store and also called customer service, but neither could help. I haven't given away my old Windows laptop yet, so I installed the U600 on it and 4G came in immediately in Atlanta. The problem is obviously with my Mac, or maybe I should say that the problem is obviously that SmartView doesn't get 4G with Macs. A Sprint tech named Shane M. in this thread says that Sprint should have the problem fixed soon, so hopefully that will happen. Thanks for working on this, Shane, and please keep us updated.


So do you think it's concompetence or deliberate deceit that tech support and sales continues to act dumb about this?


Bengass, I am pretty sure its incompitence on sprints part.  Sprint has no support for mac as they have shown.  Thanksfully there is no monopoly on wireless broadband and verizon has pretty good support.  Proof you get what you pay for.

Community News

Sprint Community is Read Only. Please use the My Sprint app or Sprint.com to manage your account. If you need assistance, please visit Sprint.com/chat or visit community.t-mobile.com
Please try Searching the Community, we have many questions already answered, you can also check out the Knowledge base
If you need immediate assistance after hours please visit Sprint Chat