cancel
Showing results for 
Search instead for 
Did you mean: 

Sierra Compass 597u & Windows XP SP3 issues

Journeyman

Sierra Compass 597u & Windows XP SP3 issues

Can anyone confirm that the embedded version of the Sprint software / drivers in the 597 are or are not compatible with XP SP3? I have a brand new fresh install of XP Home SP3 on an Acer notebook and cannot get the dang 597u to work. It worked fine with the same PC before the reload. Basically it had a ton of viruses and spyware that needed cleaned. It was simpler to format and reinstall than to try to clean it. Previously the notebook was running SP2. After installing Windows with SP2 this time, I went ahead and ran all the updates before installing the 597u device. I have WiFi at home via cable modem. I didn't try the Sprint connection until I had left home for the day.

19 REPLIES 19
Master

Re: Sierra Compass 597u & Windows XP SP3 issues

There should not be any issues with SP3 compared to SP2. The only difference between the two Service Packs are regular security updates, nothing as drastic as the change from SP1 and SP2 (Which was a major difference from any normal Service Pack). Didn't have any issues on a fairly fresh install on my father's computer running XP SP3. I was using the latest 1.20 SmartView however not the 1.18 software that is embedded on my 597u.

Journeyman

Re: Sierra Compass 597u & Windows XP SP3 issues


@halcyoncmdr wrote:
There should not be any issues with SP3 compared to SP2. The only difference between the two Service Packs are regular security updates, nothing as drastic as the change from SP1 and SP2 (Which was a major difference from any normal Service Pack). Didn't have any issues on a fairly fresh install on my father's computer running XP SP3. I was using the latest 1.20 SmartView however not the 1.18 software that is embedded on my 597u.

I think that might be the issue, but removing the 1.18 version is proving to be harder than I would expect it to be. I am finding other posts on the net saying that you need to do a system restore to really remove it. Too bad I have system restore turned off. Any chance you know about the exact location of files and registry entries need to be removed?

Master

Re: Sierra Compass 597u & Windows XP SP3 issues

As long as you uninstall through the Add/Remove Programs, reboot then just make sure that any folder in "C:\Program Files\" labeled either "Sprint" or "Sierra" are deleted. That should remove what needs to be gone for a clean installation. I have never had to do a system restore to remove SmartView. Anyone who says that is required doesn't know what they are talking about.

As always reboot after removing everything just to ensure there's nothing still running in memory.

Message Edited by halcyoncmdr on 01-28-2009 03:14 AM

Journeyman

Re: Sierra Compass 597u & Windows XP SP3 issues


@halcyoncmdr wrote:
As long as you uninstall through the Add/Remove Programs, reboot then just make sure that any folder in "C:\Program Files\" labeled either "Sprint" or "Sierra" are deleted. That should remove what needs to be gone for a clean installation. I have never had to do a system restore to remove SmartView. Anyone who says that is required doesn't know what they are talking about.

As always reboot after removing everything just to ensure there's nothing still running in memory.
Message Edited by halcyoncmdr on 01-28-2009 03:14 AM

I will try that approach and report back with my results. I appreciate the swift reply.

Journeyman

Re: Sierra Compass 597u & Windows XP SP3 issues

Ok, here is what I have done so far. I uninstalled the Sprint software via the Control Panel Add/Remove Programs. I also deleted the Sierra folder in the Program Files directory. Then rebooted the PC.

Next, I installed the latest version of the Sprint SmartView for Windows version 1.20.0016.0 that I downloaded from www.sprint.com/downloads. Once installed, it prompted me to reboot, which I did.

With Windows rebooted, I now inserted the 597 into the USB port. It detected the various components and installed the drivers without any prompt. Once all of the drivers were finished installing, I rebooted Windows one more time for good measure.

With Windows rebooted again, I now attempted to use the Sprint SmartView program. It showed the modem was connected and receiving an 80% EVDO signal. When I hit the connect button, it took a little while then came back withthe error below:

Error 651: The modem reported an error.

I then shut down the PC, removed the 597 from the USB port, started the PC, waited for Windows to fully load, then reinserted the 597 into a different USB port. Waited for the drivers to load, then rebooted again.

With Windows fully loaded again, I attempted to use the Sprint SmartView application again. This time it gave me the following error below:

Error 691: Access denied due touser name and/or password being invalid.

Now I have rebooted many times and reinserted the modem into various USB ports (3 in total) and every time I receive one of the two error messages above.

Any further assistance would be very appreciated.

Message Edited by jondilly1974 on 01-28-2009 04:08 PM

Master

Re: Sierra Compass 597u & Windows XP SP3 issues

Have you checked to make sure there are no exclamation points in the Device Manager? You can get to it by right-clicking on "My Computer" and selecting "Manage" It will be in the listing on the left of the window that comes up. If there are any exclamation points in the right side it most likely is a driver that didn't install correctly. If that is the case you can right click on the icon and select "Update driver software". Select "Browse my computer" and in the box type "C:\Windows\System32\Drivers\". It should load a compatible driver in automatically.

I don't know what those error codes mean, so the best suggestion I have is to call technical support if the drivers are all loaded and its just erroring out on you.

Journeyman

Re: Sierra Compass 597u & Windows XP SP3 issues


@halcyoncmdr wrote:
Have you checked to make sure there are no exclamation points in the Device Manager? You can get to it by right-clicking on "My Computer" and selecting "Manage" It will be in the listing on the left of the window that comes up. If there are any exclamation points in the right side it most likely is a driver that didn't install correctly. If that is the case you can right click on the icon and select "Update driver software". Select "Browse my computer" and in the box type "C:\Windows\System32\Drivers\". It should load a compatible driver in automatically.

I don't know what those error codes mean, so the best suggestion I have is to call technical support if the drivers are all loaded and its just erroring out on you.

Yeah I am sure that all the drivers are loading without errors. There are other devices that I am worried about conflicting with the 597 though. The notebook has a 56k modem, 100mb LAN, and 802.11b/g WLAN built in. When the SmartView software installed the EVDO and CDMA dial-up connections, it assigned them to the 56k modem. I did change the modem associated with those connections to the appropriate virtual modems. I have tried to simply connect through those connections as well, to no avail. The next step will be to walk it in to the Sprint store. I like to self support myself so I can fix issues in the future, but this one has me stumped.

Master

Re: Sierra Compass 597u & Windows XP SP3 issues

<blockquote><hr>jondilly1974 wrote: <br> <blockquote><hr>halcyoncmdr wrote:<br>Have you checked to make sure there are no exclamation points in the Device Manager? You can get to it by right-clicking on "My Computer" and selecting "Manage" It will be in the listing on the left of the window that comes up. If there are any exclamation points in the right side it most likely is a driver that didn't install correctly. If that is the case you can right click on the icon and select "Update driver software". Select "Browse my computer" and in the box type "C:\Windows\System32\Drivers\". It should load a compatible driver in automatically.<br><br>I don't know what those error codes mean, so the best suggestion I have is to call technical support if the drivers are all loaded and its just erroring out on you.<hr></blockquote><p></p>Yeah I am sure that all the drivers are loading without errors. There are other devices that I am worried about conflicting with the 597 though. The notebook has a 56k modem, 100mb LAN, and 802.11b/g WLAN built in. When the SmartView software installed the EVDO and CDMA dial-up connections, it assigned them to the 56k modem. I did change the modem associated with those connections to the appropriate virtual modems. I have tried to simply connect through those connections as well, to no avail. The next step will be to walk it in to the Sprint store. I like to self support myself so I can fix issues in the future, but this one has me stumped. Smiley Sad<hr></blockquote><br><br>I have never seen the SmartView software assign the connections to a 56k modem before... Unfortunately though I don't really have any other ideas.

Journeyman

Re: Sierra Compass 597u & Windows XP SP3 issues


@halcyoncmdr wrote:

I have never seen the SmartView software assign the connections to a 56k modem before... Unfortunately though I don't really have any other ideas.

Well I do appreciate your assistance. I will report back if I find the solution.

Journeyman

Re: Sierra Compass 597u & Windows XP SP3 issues

I am having problems getting the Sierra 597 to work with XP SP3.

I am a new customer, and have never gotten this modem to work very well. I can connect only sporadically. Most of the time, when I try to connect, I get the "blue screen of death."

I've tried using three different computers: a Dell laptop, an Acer netbook, and an Asus netbook. The Acer and the Asus were brand-new, right out of the box. The result were the same with all three computers. Modem is detected, and installs fine. But when I click on "connect," I get the blue screen of death.

I've updated my BIOS, my drivers, and Windows. No difference.

I called Sprint, and they were very nice, but didn't have a clue what was wrong. They sent me a new modem, but it made no difference. I still get the Blue Screen of Death.

It's driving me crazy. I'm paying $60 a month, but can't connect.

Any help gratefully accepted.

Master

Re: Sierra Compass 597u & Windows XP SP3 issues

Blue screens are usually a driver issue. When it blue screens what is the error it lists? It should be something like STOP 0x0000000000 and it may say something like IRQL_DRIVER_NOT_LESS_OR_EQUAL or something.

If it is too fast to see you can disable the automatic restart by right clicking on My Computer and selecting properties. Select the advanced tab, Startup and Recovery, uncheck "Automatically Restart" under System Failure.

In addition to that what version of the SmartView software are you using?

Community News

Sprint S.M.A.R.T Agents
Sprint S.M.A.R.T Agent are here to help Monday through Sunday 6:00 AM CT - 6:00 PM CT. If you need to speak to an agent outside of these hours, please visit Sprint Chat