cancel
Showing results for 
Search instead for 
Did you mean: 

Sierra FreedomPop Overdrive Pro Aircard 802s Firmware update error There is a SKU version mismatch.

Journeyman

Sierra FreedomPop Overdrive Pro Aircard 802s Firmware update error There is a SKU version mismatch.

I followed the firmware update link from the freedompop website which brought me to the download file located here on Sprint for FreedomPop Overdrive Pro.

http://shop2.sprint.com/en/software_downloads/mobile_broadband/sierra_overdrive_pro.shtml


After I select the firmware file 1.07.09 and click update, a

few seconds later I received the error message

"The update cannot proceed. There is a SKU version

mismatch."

Can someone help

2 REPLIES 2
Highlighted
Master

Re: Sierra FreedomPop Overdrive Pro Aircard 802s Firmware update error There is a SKU version mismatch.

TechAnt,


Hey there! I can help with this! This is odd have you tried resetting the box again to see if that helps? Let me know.


*Jazmine Social Care
Journeyman

Re: Sierra FreedomPop Overdrive Pro Aircard 802s Firmware update error There is a SKU version mismatch.

You aren't the only person with this issue.  Seems to be pretty common lately.  I'm trying to update my firmware as well and ran into this thread and the following blog post today:

Cubic: FreedomPop "free" plan is a bit dishonest

The author meanders around the whole FreedomPop free plan for a while but eventually gets to the SKU version mismatch issue.  Those of us running into this issue are apparently unable to update the firmware because someone intentionally screwed up the SKU of the device.  Resetting has no effect.

Community News

Need Help? 
Please try Searching the Community, we have many questions already answered, you can also check out the Knowledge base.
If you have an account question you can create a post and one of our Social Care Agents will help you.
If you need immediate assistance please visit Sprint Chat