cancel
Showing results for 
Search instead for 
Did you mean: 

Sprint Network FAILING! MiFi 2200 not downloading updates.

Highlighted
Journeyman

Sprint Network FAILING! MiFi 2200 not downloading updates.

My MiFi 2200 will not download and install the latest firmware updates. I do the usual update method of:

1. Open the Browser Interface, by typing http://192.168.1.1 into the address window of your web browser
2. Type the administrative password (admin) into the login box in the upper right corner
3. Select Login
4. From the Main Menu Bar, select WWAN
5. Select Configuration
6. Select Update Firmware

I then see a popup window with a green progress bar. After a few minites I am given a message to reset the modem. Once I powercycle the modem and check the firmware, I see that it is still on 133 and in the logs, I see that the update failed to download.

I've tried this over a few days and still I can't download this update. What is going on with the Sprint network, in that I can't download this update?

2 REPLIES 2
Master

Re: Sprint Network FAILING! MiFi 2200 not downloading updates.

sometimes firmware may not update wirelessly. It's unfortunate but does happen. have you tried resetting the MIFI?

HARD RESET - Using the Device Buttons:

  1. Make sure the device is powered on.
  2. Locate the master reset button on the back of the device near the battery cover.
  3. Insert a paperclip into the hole which you’ll feel a button inside slightly compress.
  4. Hold this button down for at least 5 seconds, while simultaneously holding down the Power button, until the green LED light on the side of the device goes off and then blinks.
  5. Connect the computer to the MiFi unit via the WiFi.

    If that still fails to update the firmware, a Sprint Repair Center can update the firmware for you.

Journeyman

Re: Sprint Network FAILING! MiFi 2200 not downloading updates.

Successfully did what you suggested, but it still did not work. After hard reset of the modem, logging back into the device and spending an hour resetting all my previous configuration values, I attempted to download the new firmware.

1st attempt: I got an error message, after the progress bar appeared, stating that the firmware failed to download.
2nd attempt: I got a message stating that there was no new firmware available.

All attempts thereafter keep displaying the message that there is no new firmware to download. At this stage the modem is still working with the 133 firmware, so I'm not going to continue pursuing an update. Besides, I hope to either upgrade to a 4G device (unlikely with the sucky Sprint 4G coverage ) or switch to Virgin Broadband 3G (likely, as I can get the same service $20 cheaper without the ridiculous 5Gb/month cap )

Community News

Need Help? 
Please try Searching the Community, we have many questions already answered, you can also check out the Knowledge base.
If you have an account question you can create a post and one of our Social Care Agents will help you.
If you need immediate assistance please visit Sprint Chat