cancel
Showing results for 
Search instead for 
Did you mean: 

Sprint SmartView using a lot of CPU

Journeyman

Sprint SmartView using a lot of CPU

It seems that Sprint Smartview is using upwards of 32% of my CPU when I am connected which is draining my battery pretty quickly. I'm using version 2.40.0043 on MacOS X 10.5.8 with a U301 USB device on a 16 month old MacBook w/ 2.4 GHz Core 2 Duo.

I've disabled GPS and network traffic doesn't seem to make a difference.

Does anyone else have this problem?

6 REPLIES 6
Journeyman

Re: Sprint SmartView using a lot of CPU

I have a Sierra Wireless 250U and have the same CPU usage / battery drainage problem as you.

It doesn't look like we're alone either, but there doesn't seem to be any response from Sprint:

http://forums.buzzaboutwireless.com/baw/thread/43603

Master

Re: Sprint SmartView using a lot of CPU

have you tried connecting straight from your network? system prefs, network. click on the network or modem that relates to sprint's aircard, and connect. you maybe able to connect w/o opening smartview at all.

Highlighted
Master

Re: Sprint SmartView using a lot of CPU

the person in this post stated they disabled GPS, hopefully you have as well. I also wonder if smartview is searching for WIFI networks. SSV does default to being a wifi mgr meaning it's trying to find ANY available network to connect to including NON-sprint networks. this can be disabled in the tools/settings, client tab for windows, not sure on a mac, but it should be in the settings.

Journeyman

Re: Sprint SmartView using a lot of CPU

I agree that SmartView (which I consider DumbView) uses too much cpu.  It is also very user unfriendly and I considered the old Pantech connection manager much superior to Smartview.  Looks like Sprint considers the connection manager a major app instead of a required evil to connect.  Nuisances such as no response to tell you that you are connecting during the many seconds after selecting connect is one example of the many nuisances.  It also does not allow selection of connection mode for my card.  During yesterdays day long local tower problem, I could not get any internet response even though I connected with great signal.  On the Pantech connection manager I could select things such as Roaming only which would have prevented connection to the strong signal broken local tower and allowed a roaming  internet connection to a different tower.

.

Journeyman

Re: Sprint SmartView using a lot of CPU

Tom, my SmartView is 2.40.0043.0 and doesn't handle wifi. I haven't used the Windows version so it sounds like handling wifi interfaces it's a useful feature.

On a OS X you can connect directly to 3G by going in to System Preferences, Network and finding your device in the left hand column. Click connect and you're off to the races. If you do this regularly there's a 'Show modem in status bar' which is very useful. You can see connect and disconnect messages, connect times, and that kind of thing. In previous versions of the OS there was even a signal strength meter in there which was really useful.

The WiMAX interface shows up as an Ethernet connection (often en2 I would imagine) and there's no connect button for that in the native Network Prefs. If you dip into the shell and try the usual Unix incantation of sudo ifconfig eth2 up that doesn't work even if SSV is running and has brought the interface to life. Without SSV running there's no en2. If you run ifconfig by itself it returns a list of all the interfaces the system knows about.

There's obviously other magic in there.

But this still doesn't say why Sprint SmartView chews up as much cpu as it does on a Mac. For me it usually shaves off about 30%-50% of my battery life. And that sucks more than just battery.

Journeyman

Re: Sprint SmartView using a lot of CPU

smartview 2.50.0094 for my 250u on windows XP chews up a ton of CPU as well, so not just Mac folks.

Too bad about the Sprint EVDO network going down hill so fast.  I started with Sprint 5 yrs ago or more with a s620 and those days where great!  That s620 was faster than my revA 250u on 3g by a long shot.  I rarely am in a 4g coverage area, but when I am I agree it's hard to believe fast.  I got 6Mb down while riding in a city bus.  Probably was lucky and on a completely idling tower.

I could use tips on how to make smartview more efficient and 3g alot more even in its speed.  Some times I do get good revA speeds but most of the time it's poor rev0 speed like most of you its from the same location in the house.  It's as if the towers are all going down for lack of tuning and maintenance.

Good luck, curt

Community News

Need Help? 
Please try Searching the Community, we have many questions already answered, you can also check out the Knowledge base.
If you have an account question you can create a post and one of our Social Care Agents will help you.
If you need immediate assistance please visit Sprint Chat