cancel
Showing results for 
Search instead for 
Did you mean: 

Moto G7 Power Not working with 4G/LTE

Go to solution
Journeyman

Moto G7 Power Not working with 4G/LTE

I am unable to get sprint to function properly on my Moto G7 Power. Have tried 2 sim cards now that Sprint says is compatible, both have the same results. Model of simcard is SIMOLW516TQ. It will work ok for awhile especially with wifi on but as soon as 4G connects it immediately kills all cellular data (seems to crash the simcard) including phone calls/texts. It usually comes back 10-15 seconds later and maintains 3G connection for awhile, then randomly 4G comes back and kills it all. I can text and it seems to make and maintain phone calls fine (as long as it hasn't crashed during the call/send process). Any solutions greatly appreciated, thanks.

6 REPLIES 6
Sprint Social Care S.M.A.R.T. Agent

Re: Moto G7 Power Not working with 4G/LTE

Other than changing or reinserting the SIM, have you tried any other troubleshooting?

 

 

 


 


RedCruzr
Social Care 

Queen of Unlocks and Billing Questions. Samsung for Life!!
Kudos and Accepted Solutions are welcomed and appreciated.
Journeyman

Re: Moto G7 Power Not working with 4G/LTE

Not really no, I am not sure what else to try since it seems to be software associated with the sim causing the issue. I have tried dialing numbers to "re provision" the phone but that doesnt even work the phone automatically does it after a forced reset from sprint side.

 

What I did learn from a motorolla forum:

"If you go into the hidden menu ( don't press send, just dial )`*#*#3282#*#*` APN Settings, is internet and pam blank?  Would like to give you good news, but if it's blank you don't have many options besides waiting out the bug or swapping the phone and hoping the new one isn't affected.  It's not a hardware issue, it's a software bug that's affecting a small number of phones."

I don't know how true it is because it came from a member not someone working with motorola. However he was correct though, those 2 boxes were blank showing no information. If they are not supposed to be then this seems to possibly be the issue.

Sprint Social Care S.M.A.R.T. Agent

Re: Moto G7 Power Not working with 4G/LTE

Gotcha. That's definitely great info to have. So, are you going to try to exchange the phone?

 

 

 


 


RedCruzr
Social Care 

Queen of Unlocks and Billing Questions. Samsung for Life!!
Kudos and Accepted Solutions are welcomed and appreciated.
Journeyman

Re: Moto G7 Power Not working with 4G/LTE

Yes I will try exchanging. Hopefully they will do it since it is not necessarily hardware related. I will post results when I return

Sprint Social Care S.M.A.R.T. Agent

Re: Moto G7 Power Not working with 4G/LTE

I look forward to hearing back from you. 

 

 

 


 


RedCruzr
Social Care 

Queen of Unlocks and Billing Questions. Samsung for Life!!
Kudos and Accepted Solutions are welcomed and appreciated.
Journeyman

Re: Moto G7 Power Not working with 4G/LTE

New phone fixed the problem. After significant research it seems to be related to Firmware problems. Rolling back to old firmware seems to fix it for some people (Not recommended). This problem seems to be somewhat common with the G7 lineup especially the Power. I used the exact same sim-card so I know it is not a sim issue. It is definitely related to the firmware or hardware itself. As of April 12, 2019 the only solutions are to either wait for a firmware update, or replace the phone.

 

A way you can confirm you have this issue is:

If you go into the hidden menu ( don't press send, just dial )`*#*#3282#*#*`, select APN Settings, if the internet and pam boxes are blank then you currently have a brick until update is released or you replace your phone.

Community News

Sprint S.M.A.R.T Agents
Sprint S.M.A.R.T Agent are here to help Monday through Sunday 6:00 AM CT - 6:00 PM CT. If you need to speak to an agent outside of these hours, please visit Sprint Chat