cancel
Showing results for 
Search instead for 
Did you mean: 

Moto G7 Power Not working with 4G/LTE

Go to solution
Highlighted
Sprint Social Care

Re: Moto G7 Power Not working with 4G/LTE

Did you get the latest software update? Updating the device can be a fix to this problem. 

Highlighted
Journeyman

Re: Moto G7 Power Not working with 4G/LTE

Hello,

 

I believe I have the latest update from February.  If there is a new one my phone is not finding it when I check for updates.

 

Android Version:  9

Current Version:  PPYS29.105-160-4-2

Security path level:  February 1, 2020

Highlighted
Sprint Social Care

Re: Moto G7 Power Not working with 4G/LTE

Let me verify the coverage in your area, What's your nearest cross street and ZIP code? 

 

Highlighted
Journeyman

Re: Moto G7 Power Not working with 4G/LTE

No offense, but they have been "verifying signal" in my area for over 20 years no matter where I live.  At one point they told me I did not have service and told my wife she did with the same phone on the same service in the same house.  I do not think Sprint knows where their service works and does not.

 

I H 20 and Cooper Street

76017

 

https://goo.gl/maps/QbAWTVHiMSC3rX8H7

Highlighted
Sprint Social Care

Re: Moto G7 Power Not working with 4G/LTE

Let me check this for you. 

Highlighted
Sprint Social Care

Re: Moto G7 Power Not working with 4G/LTE

You are within good coverage and your nearest tower is performing as expected. I'd like you to update the PRL on the device by following the below steps.

Step 1:From the home screen, tap Apps.

Step 2:Scroll to and tap Settings.

Step 3:Tap System Update. May be found under System section or General

Step 4:Tap Update Profile.

Step 5:Once the profile update is complete, tap OK.

Highlighted
Journeyman

Re: Moto G7 Power Not working with 4G/LTE

I update both my PRL and config daily and sometimes it helps, but usually it does not.....

Highlighted
Sprint Social Care

Re: Moto G7 Power Not working with 4G/LTE

I'm going to send you a private message. 

Highlighted
Journeyman

Re: Moto G7 Power Not working with 4G/LTE

So I just got a new update today for my Motorola G5 Play and guess what........... still no APN or Internet settings.  This is beyond ridiculous.  I hope Tmobile completely gets rid of all things Sprint.

Highlighted
Sprint Social Care

Re: Moto G7 Power Not working with 4G/LTE

That's strange! You're not getting internet? Can you try following the steps below for me? 

  1. Swipe up to view Apps.
  2. Scroll to and touch Settings.
  3. Touch More.
  4. Touch Cellular networks.
  5. Touch Access Point Names.
  6. Touch the Menu icon.
  7. Touch Reset to default.
  8. Restoring default APN settings will appear briefly.
Community News

Our Community is BACK!!
Hours of Operations are 7AM - 8PM CST. Please try Searching the Community, we have many questions already answered, you can also check out the Knowledge base
If you need immediate assistance after hours please visit Sprint Chat