cancel
Showing results for 
Search instead for 
Did you mean: 

Problems with the Motorola i776w

Highlighted
Patron

Problems with the Motorola i776w

Hi, I have posted before about my phone, which is the Motorola i776w.  This is the worst phone I have ever owned!  

I have waited for 2 months to get my replacement phone for which I finally received about 2 weeks ago.  So far so good with the camera working,

but I have encountered the same email issue as before. 

It worked fine for about 1 week then started acting up again.   When I click on the "Sprint Mobile Email" link under Java Apps, I am getting the same error message as before.  It wants me to enter my phone number again, then once I click "next", I get the error msg. of "Sprint mobile email error, Please try again (S7110)".   This is what happened before and I cannot even get my email through the other link of "Email and IM".   I am so very frustrated

since this is a brand new replacement phone!!!!! 

I am getting so fed up with the lack of help when I email or call too.  No one can seem to be able to help me with this issue.  When I email, they tell me to

call and when I call, they can't help me there either!

What am I supposed to do now?  This is a replacement phone of the same model and I want to get another type of phone with all of the features of this one but I don't think that I should have to pay for it since this is of no fault of mine.  If no one can help me get this fixed even when I visit a Sprint store,

and no one can help me over the phone nor email, just where am I supposed to turn now?  I have been with Sprint/Nextel for over 12 years

and have never encountered so many problems during all those years until now!

I have 3 phones on my account and if my husband didn't rely on the Direct Connect so much, I would seriously consider changing to a different provider!

Let me know if anyone else out there has had problems with the Motorola i776w.

I would like to know if you've had any similar issues.

Thank you!

19 REPLIES 19
Highlighted
Journeyman

I am having the exact same issues with the i776.  I am on a replacement phone now. I have had it for one week and it is going bad and I am only 1 year into my contract.  I have been with Nextel for over 10 years and am about to buy out my contract and leave them over this.  NO ISSUES BEFORE THIS WITH THE COMPANY and this is it.  I have the insurance plan.  The service center told me that the insurance was only good for physical damage to the phone but the website states it is for technical issues as well.  Go figure!  RRRRR, this is ridiculous!!

Highlighted
Journeyman

I've nothing but problems with i776 too.  My flip cracked after about a month and my direct connect barely works.  The local store where I bought the phone from was absolutely no help.  I am changing carriers as soon as my contract is up.

Highlighted
Journeyman

I am having the same prob. my direct connect does not work and I have a lot of trouble downloading a message. it has been a couple fo days now that I cannot send text's and/or receive them, it tells me it had a transport error.

Highlighted
Journeyman

hahahaha yeah, it takes like 3 minutes to download a dam txt message

This phone sucks.

Highlighted
Journeyman

I've experienced the exact same problems. Bottom line is, Sprint is doing away with anything NEXTEL and they make these decisions up in corporate and are not proactive in telling us what they are doing. Not only will they not admit this, but that information doesn't even trickle down to their customers. They just cut off our email and then we call them to fix and their reply is to "get a newer phone." All this in the name of "progress."

Highlighted
Journeyman

I have had the same issues with my i776w. I called customer service they could notg help. I went to repair shop and they could not fix. I called tech support again today and they still could not help. This is a piece of crap phone and they refuse to replace it with another one. I have had it for over a year and it has never worked and they can not correct the issues.

Highlighted
Journeyman

I found a way to fix this problem. I got ticked off one day and decided to DEINSTALL the whole Sprint Mobile Email application from my phone. (select the SME icon, DON'T CLICK IT, but hit the menu button; deinstall is available, click it and let it run).

Later the same day it dawned on me to try and re-install the Sprint Mobile Email app to see what happens. You do this by going into the JAVA APPS icon (not the net icon), then DOWNLOAD APP icon (takes a bit for it to work), then BYPASS the instructions (if it appears), then hit FACTORY PRELOADS and then scroll down to SPRINT MOBILE EMAIL, and load it up!

It worked for me!! Try it!

Let me know how it works out - Good luck!

Dave

Highlighted
Journeyman

I have not had this issue but I would go to the CEO of Sprint and let him know your frustrations and I am sure there is someone within the company that could direct your email to the proper Individual for a resolution to this issue.

Nancy

Community News

Our Community is BACK!!
Hours of Operations are 7AM - 8PM CST. Please try Searching the Community, we have many questions already answered, you can also check out the Knowledge base
If you need immediate assistance after hours please visit Sprint Chat