cancel
Showing results for 
Search instead for 
Did you mean: 

wifi disconnects when the phone is locked

Journeyman

wifi disconnects when the phone is locked

I recently switched from an Evo Shift to the Photon 4G. I love the Photon, but I seem to be having a strange wifi problem.

When I get to work, I connect to wifi and go about my day. Later when I go to check my phone it is connected to 3g and not wifi.

After I unlock the phone I get the message that a wifi network had been detected and it reconnects to the wifi network.

This never happened on my shift, is this some weird quark of the Photon, or did I miss a setting somewhere?

Tags (4)
7 REPLIES 7
Highlighted
Wizard

wifi disconnects when the phone is locked

Out of curiousity, are you using any of the power saving features that came pre-loaded on the phone?

-Alec

Highlighted
Journeyman

wifi disconnects when the phone is locked

The battery mode is set to nighttime saver

Highlighted
Wizard

Re: wifi disconnects when the phone is locked

That may be part of it. But I would check here first:

1.From the Home screen, press Menu  > Settings.

2.Touch Wireless & networks > Wi-Fi settings.

3.Press  Menu > Advanced > Wi-Fi sleep policy.

4.Touch When screen turns off.

It's supposed to help with battery life but if it's more annoying than useful feel free to turn it off.

-Alec

Highlighted
Journeyman

wifi disconnects when the phone is locked

Alec,

I think that's the setting I was looking for.

Mine was set to never when plugged in.

I set it to never since I want it to always use wifi when available.

I will post tomorrow with a follow up to see if that solved my problem.

Thanks for the help!

Highlighted
Journeyman

wifi disconnects when the phone is locked

Setting the wifi sleep policy to never solved my problem with it connecting to 3g when locked and it improved my battery life significantly.

Highlighted
Wizard

wifi disconnects when the phone is locked

Awesome.

Highlighted
Journeyman

Re: wifi disconnects when the phone is locked

Hey, CliffyMcJ
  Thanks from me too.  Had same problem.

Community News

Need Help? 
Please try Searching the Community, we have many questions already answered, you can also check out the Knowledge base.
If you have an account question you can create a post and one of our Social Care Agents will help you.
If you need immediate assistance please visit Sprint Chat