cancel
Showing results for 
Search instead for 
Did you mean: 

After recent update, wifi keeps turning on.

Journeyman

After recent update, wifi keeps turning on.

Has anyone else had this problem with the photon Q? My wifi keeps turning on when i tell the default power widget to turn it off.

9 REPLIES 9
Journeyman

Re: After recent update, wifi keeps turning on.

So i called sprint, and they suggested to do a factory reset on the phone. I did a full reset of the phone and formatting of the SD card, and the problem is still persisting. Does anyone have any other solutions?

GrandMaster

Re: After recent update, wifi keeps turning on.

go into settings-wireless and networks-mobile networks and you should see something that says connections optimizer..shut that off..what its doing is contolling your connections to give you the better performance..unlike before if you left your wifi on it would continue to search for a connection in the background which drains your battery like crazy..the connections optimizer will turn it on every so often to check for a signal..then shut itself back off (the only connection it will look for are the ones you have stored in your phone already unless you have it set to notify you when a connection is available..then it will pop up all the time..turn off the notificaion). if you dont want it doing that uncheck it..if it STILL tries to do this you will have to go into your manage apps and disable it..someone ran into this issue on the HTV EVO LTE and had to do this to fully shut it off.

*********************************************************
I like many others come onto this site for assistance and to help others. Marking a reply as helpful or correct helps others with like issues when they try to search the site for assistance. I do not work for Sprint and my suggestions and or opinions are my own. *************************************************************************************************************
Journeyman

Re: After recent update, wifi keeps turning on.

The Photon Q 4G does not have that option. I'm wondering if it is included in the firmware, but someone forgot to actually put it into the GUI to enable/disable it.

GrandMaster

Re: After recent update, wifi keeps turning on.

which option? the connections optimizer or the ability to disable it? if anything you should be able to click it and uncheck the box either at the top or bottom of the long biography explination of what the connection optimizer is lol

*********************************************************
I like many others come onto this site for assistance and to help others. Marking a reply as helpful or correct helps others with like issues when they try to search the site for assistance. I do not work for Sprint and my suggestions and or opinions are my own. *************************************************************************************************************
Journeyman

Re: After recent update, wifi keeps turning on.

There is no sprint optimizer option shown on the phone. Which from what people have said about this being a common problem on other phones with the optimizer turning on, is that the optimizer exists within the firmware of the phone, but it was never put into the GUI of the phone.

GrandMaster

Re: After recent update, wifi keeps turning on.

i have no issues with it and im currently running it. there is a learning curve with it but aside from that eh..it does the job. every phone all the way back to the original evo should have the connections optimizer..which is why your wifi no matter how many times you shut it off keeps turning back on..manually turning it off only resets it for a little bit. one other way to check and see if this is the reason is to go into your settings-applications-running applications and odds are it will show up in there seeing as how its running in the background..odds are one of the techs in here will have to let you know where its located since i do not have one of these phones in front of me to locate its exact location. i just know that every phone from the original evo up now has the optimizer. i know that on the LTEVO they had to manually go in and disable the app itself..unchecking the optimizer wouldnt fully shut it down. havent heard of many complaining about it with the SIII though..and if they did it wasnt that hard to locate the optimizer and uncheck it..it stayed off without any further things to do...with this phone though...not sure WHAT magical things will need to be done lol

*********************************************************
I like many others come onto this site for assistance and to help others. Marking a reply as helpful or correct helps others with like issues when they try to search the site for assistance. I do not work for Sprint and my suggestions and or opinions are my own. *************************************************************************************************************
Master

Re: After recent update, wifi keeps turning on.

Maethus wrote:

There is no sprint optimizer option shown on the phone. Which from what people have said about this being a common problem on other phones with the optimizer turning on, is that the optimizer exists within the firmware of the phone, but it was never put into the GUI of the phone.

The Photon Q does not have the Sprint Connection Optimizer as of the update 7.7.1Q-6_SPR-125_ASA-10 released 11/6/2012. The phone does have a setting under WiFi > Advanced to notify you of available WiFi networks when "opening certain apps" (whatever that means, I'm assuming it's a list of apps that work significantly better over a WiFi connection).

The Optimizer turning on WiFi on its own is by design. It turns on/off the WiFi/3G connections at set periods to determine if a connection is available. If no saved WiFi connection is available, it turns off WiFi until that set period again. The setting will appear to still be "on" in the phone due to an Android limitation, but the radio is turned off. Much the same the WiMax devices did with later software versions. The 4G connection was "on", but it wasn't constantly scanning if it didn't find a connection, it would shut off and only check periodically. The setting would be "on" but the radio would be "off" if no connection was found until the next scan period; the same thing happens with WiFi and the Sprint Connection Optimizer.

It is meant for the users who do not regularly connect to WiFi when available, or who don't turn it off when WiFi is unavailable. These also are the users who are least likely to go into the settings of a phone and often will leave most settings at the default, so the default is enabled. It attempte to optimize the user experience by utilizing WiFi when available for a faster connection and to ease congestion on the Sprint network when another network is available to the device, thereby leaving more network space available for those who cannot offload onto a WiFi connection instead.

Journeyman

Re: After recent update, wifi keeps turning on.

This has been driving me nuts for a while now. I just went to Setting >>More  then turned ON the Wi-Fi Direct setting. The description says 'This will turn off Wi-Fi client/hotspot operation.' So far, it's working. Hope it sticks....

Journeyman

Re: After recent update, wifi keeps turning on.

for me, unchecking the 'Show Reminders' option in the advanced wifi settings seems to do the trick.... I haven't had wifi turn on when I didn't want it to hehe.

Community News

Sprint S.M.A.R.T Agents
Sprint S.M.A.R.T Agent are here to help Monday through Sunday 6:00 AM CT - 6:00 PM CT. If you need to speak to an agent outside of these hours, please visit Sprint Chat