Showing results for 
Search instead for 
Did you mean: 

Turn on 4G?


Turn on 4G?

Day 3 with my new Photon Q and I can't figure out how to turn on the 4G. My previous phone was the Epic 4G and it was as simple as going to the pulldown bar and pressing "4G". This phone I have to dig around through some menus before I find "4g Status". When I select it I get "Network Provider Unavailable" and "IP Address".

Per the Sprint coverage map I'm in the middle of the 4G LTE coverage area so that shouldn't be the issue. Ideas?

I despise the thought of having to deal with a Sprint store.


Just followed the tutorial for checking device performance. It indicates 4G is "ON". So no way to turn it off? Sounds like it is always searching... another unnessary battery drain.

So Sprint's coverage map is wrong?! Never would have thunk it. It also says I get 3G coverage... yeah, with free Airave they sent me.


its automatic..if you want to turn off 4G then you have to go into your settings and change it from LTE/CDMA to CDMA only.

as for the LTE coverage...its supposedly showing what coverage SHOULD be once fully deployed..which many think (including myself) needs to be changed to actual instead of theoretical

I like many others come onto this site for assistance and to help others. Marking a reply as helpful or correct helps others with like issues when they try to search the site for assistance. I do not work for Sprint and my suggestions and or opinions are my own. *************************************************************************************************************
Community News

Our Community is BACK!!
Hours of Operations are 7AM - 8PM CST. Please try Searching the Community, we have many questions already answered, you can also check out the Knowledge base
If you need immediate assistance after hours please visit Sprint Chat