cancel
Showing results for 
Search instead for 
Did you mean: 

No 3G since 4.0 update Ice Cream Sandwich

Journeyman

No 3G since 4.0 update Ice Cream Sandwich

I have a Nexus S 4G phone, Anybody else have problems with connecting to 3G of which I have always had in the 07826 area since the new update?  I brought my phone to the sprint store as requested there is nothing wrong with it, in fact, i get 3G as soon as I hit the store 36 miles from my home. 

Phone says 1x, I pay for service and expect to have that service.  CS on the phone did every diagnostic test and nothing fixes it. 

Ok so once again there are tower problems since the 11th ticket was closed on the 14th and it then takes 72 hours??  Really.  Why are there always problems with the towers up here, Verizon doesn't have these issues, im surrounded by Verizons users who get 4G service also....but that's ok i just want my 3G back...

Hey remember that commercial 'LOADING, LOADING LOADING"  This is ridiculous!!

5 REPLIES 5

Re: No 3G since 4.0 update Ice Cream Sandwich

SussexCounty, Can you provide me with your nearest cross streets to the location you are having the issue so I can research this for you.

Journeyman

Re: No 3G since 4.0 update Ice Cream Sandwich

zip code 07826

im right on US hwy 206 work and home nearest crossroad, Myrtle Road from home

Re: No 3G since 4.0 update Ice Cream Sandwich

Do you recall where the store you visited was located?

Journeyman

Re: No 3G since 4.0 update Ice Cream Sandwich

Of course it was the store in Ledgewood, NJ  Oh and I still have no 3G service.  Im really not liking this at all....Im paying a premium and not getting it.  Im spending more time on the phone with Sprint CS over an hour this am and they still can't seem to fix it. 

I am one very disappointed customer

Highlighted
Journeyman

Re: No 3G since 4.0 update Ice Cream Sandwich

Yes this is TERRIBLE. I have already commented at electronic review sights.  My thoughts are simple. Whomever came up the OS should get fired.  My $500 phone is trashed! 

1. POWER CONSUMPTION IS OFF THE CHARTS

2. Signals levels seem less than normal, including WiFi in my house!

3. Can't tell if my I am in Bluetooth mode at a glance, while driving on the phone!

4. When initiating Phone mode the Phone pad always pops up.  Why not the last phone function I used!?! ( LIKE IT WAS)

5. What happened to my Google Voice link?

6. What's with hard Google search field?  I already move the original to adjacent page.  Didn't want it on mty home window.

7. Everytime I turn on my phone, the battery is at 95%. 

I called SPRINT, they said they be may able to revert the phone back to the earlier OS.

Then the call dropped!

It's a phone first, otherwise I don't need it.

Community News

This is a PUBLIC ARCHIVE board, all artciles are read only.

Please click here to search the Active Community.