cancel
Showing results for 
Search instead for 
Did you mean: 

Roaming Mexico for over a year without issue. After the Android 10 update, won't connect for service

Go to solution
Highlighted
Journeyman

Roaming Mexico for over a year without issue. After the Android 10 update, won't connect for service

I've been in Mexico with my Essential PH-1 since Feb of 2018. Phone has been working fine. Got the Android 10 update a few days ago and it appears the phone hasn't been able to connect to a cellular network since. 

 

SIM card is still in it and wifi works just fine. I tried OMADM updates; PRL and Profile. They worked but didn't fix the issue. 

 

I've been on with chat and was sent to Tier 2 support in which they opened a ticket for me. Ticket #501439-191102. They said Tier 3 support would text me with a number to get help but since my phone doesn't have service, I will not get that text. I got back on with someone else and let them know to note my ticket to contact me via email.

 

I've had some off and on issues with using Sprint in Mexico but they've been resolved. Not always quickly but they have been fixed. I can't use my phone at all right now to make calls or receive texts. It can only be used for certain things while I'm on wifi.

 

I need to get this resolved as my phone and service I pay for with Sprint is useless at the moment. 

I've been with Sprint for about 20 years now. This is the first time I'm considering switching carriers because it seems to take a while to resolve issues. 

 

I'm hoping I will hear from someone on here or via email to get this fixed for me. 

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Sprint Employee

@lemonjello669a,

Hey! I Would like to take a look into your account and see what else can be done. I've sent you a private message, check your inbox. 


Kryshna
Sprint Social Care

View solution in original post

2 REPLIES 2
Highlighted
Sprint Employee

@lemonjello669a,

Hey! I Would like to take a look into your account and see what else can be done. I've sent you a private message, check your inbox. 


Kryshna
Sprint Social Care

View solution in original post

Highlighted

I managed to fix this on my own. My phone's "Preferred Network" in phone information when entering *#*#4636#*#* was set wrong. The Android 10 update must have set it different than it was before.

Community News

Our Community is BACK!!
Hours of Operations are 7AM - 8PM CST. Please try Searching the Community, we have many questions already answered, you can also check out the Knowledge base
If you need immediate assistance after hours please visit Sprint Chat