Showing results for 
Search instead for 
Did you mean: 

S8+ always roaming and LTE doesnt work

Go to solution

S8+ always roaming and LTE doesnt work

Hello. Here are the cross streets and town for reference:

Sheep Creek and Goss

Phelan, Ca.


We had a sprint store in our town for years. I got the s8+ last year and everywhere but my town I have service. I ran speed tests through LTE doesnt even register so speedtest cant test it. And the 3G I got 1mb down. (Even though takes 2 minutes to load.) 

Even my slow wifi is faster than the sprint network.20180929_222227.jpg


Why would sprint have stores up here and have almost no service. I've tried updating PRL, my profile (which by the way will only update when I'm on wifi and not sprint network.)

My phone is completely up to date. Yet my wife's Galaxy Note 3 will have LTE while I'm roaming.


Anyway to fix this issue?


I used to be a truck driver, I've been all over the country. And besides, Montana, new Mexico and some of wisconsin. My home area has been the worse connection I've ever had.


Accepted Solutions

My apologies folks, I've been out of town for work and still trying to catch up.  Sprint devices may roam in areas they did not roam previously. This is by design and is a result of updated acquisition files being pushed to devices to prefer LTE roaming over Sprint 3G. Sprint does not charge customers for Domestic roaming voice, data or SMS usage. Please do not swap devices. 


In the past, the device was told to look for Sprint LTE first, then Sprint 3G.  Now, it's told to look for Sprint LTE first, then Roaming LTE, next Sprint 3G, and then finally 3G/2G roaming.  This is to keep the fast LTE data speeds before dropping to 3G or lower.  By default, devices are set to automatic, meaning it will attach to the strongest signal should it be ours or a competitor's.  If the constant "Roaming" sign on your screen is making you nervous, you can set your device from automatic to LTE/CDMA.

View solution in original post


if its working everywhere else but your town there could be a outage that has yet to be reported by the tower owners. the agent in here can look into this or kick out a ticket for it to be checked. are there any other Sprint phones around you in town that are seeing this as well?

I like many others come onto this site for assistance and to help others. Marking a reply as helpful or correct helps others with like issues when they try to search the site for assistance. I do not work for Sprint and my suggestions and or opinions are my own. *************************************************************************************************************

Like I stated in my post my wife's note 3 which is a sprint phone works fine. My phone has had no service here since I bought the phone over a year ago. As I'm typing this my phone is roaming and my wife's says LTE. I didn't think much of it because of me only being home 2 days a month.

But recently I became disabled, so I've been home for 3 months, and I'm almost always Roaming. Everyone in her family has sprint phones and they all work just fine and they all have older phones, note 3, galaxy s4 etc. I have the s8+ and they have better reception then me, how is that possible. I cant afford to get a new phone because I'm not currently working and I'm still trying to pay off this phone.


So any info on how to actually have reception would be nice.


And since I live in the middle of nowhere my wifi is basically dial up speeds (300kb max download speed) so I cant use it for anything really to help.


Let's look at your area:




For context, yellow is LTE coverage and gray is roaming.  As you can see there is roaming all over the area.  Your phone is set to 'automatic' by default.  Meaning, it will automatically attach to the strongest signal, should it be Sprint or a roaming signal.  I would suggest setting the device to Sprint/Home Only so it will only look for Sprint signals.  You can change that in settings under network.  I don't have a Samsung with me right now or I would type out the steps.


Mines set to LTE/CDMA not automatic.

I worked in IT for a few years before becoming a truck driver so I'm not completely Tech Illiterate.


Any other options?


And as I'm typing this....back to roaming.

Does this in my house, outside my house.

No win for me.





That's different.  I will have access to one soon...standby


Screenshot_20181001-150354_Mobile networks.jpg


These are my options, and then when it does jump to LTE or 3G I still have to use wifi because I have no internet so even my dial up wifi is better than this LTE and 3G I'm getting.


You are tapping Network Mode. You are wanting to tap Roaming right above it and then turn off voice and/or data roaming on the next page. 

@Dukeneedles wrote:

Screenshot_20181001-150354_Mobile networks.jpg


These are my options, and then when it does jump to LTE or 3G I still have to use wifi because I have no internet so even my dial up wifi is better than this LTE and 3G I'm getting.



Screenshot_20181001-173406_Mobile networks.jpg


Everything is off on the next page already.


And to show that they are all off and I'm still roaming: Screenshot_20181001-180651_Mobile networks.jpg



That's weird. The phone should not roam at all. Turn roaming on for 10 seconds and then turn it off. Finally turn the phone off for 2 minutes to clear cache and then turn it back on. 


Did what you said.

This time at least speedtest recognized LTE but this was the speed test:Screenshot_20181001-213642_Speedtest.jpg



Basically that means Sprint LTE is slower than the Sprint 3G for me which is very sad. So basically still cant use the sprint internet unless I wanna drive 15-20 minutes into the neighboring town.


Edit: Now it seems instead of showing roaming is just gives me nothing:Screenshot_20181001-215235_Samsung Experience Home.jpg



 Never mind got this shortly after:Screenshot_20181001-223820_Samsung Experience Home.jpg



Still Roaming........


Yeah, I'm not surprised at the speed given all the roaming and no service displayed on the coverage map.  However, the roaming while roaming is off is strange although I only see the roaming indication when you have Wifi turned on.


Given the area, the only fix would be an indoor solution like a Magic Box.  Unfortunately, those are out of stock until mid- November.

Community News

Our Community is BACK!!
Hours of Operations are 7AM - 8PM CST. Please try Searching the Community, we have many questions already answered, you can also check out the Knowledge base
If you need immediate assistance after hours please visit Sprint Chat