cancel
Showing results for 
Search instead for 
Did you mean: 

My sim cards do not work with my Nexus 5X

Go to solution
Journeyman

My sim cards do not work with my Nexus 5X

I have a brand new Google Nexus 5X and a brand new Sim Card from Sprint.

SKU - 019962040146

Part - SIMGLW446C

My phone will not activate with this sim card. Everyone in CS is telling me that this card is not compatible with the Google Nexus 5X. Is there any way to do some real debugging or is going with another carrier my only option now?

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Journeyman

So, I called CS again, 7th time. This time, as I am confirming the IMEI, the lady (Sherry) on the other line asks me for the MEID. When I told her I don't have it, she told me to look at the box. That's something I have not tried yet. There definitely was an MEID printed on the sticker on the box. I gave that to her. And we started to activate the phone and it works!

Not sure why the first phone worked on IMEI and the second one needed MEID. For those on Sprint's end, could it be possible the CS were entering the numbers in the wrong fields on the software?

View solution in original post

9 REPLIES 9
Highlighted
GrandMaster

How to get a SIM for your Nexus 5X or 6P

  • The SIM SKU you will need is CZ2144LWC. The UPC code for that SKU is 019962040146 and may be needed if you are working with someone in Retail or Care. The description is "Worldwide LTE-GSM Remov 4FF CSIM".
  • Retail stores should carry the required SIM. Alternatively you can call order support at 866-789-8292 to order the SIM. If you receive any pushback please escalate to a manager and insist Sprint can activate Nexus 5x and Nexus 6p or point them to this page
*********************************************************
I like many others come onto this site for assistance and to help others. Marking a reply as helpful or correct helps others with like issues when they try to search the site for assistance. I do not work for Sprint and my suggestions and or opinions are my own. *************************************************************************************************************
Highlighted
Journeyman

The UPC is correct, I guess I mistook the SKU and UPC. I got that from Sprint World Wide online chat, like the forums advise. And strangely, I ordered 3 sims and 3 phones, one of the phones and sims worked.

Beyond a series of "Black Box" push this button, reset the phone, blah, I was hoping there would be more in-depth analysis abilities to tell me what else is happening.

The second (in the series of 5 CS folks I spoke with), put me on hold to check something on their backend. He said everything checked out and I just need a wifi connection to get the device config updated. That didn't work either, so I'm assuming there's ways to looking into more data like what signals (if any) my phone is sending the towers.

Highlighted
Journeyman

So, I called CS again, 7th time. This time, as I am confirming the IMEI, the lady (Sherry) on the other line asks me for the MEID. When I told her I don't have it, she told me to look at the box. That's something I have not tried yet. There definitely was an MEID printed on the sticker on the box. I gave that to her. And we started to activate the phone and it works!

Not sure why the first phone worked on IMEI and the second one needed MEID. For those on Sprint's end, could it be possible the CS were entering the numbers in the wrong fields on the software?

View solution in original post

Highlighted
GrandMaster

if im remembering right the IMEI and MEID are pretty much the same number but the MEID has a few extra numbers. just looked at the one for my M9 and the only difference i can see at quick glance is the last number.

you dont have access to these numbers in your about phone area in settings?

*********************************************************
I like many others come onto this site for assistance and to help others. Marking a reply as helpful or correct helps others with like issues when they try to search the site for assistance. I do not work for Sprint and my suggestions and or opinions are my own. *************************************************************************************************************
Highlighted
Journeyman

Yeah, the IMEI is only 1 digit off from the MEID.

This leads me to believe Sprint CS is hit or miss. The first time I activated my phone, either the CS person knew that and removed the last digit from the IMEI I gave her to make it an MEID, or their software requires them to specify what type of number it is (I definitely did not provide her with an MEID) and the activation went through. Knowing that the MEID is what was needed, I was able to get the 2 additional phones activated, which cost me an entire day of talking to 7 different CS people. None of which could figure out such a simple problem in front of us.

Lastly, this morning when trying to activate my 3rd phone, the CS accidentally hijacked the number from my 2nd phone and put it on my 3rd phone. I only knew that because I tried to call myself during the initial test call, and it said calling Voicemail. Knowing immediately the situation, I had to explain to her what she just did and after convincing her what had happened, we finally got the lines swapped back correctly in place.

I've been a Sprint customer for a very long time. I know there are cheaper plans out there and carriers with better coverage for my area. I've just not had the incentive to switch to a cheaper plan with better coverage, until now. So long Sprint. If I'm going to put up with this crap, I might as well pay less to deal with it.

Highlighted
Journeyman

So does Sprint have 2 different SKUs under the same UPC? I was sent the same SIM as the OP, and it works but only on 3G and sometimes the reception "bars" go blank. Not sure if it's a coverage issue or a SIM issue.

Highlighted
GrandMaster

the SIM itself is what is letting you connect to LTE..if its the same one that the op is using and his works but yours doesnt it might be how the agents are entering your device into the system.

*********************************************************
I like many others come onto this site for assistance and to help others. Marking a reply as helpful or correct helps others with like issues when they try to search the site for assistance. I do not work for Sprint and my suggestions and or opinions are my own. *************************************************************************************************************
Highlighted
Journeyman

I have a friend who works in a Sprint retail location and he confirmed CZ2144LWC is supposed to be the SIM for the 5X. That being said, after going into my settings and resetting the APN to default (had to use *#*#3282#*#* since this menu is not in the settings natively), my phone started connecting to LTE.

I indeed am using the SIMGLW446C, but it appears to be working.

When i first went into the APN settings, there seemed to be some leftovers from Project Fi. I imagine it's possible the phone was referencing these settings to try to get access and my profile was invalid to use the old APs. I've seen a few different LTE bands (using SignalCheck).

Highlighted
GrandMaster

thats what its looking like. the old info wasnt fully flushed out and was giving mixed results.

*********************************************************
I like many others come onto this site for assistance and to help others. Marking a reply as helpful or correct helps others with like issues when they try to search the site for assistance. I do not work for Sprint and my suggestions and or opinions are my own. *************************************************************************************************************
Community News

Our Community is BACK!!
Hours of Operations are 7AM - 8PM CST. Please try Searching the Community, we have many questions already answered, you can also check out the Knowledge base
If you need immediate assistance after hours please visit Sprint Chat