cancel
Showing results for 
Search instead for 
Did you mean: 

With 4.4.3, stuck on 3G in an LTE area

Journeyman

With 4.4.3, stuck on 3G in an LTE area

I recently took the 4.4.3 update. With that update, my phone will no longer connect to LTE in an area that I know has great LTE coverage, because I had LTE with 4.4.2, before the update. Also, if I reboot my phone or toggle airplane mode, it will connect to LTE for about 2 minutes, but then it goes back to 3G and just stays here. What is the issue?

25 REPLIES 25
Master

Re: With 4.4.3, stuck on 3G in an LTE area

SPARHAWKRGC6,

Thank you for letting us know about the issue. Could you please send me the cross streets and zip code where you are experiencing these LTE issues? Could you also please let me know what sort of device you currently are using?

Thank you
Bran
Sprint Social Care
Journeyman

Re: With 4.4.3, stuck on 3G in an LTE area

I am also having the same exact experience on my nexus 5. I am in 10469 Paulding ave and 220th street.

Journeyman

Re: With 4.4.3, stuck on 3G in an LTE area

I am at 200 South and State Street in downtown Salt Lake City, zip code 84111. I am running a Nexus 5. Sorry, I thought you'd know that because I am posting in the Nexus 5 forum.

Master

Re: With 4.4.3, stuck on 3G in an LTE area

SPARHAWKRGC6 -- This is a known issue that our network engineers are currently working on resolving. This has to do with Sprint Spark and tri-band capabilities. We will post a fix on this forum as soon as one is found. *Julian
Journeyman

Re: With 4.4.3, stuck on 3G in an LTE area

I am having the exact same issue. After the upgrade to 4.4.3, my Nexus 5 connects to LTE for a couple of minutes then turns back to 3G even though I stay at a stable spot. I think this happens in the entire city of Atlanta. To turn on LTE on the phone, I have to turn on and off the Airplane mode but the LTE connectivity lasts only for a minute or two. Of course, I can use the internet while on the LTE network without any problem.

Journeyman

Re: With 4.4.3, stuck on 3G in an LTE area

Your device is fine and is working as it should for a perfect mature network. I did some research on this and the problem is on the network side and its called eCSFB. Our phones are scanning more bands now and when it senses that your serving cell does not have eCSFB properly setup or broken it knocks you down to 3G to keep voice service going and you wont miss calls. Go to S4GRU.COM and go to the Nexus 5 forums you will find a better explanation of what's going on.

Journeyman

Re: With 4.4.3, stuck on 3G in an LTE area

I am also having this issue both in home area 1600 North ave and Springfield ave 60651 and work upper wacker and dearborn Downtown chicago where it was excelent LTE.

Journeyman

Re: With 4.4.3, stuck on 3G in an LTE area

Everyone who is having the problem do a profile update.

Settings/more/mobile networks/carrier settings/update profile.

Do this while connected to 3g, after the update, reboot and see if you have lte.

Journeyman

Re: With 4.4.3, stuck on 3G in an LTE area

But my question is....

Why I didn't have such a problem until I updated the OS to 4.4.3??

Journeyman

Re: With 4.4.3, stuck on 3G in an LTE area

The LTE connectivity lasted longer (about an hour) after refreshing Profile,, but got back to 3G again

Journeyman

Re: With 4.4.3, stuck on 3G in an LTE area

SprintCare Ugh, add me to the list... I am in the greater Phoenix area and dropping LTE all the time now since the 4.4.3 update.

Community News

Sprint S.M.A.R.T Agents
Sprint S.M.A.R.T Agent are here to help Monday through Friday 6:00 AM CT - 6:00 PM CT. If you need to speak to an agent outside of these hours, please visit Sprint Chat