cancel
Showing results for 
Search instead for 
Did you mean: 

Roaming options grayed out on GDR3

Highlighted
Journeyman

Re: Roaming options grayed out on GDR3

I completely and wholeheartedly agree with everything Blue_Frog has outlined (quite nicely, I might add).

I would only add one thing:

To Item 3a: Both phones I received had GDR2 and voice and data roaming were already greyed out and disabled as soon as I activated the phone.

Sprint, this is not an isolated issue but an ongoing foul-up. I won't insult your intelligence by posting dozens of links to various forums outlining the case (though Blue_Frog's citation is to the point). In this case, the MS update made things worse (I admit) though it appears to have at least allowed me to select roaming options (something that was unavailable since I've had the phone). Call Ting, call MS, call Samsung - we don't care. Just fix the phone and your stupid service.

Highlighted
Master

Re: Roaming options grayed out on GDR3

Blue_Frog,


Thanks for sending out this info. This is something that our device guys have been aware of but have been unable to get specific examples. Christy is going to push this message to that department so that can have solid info about this issue. This is not something that is going to be fixed over night but the info that you have provided will go a long way to help get this taken care of.


Sean L
Social Care
Highlighted
Journeyman

Re: Roaming options grayed out on GDR3

@Sean L: What?! You've been unable to get specific examples?! Are you kidding me? You must be kidding me.

Highlighted
Journeyman

Re: Roaming options grayed out on GDR3

Sean and Christy,

Here is the simple fix to the greyed out roaming issues.  Please forward this to your device team....

I am sitting in London right now doing international roaming, both voice and data!  Yea, finally!  Screenshot attached for proof.

These 4 keys are all set to "1", change them to "0"

HKLM\Software\Microsoft\Connectivity\CellUXOEMConfigurable\

HideDataRoamingInternational=0

HideDataRoamingDomestic=0

HideVoiceRoamingInternational=0

HideVoiceRoamingDomestic=0

As a side note, here is the provisioning information Ting and Sprint need to setup for GDR3 and 8.1.

Windows Phone Dev Center</title> <link type="image/x-icon" rel="shortcut ico...

Have a fantastic day!

Blue_Frog

Highlighted
Journeyman

Re: Roaming options grayed out on GDR3

Jeremy,

While we are at it, let's fix you too, and re-enable the Network Profile Updater....

Go to HKLM\Software\OEM\OMADM and set the following STRING keys:

ActivationType = Sprint

ActivationProxyUrl = oma.ssprov.sprint.com

ActivationProxyPort = 80


Then set the following DWORD key:

DisableNetworkProfileUpdate = 0


The you can use the "settings-->network profile updater" again and re-download your Sprint profile.  Sprint shouldn't have ever disabled this to begin with.

Jeremy, can you confirm if this fixes your issue and let's you update your network profile?

-Blue_Frog


Highlighted
Journeyman

Re: Roaming options grayed out on GDR3

Hi Blue_Frog,

Though I've "said" it a few times, thanks again for taking the time to work with those of us having this issue! I'll probably say it a few more times.

The registry settings are already as you describe except the DWORD key, DisableNetworkProfileUpdate. On my phone, it is set to "1" (true), and I can't change it as I lack a registry editor (no interop unlock here with 8.1) and, to my knowledge, there is not a registry editor that works in the absence of an interop unlock of some kind. Plenty of viewers, mind you, but most entries are protected.

I'm open to other ideas/methods of editing the registry. Even browsed Polish sites for a few hours last night!

Highlighted
Journeyman

Re: Roaming options grayed out on GDR3

Blue_Frog, I'm not sure how you found these settings, but on my interop unlocked phone, this did the trick.  Not only is network profile update back, but so are my roaming settings!  Everything appears to be working properly now.  How Sprint hasn't been able to fix this issue for more than six months is effing amazing!

Edit: Only down side is that I have to re-select the roaming options each time I reboot the phone because it reverts to "don't roam" but at least the drop down box is actually selectable now!

Edit 2: Is there any way to set the DefaultRoamingOption setting via registry?  I'm not seeing anything like that in devcenter.

Highlighted
Journeyman

Re: Roaming options grayed out on GDR3

Hi Tomn18,

That question is a little trickier. The info is in devcenter, though it's buried. You have to create (or modify) an xml file called DefaultRoamingOptions.

http://bit.ly/1kk9QF5

And yes, it is amazing, isn't it? Makes you wonder how much (i.e., how little) time is put towards these issues, despite talk of escalations and all the PR talk.

Highlighted
Journeyman

Re: Roaming options grayed out on GDR3

tomn18,

Try changing these DWORD values to 1:

HKLM\Software\OEM\Cellular\CellManager\EnhancedRoaming

DomesticVoiceRoaming

DomesticDataRoaming

InternationalVoiceRoaming

InternationalDataRoaming


I am not certain if they do anything anymore, but this is where they are initially provisioned.  Mine are all set to one and my roaming is all on, even after soft resets.

-Blue_Frog

Highlighted
Journeyman

Re: Roaming options grayed out on GDR3

Seems that Sprint or Ting could publish a small app to the app store that would reset these registry keys on non-unlocked devices.  They have the authority to sign apps that can change registry settings.  It would take a very short amount of time to generate a app that changes a handful of keys and would restrict it to 8.1 builds.  Publish it to the store and problem would be resolved.....  Or they can push provisioning.xml docs out over the air....  Or setup a provisioning server, etc.

Us lowly developers can't publish apps that change these keys, but the OEM vendors can....

Sprint, can you make this happen?

-Blue_Frog

Highlighted
Master

Re: Roaming options grayed out on GDR3

Blue_Frog, I can sure pass the request along for consideration; you bet.

*Christy

Sprint Social Care Team

Highlighted
Journeyman

Re: Roaming options grayed out on GDR3

Here is one solution that helped a Sprint customer!

JustAnotherSprintUsr Jul 14, 2014 6:11 AM (in response to NoLaGirL13)

My MMS wasn't working either and I got that Error 225 not activated message.  Did the ##72786# reset and it didn't work..Then I got on the phone with Steve (2nd line of support) and Steve fixed it. When he looked at the account, there was nothing wrong.  Here's what he did:

       turn off phone

       Steve blocked MMS on my account

       Steve un-blocked MMS on my account

       turn phone on

       Phone updated profile

       able to send MMS now

That Steve is a good guy to know....

Community News

Our Community is BACK!!
Hours of Operations are 7AM - 8PM CST. Please try Searching the Community, we have many questions already answered, you can also check out the Knowledge base
If you need immediate assistance after hours please visit Sprint Chat