cancel
Showing results for 
Search instead for 
Did you mean: 

Cannot enable CallingPLUS on my S8+

Wizard

Re: Software Update: S8/S8+ - CallingPLUS now enabled!

@Earlybird Glad to hear you got it fixed. Yeah this is a good example of something as simple as something like Data Saver turned on could effect other features of the device. Again everyone has their device configured different just like they have different apps installed settings so forth which can always possibility cause problems for some and not others. Just a reminder that everyone device settings so forth will Always vary.. 🙂 

Journeyman

Re: Software Update: S8/S8+ - CallingPLUS now enabled!

My wife's Galaxy S8 will not turn on CallingPLUS.  I have tried everything that was discussed in this thread.  Data Saver is turned off.  Any ideas what to try next?

Journeyman

Re: Software Update: S8/S8+ - CallingPLUS now enabled!

I gather her phone shows the Calling Plus tab in settings. The network settings should be either Automatic or CDMA/LTE. The phone is connected to the wifi  and mobile network allowing access to the internet is on. Data saver is off. If after all that, does the calling plus slider show blue when turned on? There should appear options for wifi & LTE calling below the slider. If you get a revolving circle that times out & a notification that it isn't working, check app permissions. I ran into that problem by restricting various apps permissions.  Turning off the phones' Malware, Virus scan, Safe wifi security software etc before configuration may help. Ok this is all I know. Oh! I think it only works in the USA. But pls check with the Seawolf. Good Luck

 

Journeyman

Re: Software Update: S8/S8+ - CallingPLUS now enabled!

Yup you are so right. It seems to me that data saver, 'always on' and battery saver, for example, are apps that can interfere in ways that are not 'intuitive'. Turn one on and something else stops working. Imho, these 3 particular settings are valuable as $$ and time savers, and it's a shame they can't operate seamlessly. 

Journeyman

Re: Software Update: S8/S8+ - CallingPLUS now enabled!

It allows me to slide CallingPLUS on, but then it turns off right away.  It then displays Cannot turn on Wi-Fi Calling service.

Wizard

Re: Software Update: S8/S8+ - CallingPLUS now enabled!

You might make sure that your in a LTE Area as well and try clearing the cache as well. 

Journeyman

Re: Software Update: S8/S8+ - CallingPLUS now enabled!

Anyone else having the other caller say you sound like you are under water or they can't hear you? They sound fine on our end. I didn't have this before this last update.

Community Manager

Re: Software Update: S8/S8+ - CallingPLUS now enabled!

Are you still having trouble today, @toolman2013?  If so I can send off a report to the folks who manage CallingPLUS.

 

@JPhrost I know that call quality can be a bit of an issue in areas where LTE may not be as strong as CDMA.  We're still working on that, which is part of why CallingPLUS is a phased launch.

 


SeaWolf
Sprint Community Manager & Customer Advocate
Captain of the Vicious Cream-puff
I encourage you to post your questions on the community, give Kudos when earned and always mark the correct answer as "Accepted Solution".


Journeyman

Re: Software Update: S8/S8+ - CallingPLUS now enabled!

CallingPLUS still not able to turn on. 

Sprint Employee

Re: Software Update: S8/S8+ - CallingPLUS now enabled!

Just an update on this issue; we did have a back-end configuration issue that was impacting some users and the result was the problem described here.  If you are still having this issue, please send a Direct Message to myself or SeaWolf and we can get you fixed up.  

Journeyman

Re: Software Update: S8/S8+ - CallingPLUS now enabled!

Yellowjacket 445 solved same problem for my new Samsung S8 ! Great service. Thank you!
Highlighted
Sprint Employee

Re: Software Update: S8/S8+ - CallingPLUS now enabled!

Glad to help.  I will post what we did in case others happen to experience the same issue.  The issue was the device got out-of-synch with what the back-end systems had in place.  This little workaround is the easiest way to get everything refreshed.  

 

If by chance you have Calling PLUS toggled On, but it is not working then lets back-it out first.

To do that, go to Settings > Calling PLUS and choose the Deactivate option from the menu (3 dots) in top right. When the address page loads, scroll to the bottom and select the Deactivate option. That should finish up and you will see the toggle go to Off.

 

After that, or if you weren't able to do that, go into Bluetooth.

From the menu (3 dots), select Rename Device.

Modify the name slightly by adding something to the end (* or 1 or something). Save.

Restart the device.

After the Restart, wait about 3 minutes and then try to start Calling PLUS again. The 3 minutes make sure it refreshes the back-end systems with the device name change.

Community News

Need Help? 
Please try Searching the Community, we have many questions already answered, you can also check out the Knowledge base.
If you have an account question you can create a post and one of our Social Care Agents will help you.
If you need immediate assistance please visit Sprint Chat