cancel
Showing results for 
Search instead for 
Did you mean: 

Ever since the update on Feb.6 wifi and 4g are randomly turning on!

Journeyman

Ever since the update on Feb.6 wifi and 4g are randomly turning on!

I received an update the other day that was suppose to fix some bugs. I accepted it since this phone is really buggy since being updated to ICS as most of you know. I actually get...or should I say got good battery life. Now since this update the wifi turns on randomly, but worse the 4g does. I don't even have 4g in my area yet and it's draining the battery like crazy. I have to constantly turn it off. I went from comfortably getting 16 hours of standby on the phone to now barely 9 hours. Does anyone else have this issue or know when it will be fixed?

5 REPLIES 5
Journeyman

Re: Ever since the update on Feb.6 wifi and 4g are randomly turning on!

I actually just found the answer in an older post on here. Goto connections optimizer in the mobile networks settings in the settings menu. There is a checkbox to turn this off.

Journeyman

Re: Ever since the update on Feb.6 wifi and 4g are randomly turning on!

Thing is, even after unchecking the box, whenever I go back the check is there again.  Suggestions on turning this off?

Journeyman

Re: Ever since the update on Feb.6 wifi and 4g are randomly turning on!

There was an upgrade to software called connections optimizer. Not all phones recived it. The intent was for the phone to allways look for fastest service wiifi- 4G- 3G. this runns down battery also. To see if you have it go to settings--- more under wireless and network--- mobile networks----   connections optimizer if there. Uncheck or read the statement explaining what it does.   If off then it is up to you to tell the phone how and where to connect.   This worked for me.

Journeyman

Re: Ever since the update on Feb.6 wifi and 4g are randomly turning on!

i think when you have it turned off and go back into the menu and you select "Agree" it turns it back on.  If you get the message to agree that means it is already unchecked and you should be back to normal

GrandMaster

Re: Ever since the update on Feb.6 wifi and 4g are randomly turning on!

worst case scenario if you guys ABSOLUTLEY need it shut off go into your applications-all applications and disable it. problem solved.

*********************************************************
I like many others come onto this site for assistance and to help others. Marking a reply as helpful or correct helps others with like issues when they try to search the site for assistance. I do not work for Sprint and my suggestions and or opinions are my own. *************************************************************************************************************
Community News

Sprint S.M.A.R.T Agents
Sprint S.M.A.R.T Agent are here to help Monday through Sunday 6:00 AM CT - 6:00 PM CT. If you need to speak to an agent outside of these hours, please visit Sprint Chat