cancel
Showing results for 
Search instead for 
Did you mean: 

Issues with Epic 4G Touch

Highlighted

Issues with Epic 4G Touch

I truly hope that you will be addressing the "weaker" 3G signal and WiFi connection strength. I enjoy the phone but as far as data connection, it is really not that much of an improvement over my HTC Hero (for the price of the phone and the extra $10 charge). Thanks

Highlighted

Issues with Epic 4G Touch

Al1999 - Is there an update on a Maintenance Release or more to add to the issues log? Thanks

Highlighted

Issues with Epic 4G Touch

The two main issues I've had are weak radio signals and very poor GPS performance.  Minor issues have been a unusually warm phone at times and problems with the touch interface when plugged in.  I love the display though, Big Bright and Beautiful!

Highlighted
Journeyman

Issues with Epic 4G Touch

I discovered a new issue with TouchWiz. If you put a music file in your downloads folder and there's no album art embedded it'll pick a picture out of the same folder and make it the album art. This is pretty annoying to be honest.

Highlighted

Issues with Epic 4G Touch

gstwoofoo - what is wrong with the camera? I don't have a problem with shortcuts not staying on the desktop - actually much easier to put them on than my HTC Hero (screen scrolls easier to an available space). I have not seen a lag between power button and screen -  I don't like the "short" time that the screen goes blank - I find that annoying and no way to adjust.

Journeyman

Issues with Epic 4G Touch

Just want to add a lock screen lag issue to this post.  Everytime I press the power button to wake the phone up, there is a 1 to 2 seconds delay before the lock screen comes up.  Other Epic Touch owners on the internet reported the same issue.  This issue only affects E4GT with SD card installed.

Highlighted
Journeyman

Re: Issues with Epic 4G Touch

Ok I think I found a solution to my lock screen lag problem on the web.  By unmounting the SD card, then remove and reinstall the SD card seem to fix the lag issue.  I will report back later today. 

Update:  It worked right after I reinstalled the SD card, a few minutes later the lag problem came back.

Highlighted
Wizard

Issues with Epic 4G Touch

Shane_M, its been 31 days since the release of this phone.  Can you please give us an update on the status of fixes for

  • Loss of Signal
  • weak reception/slow data speeds
  • camera shutter sound being able to be disabled through a setting (or system sounds)
  • AGPS needing manual update to work properly sometimes
  • any others?!

It would be a nice time for some communication about a fix or the potential fix for this phone.  I realize that much of Sprint's efforts are in appeasing the new iphone users, but you've got a whole heap of upset Android users with this phone.

Highlighted
Journeyman

Issues with Epic 4G Touch

Thought I would add my issues...but I don't see anyone else reporting similar.  My Epic Touch 4g just plain locks up and needs a battery pull, or restarts but then fails to operate properly until I do another manual restart about once every 24 to 36 hours.  Also, when using the phone while charging all manner of crazy stuff happens..mostly random apps opening themselves (I have read elsewhere that this is a known issue - but very annoying).  I am trying to decide if this means I have a faulty unit and I should bring it in to be swapped.  Opinions?

Highlighted
Wizard

Issues with Epic 4G Touch

sperington wrote:

Thought I would add my issues...but I don't see anyone else reporting similar.  My Epic Touch 4g just plain locks up and needs a battery pull, or restarts but then fails to operate properly until I do another manual restart about once every 24 to 36 hours.  Also, when using the phone while charging all manner of crazy stuff happens..mostly random apps opening themselves (I have read elsewhere that this is a known issue - but very annoying).  I am trying to decide if this means I have a faulty unit and I should bring it in to be swapped.  Opinions?

Sounds like a faulty unit. I haven't seen any of those issues.  I haven't had to pull the battery on this guy once.  Just take it back and get a new one.

Highlighted
Journeyman

Issues with Epic 4G Touch

Yeah I would take the phone back for exchange soley for the power/battery problem. I've heard of issues with the phone malfuntioning when plugged in but I myself have not had those problems. For the other issues listed I have though.

Highlighted
Journeyman

Issues with Epic 4G Touch

Abarth99 wrote:

Ok I think I found a solution to my lock screen lag problem on the web.  By unmounting the SD card, then remove and reinstall the SD card seem to fix the lag issue.  I will report back later today. 

Update:  It worked right after I reinstalled the SD card, a few minutes later the lag problem came back.

Tried it! Totally worked for a little while, it was refreshing to feel imediate response but alas the lag returned . I have a 32gb card with 28gb used for note..but this same card was in my evo and had no lag.

Community News

Our Community is BACK!!
Hours of Operations are 7AM - 8PM CST. Please try Searching the Community, we have many questions already answered, you can also check out the Knowledge base
If you need immediate assistance after hours please visit Sprint Chat