cancel
Showing results for 
Search instead for 
Did you mean: 

Loss of Signal on Samsung Epic 4G Touch

Journeyman

Loss of Signal on Samsung Epic 4G Touch

Yep, happened to me twice now.

Journeyman

Re: Loss of Signal on Samsung Epic 4G Touch

Your information is scary due to so so many reporting in forums that they've called sprint letting them know of issue and it hasn't been documented as device issue yet on your end.

I figured after everything that went bad with Epic 4G and Nexus that Sprint would be on top of this one.

Sprint needs to get on the ball unbox 20 Epic Touches hand them out to field testers for a couple days do some real world testing next to Photon and EVO.

There is no doubt radio issue will be discovered patch should follow within a week.

Journeyman

Re: Loss of Signal on Samsung Epic 4G Touch

you have 3 there, at the same place, possibly at a sprint facility? There are thousands of customers complaining about exact same issues all over the web. I have been with sprint for over 10 years and I've never had signal issues until now. I have 5 lines in the same house, and few other old deactivated sprint phones- all have full bars except the galaxy s2.

It is a bit alarming that after all these people complaining about same exact issue, someone from Sprint to write that they don't have anything documented regarding this issue..really?

It happens to me every 5 to 10 minutes when I'm home. I did notice, once I clear the ram, service tend to come back and it usually goes out after phone screen locks/sleep mode. Not sure if they're relevant.

SC20110924-115623.png

SC20110924-194631.png

Journeyman

Re: Loss of Signal on Samsung Epic 4G Touch

Yeah, that is not reassuring that they don't have a report on this by now at the enterprise level.  This is an extremely common issue and has been discussed from day1 with a lot of users calling in to Sprint to report it.  

You even have a Sprint tech acknowledging the issue and being proactive about it days ago here in the forums and yet here is another, presumably higher-up, citing no knowledge whatsoever and the only way he can have any knowledge is if everyone takes their phones in to the service centers?   Either this is 1993 or there are fractured lines of communication within the enterprise.

Make no mistake to any lurkers - this is a fantastic device.   But it does have a radio issue, which seems fixable if Sprint/Samsung can get out of their own way and take care of it.

Highlighted
Journeyman

Re: Loss of Signal on Samsung Epic 4G Touch

Best Buy just replaced my phone and i gotta say, wow what a difference. Everything works as it should. Is it possible there is a bad batch of radios in these devices? Otherwise i'd think we'd see Thousands of threads on this instead of just the few handfulls. Honestly, im so happy i got this thing working perfectly. Good luck people. If at all possible, fight your way into replacing the phone.

Edit: The guy at best buy tried to convice me that all samsung phones behave this way and is normal. Proved him wrong when the new one was activated and demonstrated.

Message was edited by: Techfunk

Journeyman

Loss of Signal on Samsung Epic 4G Touch

Well I must thank RC again.

If he didn't post we wouldn't know how Sprints handling issue.

Evidently their not handling it which is bad news for all owners and those thinking of purchasing

Journeyman

Re: Loss of Signal on Samsung Epic 4G Touch

Slow down techfunk your to excited you just swapped out give it a day or two.

For now Make wifi connection then go into wifi-settings glance down at wifi-networks and it will disaply 'Scanning"

Thats bad news , it means your battery is getting burnt up.

Journeyman

Re: Loss of Signal on Samsung Epic 4G Touch

LOL.. I certainly hope your wrong for my sake... Will do just as you said for a few days and will get back with some results as best as i can Phil...

Edit: I see what you mean Phil about the scanning deal. Otherwise, my network connection seems to be ok at this moment which messed up my GPS lock on my first one. Will report back if anything changes. 

Journeyman

Re: Loss of Signal on Samsung Epic 4G Touch

Cool.

I haven't had radio cut out Signels been fair should be much better.

Data and wifi have been bad compared to EVO / Evo 3D , Ive been getting half the data performance I got out of EVO.

GS2 Data speed 180 down /60 Up

EVO Data speed 408 down / 200up

Wifi is weak 3 bars below EVO

Bad radio chips? i think not.

Its more like unstable radio software  that needs to be updated across the board

Journeyman

Re: Loss of Signal on Samsung Epic 4G Touch

I had this issue on the first couple of days (said I was roaming but I was in an area where the signal was good with the evo 4g), but now the phone works great.  I don't know what caused it to work "normal".  It is an awesome phone!Smiley Happy

Journeyman

Loss of Signal on Samsung Epic 4G Touch

This is pretty strange.  I currently work at a Sprint store and have been taking home the 3D, Photon, and S2 for testing purposes as online posts have made me want to put the phones to the test.

Using Opensignal I've gotten signal strength to very comparable strengths with each phone taking turns at getting the strongest strength.  It was never anything noticeable. 

The S2 was consistantly getting better download and upload speeds on 4G and didn't notice anything wrong with the wifi connection strength.  It did continue searching for wifi even while connected.

GPS worked just fine and had a small expected hiccup when I went out of network (used Sensorly to verify this) and didn't have data roam on.

I'm in the same boat as many people out there in that I'm deciding on what smartphone I want to get except I get to test phones out more thoroughly before purchasing.  I still have to do more testing, but I haven't found anything except that wifi bug so far.  My customers haven't reported back anything negative about the phone yet so I'm wondering if other people just got a bad batch or my store demo phone just happens to be a superior one.

I'll post more as I do more testing.

Journeyman

Loss of Signal on Samsung Epic 4G Touch

Here is something I tried and seems to be working everytime.

Instead of rebooting, open up task manager > RAM > Clear Memory. Everytime I lose reception/3G connection, after clearing memory it seems to come back up with full bars and 3g connection, stays on for while as well. I hope this information helps! Also, even though, I keep getting message sent failed error, it actually does go through. I tried it few times with my friends and they got the message event hough it showed "failed" on my side.

Community News

Sprint S.M.A.R.T Agents
Sprint S.M.A.R.T Agent are here to help Monday through Sunday 6:00 AM CT - 6:00 PM CT. If you need to speak to an agent outside of these hours, please visit Sprint Chat