cancel
Showing results for 
Search instead for 
Did you mean: 

Loss of Signal on Samsung Epic 4G Touch

Journeyman

Re: Loss of Signal on Samsung Epic 4G Touch

Your hardware version is D700, not D710.  Are you sure you have same phone we are all talking about?  My Sprint GS2 is hardware version D710.10.  It shipped with Gingerbread, but you specs list Froyo.

Also, unemployeduser says he's had the phone for 6 months.  It only came out in the last few weeks.  How is this possible?

I swapped my Sprint Samsung Galaxy S2 Epic 4G Touch at a corporate Sprint store Thursday and have yet to experience LOS on the new handset.  I know some of you had problems even after a replacement, but that's my story right now.  I was getting LOS several times a day and so far not once with after exchanging devices.  FWIW, the new device is running build GINGERBREAD.EG30.

*edit for formatting

Journeyman

Loss of Signal on Samsung Epic 4G Touch

Uh the epic 4g is not that new guys.  Not the epic 4g II or whatever the super ultra super model thin one.  Are you sure you are on the same post?  Its for the epic 4g touch.

Journeyman

Re: Loss of Signal on Samsung Epic 4G Touch

Mobile Device -  Never Rooted Samsung Epic 4G Touch ;
                           Kernel 2.6.35.7-SPH-D710.EG30-CL435734 ;
                           2.3.4 Build Number: GINGERBREAD.EG30 ;
                           HW D710.10                    

LOS Issues-

Weak weak wifi signal - only getting 3 bars using N Technology with wpa2 encryption (missing 2 bars when the router is in the next room)

Upon downloading an app from the Android Marget I sometimes get " Connection lost, retry". I have to back out of the Market and re-execute to get a

download started sometimes

Roaming issue has come up 3 times since 9/16/2011.

Journeyman

Re: Loss of Signal on Samsung Epic 4G Touch

I'm on my third one, maybe third times the charm, not sure.  It's been since Thursday and not a single LOS yet.  Used to happen 2-6 times per day.

Journeyman

Re: Loss of Signal on Samsung Epic 4G Touch

Good luck... Im so happy Best Buy replaced my phone. My Epic Touch works flawlessly.  My first unit had issues out of the box.

Edit: Take under consideration how many los reports vs Epic Touch phones sold by Sprint (gotta be in the thousands). Its gotta be a small bunch of defective units out there. Get your phones replaced till you get the right one.

Journeyman

Re: Loss of Signal on Samsung Epic 4G Touch

INCOMING PATCH

http://samsunggalaxys2review.org/android-2-3-5-making-its-way-to-samsung-galaxy-s-ii-via-kies/

Hope this patch adds other fixes to the LOS issues as well.

Journeyman

Re: Loss of Signal on Samsung Epic 4G Touch

I dont think thats a patch. More like android upgrade.

Journeyman

Loss of Signal on Samsung Epic 4G Touch

Be great to even get to update, but the phone has no signal, or goes into roaming, it wont download, because it cant hold a signal.

Journeyman

Re: Loss of Signal on Samsung Epic 4G Touch

I think they mean to download it via KIES on your PC and then flash it to your phone...  That is, go to Samsung's website on your PC, download Kies, and then following the instructions. The Kies program will copy the update to your phone and instruct you how to update. Though I don't like the idea of losing the scroll bump highlighting just because apple sued Samsung...   Apple has stolen/copied their share of ideas, circa 2006 with teh LG Prada (which I still can't bear to part with) and used that form, shape and sleekness in their i Phony...  lol

Journeyman

Re: Loss of Signal on Samsung Epic 4G Touch

TechFunk, when you say that the first phone had issues out of the  box, you're referring to the store opening the phone and activating it  there, and the activation went okay, is that correct? Then a short time  (or sometime)  thereafter you started having issues, is that also  correct?  When they replaced the phone at best buy, they swapped it, and  activated the new unit in front of you? They didn't just take the old  one, give you a new one, and send you on your way to take care of the  re-activation yourself, right?

I ask this because at least one person (maybe two)  say(said) they got the replacement phone, went home, and activated it  (the replacement) and I was thinking and that one had issues also, that  it wouldn't activate... and I'm thinking, well, wouldn't they have had  the store who was doing the exchange actually activate it there, change  over the SD card etc?  I guess I'm getting old and missed something  along the way...

Journeyman

Loss of Signal on Samsung Epic 4G Touch

Just to clarify, this topic is addressing the Samsung Galaxy SII Epic 4G Touch released Sept 16th this year in America (been out awhile internationally), not the Samsung Galaxy S Epic 4G (has a physical slide out keyboard) which has been out since last year. 

On a different note I did another side by side test with opensignal on my way home from work.  The drive took about 32 minutes so I left the graph running on opensignal using 3G.

SGS2 - Highest signal strength and lowest signal strength.  Topped over 24asu and dipped below 8asu.  Seemed to spike up and down often. (spiky graph)

Photon - Stayed consistant.  Straight line right above 16asu except at the end of my trip where it dipped for just under the 16asu point. (straight line)

Evo3D - Seemed to be more stable than the SGS2.  Highs and lows not as extreme like with the SGS2.  Hovered right above and below the 16asu point. (blocky graph like something you'd see in TRON) 

Perhaps if they found a way to stabilize the signal strength you'd have close to a flawless phone.  The only other bug I've seen so far is the constant search for wifi even when connected. 

Wizard

Loss of Signal on Samsung Epic 4G Touch

I had this happen to me yesterday for the very first time since I picked it up on 9/22, I thought I just had a good unit - alas its all of them, which is a little more comforting to hear because it's a major issue that should be addressed.  I think what mine was having an issue with was the hand off from tower to roaming and back and THEN LOS.  I was in a low signal area (and I was at a football tailgate near the Badgers stadium) so the network was taxed to the max.  My phone would not switch over to roaming to get the job done very efficiently or hardly at all.  Many times the 3G signal would just disappear and I couldn't coax it back without a reboot of the phone.  THEN I got the circle with the slash through it indicated complete LOS.  Power cycle brought this back.  This phone should have a far more stable data connection than what it has.

I think this MUST be solvable by a software update, and I know its being worked on, just wanted to chime in because it is more than a few users experiencing this issue.  I don't see it all the time BUT the LOS and the hand off to roaming towers needs to be addressed.  It is absolutely enfuriating when this happens, clearly.  My friends, who had Evos and blackberries, didn't have problems kicking into roaming and getting their messages and checking scores.  PLEASE FIX THIS SOON!  (like before Thursday, otherwise, I might have to go to the photon....even though I absolutely love this phone!!! )

Community News

Sprint S.M.A.R.T Agents
Sprint S.M.A.R.T Agent are here to help Monday through Sunday 6:00 AM CT - 6:00 PM CT. If you need to speak to an agent outside of these hours, please visit Sprint Chat