cancel
Showing results for 
Search instead for 
Did you mean: 

1/19 - Samsung Epic™ 4G Software Update - EL30

Highlighted
Wizard

1/19 - Samsung Epic™ 4G Software Update - EL30

Samsung Epic™ 4G Software Update - EL30

Enhancements/Fixes

- Security update

- Speaker feedback fix

- The QIK and Asphalt 5 applications are no longer preloaded.  When opening

  the applications using the application icon, you will be redirected to the

  Android market to download and install the full application. 

  * After the QIK install, you will need to login using your original

    account information or create a new account.  All contacts should remain intact

  * After the Asphalt 5 install, previous game play data (eg. levels) will not be retained.

Important Notes

- Software version is: S:D700.0.5S.EL30

- Released in stages with 100% of devices having received the update within

  approximately 10 days

- Refer to the Samsung Epic Software Update blog for install instructions  

1/26 update:

If a force close error is displayed when you receive an incoming call, ensure the "reject call with message"

set up includes no more than 5 messages.  To access these settings, go to

Menu > Settings > Call settings > Reject with  message, choose the menu key and select 'delete', check

the box next to each message to be deleted and select 'delete' again.

Message was edited by: dshoem01

118 REPLIES 118
Highlighted
Journeyman

This update has totally screwed up my network coverage. Sprint's "fix" was to give me a $25 account credit and send me an Airave. They said they would send it two weeks ago, but I still don't have an e-mail confirmation that it has been shipped. This happens inside, outside, everywhere and I live DOWNTOWN!

Highlighted
Journeyman

yes, happening to me too, and they don't acknowledge a known issue, plus I thought my upgrade was now, and it's no longer yearly so I have to wait until March to get rid of this phone, which is useless with no signal!!

Highlighted
Sprint Employee

Please send me a private message, I will look into this for you.

No longer working Community Response.
Highlighted
Sprint Employee

Please also send me a private message.

No longer working Community Response.
Highlighted
Journeyman

what are you going to do about it? Sprint does not acknowledge an issue.  if there's a fix, put it right here on the board, what's with the "private" ?

Highlighted
Master

teresazu5 wrote:

what are you going to do about it? Sprint does not acknowledge an issue.  if there's a fix, put it right here on the board, what's with the "private" ?

Any communication that requires accessing a customer's account or service information is done through private messaging so customer information is not made public.

Highlighted
Journeyman

there is no need to access customer account for this problem.  it's internal phone problem.

Highlighted
Master

teresazu5 wrote:

there is no need to access customer account for this problem.  it's internal phone problem.

I have never seen this problem in person, and I work at one of the top 15 busiest stores in the country (I am a technician and we are a service and repair store). It is quite possible the issue could be related to a network issue in the area, not the device. We simply don't know for sure at this point. I see posts all of the time saying the update did this or broke that, and the issues can't be duplicated on a wider basis or in the testing lab. If it can't be duplicated, the issue could be related to an issue on that specific device, conflicting applications, corrupted app or system files, etc.

This is why I always recommend if people have weird issues after a software update, that they attempt to clear app data if it is a specific app having an issue, or potentially reset the phone back to factory settings if it is happening in a number of applications.

Signal issues most of the time are network related, not device. The only way to know for sure if it is the phone is to take it into a service and repair location and have them run an antenna test (POST) on the device. I have Epics come in all the time that we test the antenna on running EL30 and FC09 software which are operating normally for network connections. It is not an issue with the software update overall; or else most, if not all, of the phones with that software would have the issue, as it stands I have not seen that and the internal device forums we use for S&R work don't show a massive number of issues like this either like it would if it was widespread.

Highlighted
Journeyman

people have done factory reset, and other things, you need to read all the entires here, and even google some more.  of course it's the phone if THAT many people are having the SAME issue. 

Highlighted

teresazu5 wrote:

people have done factory reset, and other things, you need to read all the entires here, and even google some more.  of course it's the phone if THAT many people are having the SAME issue.

A handful of people here are posting issues with signal and you make it seem like it is a widespread problem. There are thousands of Epics out there. You'd think if there was a major issue there would be a whole lot more people complaining here and to Sprint on the phone. I had no issues with signal strength on my Epic when I had it...on any software version...and I was running FC09 when I got rid of it.

You do realize that Sprint is upgrading towers to support LTE in several places right? When they do that, the tower goes down and can cause issues. If they are upgrading towers in your area that could cause problems...but if you don't let someone offering to help, help, then I guess you'll never know.

Highlighted
Journeyman

Are you still on EL30 or are you now on FC09? 

Sorry to hear about your phone problems.  Odd. For me EL30 fixed pretty much everything (GPS, freezing, constant rebooting).  Unfortunately, the FC09 seriously messed up my phone so I now call her "Sybill."  Even with my FC09 issues, I'm still getting the same Sprint reception.  FC09 for me reintroduced the GPS and constant rebooting and freezing issues.  Eventhough I've turned off the optimizer, it's still running in the background messing things up.  It's worse when I'm downtown on campus (University) with multiple free wi-fi zones.

When they were screwing with the towers in Chicago, I did get day late text and voice messages along with some missed calls. 

Sprint coverage for me has always been 3rd rate (literally, based on the carrier coverage apps out there) but it's enough to keep me connected and there's no beating Sprint's unlimited data plan. 

Community News

Our Community is BACK!!
Hours of Operations are 7AM - 8PM CST. Please try Searching the Community, we have many questions already answered, you can also check out the Knowledge base
If you need immediate assistance after hours please visit Sprint Chat