cancel
Showing results for 
Search instead for 
Did you mean: 

Cannot connect to PC via USB in Windows 7

Journeyman

Cannot connect to PC via USB in Windows 7

I've been having this problem for a while now; figured I might as well ask about it here.

After following all the steps listed on the tutorial, I cannot connect my Epic 4G to my computer, which runs Windows Home premium. No autoplay pops up when I tell the phone to connect. A "Removable Drive E" shows up in My Computer and in the Remove Hardware menu (associated with the phone), but double-clicking only tells me to "insert a disk" into the "drive."

Any ideas?

15 REPLIES 15
Wizard

Re: Cannot connect to PC via USB in Windows 7

     First, on the Epic under: Menu > Settings > Wireless and Network > USB connection, you will find the default USB connection type. This needs to be to be set to either Mass Storage or Ask on connection. If you're set to Ask on connection, you will get a notification on the Epic when plugged into a computer. After the device has gone into Mass Storage mode, you should be prompted with autoplay on your Windows computer. Let me know if this doesn't help!

-Donnie

Journeyman

Re: Cannot connect to PC via USB in Windows 7

Dumb question: do you have a microsd card in the phone? If not then the way it's acting is what I would expect (saying there's not a disc in the drive)

You can't mount the main partion of the phone as USB storage (the HTC One X can do this from what I read, but the phone has to be setup that way and I highly doubt the epic 4g is)

Wizard

Re: Cannot connect to PC via USB in Windows 7

     You're right, there's no way to mount the Epic without an SD card installed.

-Donnie

Journeyman

Re: Cannot connect to PC via USB in Windows 7

It's currently set to "Ask on connection," and it goes into mass storage mode like it's supposed to. But no autoplay appears.

Also, yes, there is a microsd card in the phone.

I've also tried plugging it into multiple ports, changing cables, and checking and unchecking the "USB Debug Mode" setting.

Journeyman

Re: Cannot connect to PC via USB in Windows 7

Two other questions...

- Have you tried another computer- it can happen where windows is unable to read external media.  I've seen it a few times, maybe due to a virus or corrupt file

- Is the micro SD card formatted?

You can also try making sure it's formatted correctly by (in Windows) going to the Control Panel > Administrative Tools > Computer Management > Disk Management, check the E drive, it should, if it's reading the SD card, show up there, even if it's not formatted for Windows.  Let me know what it says or take a screen shot with Jing (http://www.jing.com) or snagit (http://www.snagit.com).

Wizard

Re: Cannot connect to PC via USB in Windows 7

     Once the phone is in mass storage mode. Are you able to view content, such as pictures, from the device? If it's truly in mass storage mode, the phone should no longer be able to access the memory card until it's unplugged. Assuming it really is giving ownership of the card to the computer, it may be a driver or cable problem. If you have another micro USB cable, try using it.

     If the problem is driver related, you can download the driver from Samsung's site here. You have to click Software on the Manuals & Downloads tab and you will see the download link.

     You may also have success if you find the device in the device manager on your PC (if it even shows up) by uninstalling it in the right-click menu. The driver should be reinstalled automatically when you plug the device in again. It's likely going to be much easier to download and install it from Samsung though.

-Donnie

Journeyman

Re: Cannot connect to PC via USB in Windows 7

It's definitely going into mass storage mode -- all the applications I installed on the SD card have greyed-out icons with a little "SD card" icon on them.

Using another cable does not work.

Using another computer DOES work but doesn't really fix anything. As a side note, my computer is fine with my external drive and pen drive, so it's not a matter of being unable to read external media.

 

Reinstalling the driver did not help, either through samsung or by uninstalling it and plugging the phone back in. Though uninstalling and letting it reinstall itself did seem to complete successfully, it did not fix the issue.

Finally, viewing the formatting for the drive brings up the following:

Disk 3

Removable

14.74 GB

Online

Next to that it says:

E:

14.74 GB RAW

Healthy (Primary Partition)

...so that's a problem. However, plugging the microSD card into the computer via SD adaptor works just fine and gives the formatting as FAT32. So the SD card itself is formatted correctly.

Also, a note: every time I plug it in, I do always try to Eject it through Windows before disconnecting, but it always says its "in use." That's pretty normal for my comp though -- I have to force eject all my other external media too.

Highlighted
Journeyman

Re: Cannot connect to PC via USB in Windows 7

Win 7 is a little sticky about cables. If you're trying to connect with your charger cable, forget it. It only works selectively. Your best solution is to get a high quality usb 2 cable.

Journeyman

Re: Cannot connect to PC via USB in Windows 7

Bring up the dialer and enter the following:

##8778#

Check that UART is set on modem and that USB is set on PDA.

With those settings, you should be able to connect the phone to the computer.

Journeyman

Re: Cannot connect to PC via USB in Windows 7

Thanks c_brook.   This did the trick.  I have been baffled with this one for some @#$^% time.  If you're ever in Kansas City, please let me buy you a drink.

Journeyman

Re: Cannot connect to PC via USB in Windows 7

Hm, everything seems to be in order there.

I've already tried a different micro USB cable, but I suppose I can keep trying them.

Community News

Sprint S.M.A.R.T Agents
Sprint S.M.A.R.T Agent are here to help Monday through Sunday 6:00 AM CT - 6:00 PM CT. If you need to speak to an agent outside of these hours, please visit Sprint Chat