cancel
Showing results for 
Search instead for 
Did you mean: 

OMG ... if someone can't tell me how to fix this "9230: Message sent using invalid number of digits..." error, I'm going to scream. My husband and I both have Sprint Epic phones and love them EXCEPT for this one problem! Help!

Journeyman

OMG ... if someone can't tell me how to fix this "9230: Message sent using invalid number of digits..." error, I'm going to scream. My husband and I both have Sprint Epic phones and love them EXCEPT for this one problem! Help!

thanks tomdeaver,  worked great!!

Journeyman

Re: OMG ... if someone can't tell me how to fix this "9230: Message sent using invalid number of digits..." error, I'm going to scream. My husband and I both have Sprint Epic phones and love them EXCEPT for this one problem! Help!

I work in Business Wireless Technical Support and have had several calls about this......steps we use to resolve this is to make sure that all numbers you are texting to are 10-digit numbers, if not then you will need to remove the contact and readd using the 10-digit numbers. Some questions we do ask is: are you able to text other people in your contact list or is it this specific number? Can you reply to this contact should they text you first? Getting this error isn't a known issue per se, but we do get several calls when this happens on any phone capable with text messaging. If you are still having trouble call Sprint Technical Support by dialing *2 from your phone or call from a different phone to better aid in troubleshooting.

Journeyman

Re: OMG ... if someone can't tell me how to fix this "9230: Message sent using invalid number of digits..." error, I'm going to scream. My husband and I both have Sprint Epic phones and love them EXCEPT for this one problem! Help!

If you are using gmail then once you sign back in all your contacts, emails, & calendar will be resynced to your phone, you can also save your contacts to your sd card by going to contacts, pressing menu, selecting import/export to sd, this can also be done to back them up on to your gmail if you recently added it to your phone to make sure they ar backed up. To confirm they are up to date you will need to log into gmail on the computer to view/edit your contacts.

Journeyman

OMG ... if someone can't tell me how to fix this "9230: Message sent using invalid number of digits..." error, I'm going to scream. My husband and I both have Sprint Epic phones and love them EXCEPT for this one problem! Help!

This message is addressed to the SPRINT TECH SUPPORT PERSONNEL. I hope you read this.

I am also having this problem. Deleting the message log works - for a while. Here's one curious think I have noticed.

I have a contact with a 10 digit number. I send a message to that contact. That person replies. The contact appears with the proper 10 digit number. I reply to that message, no problem. The person replies again, but this time, the area code is missing from the contact. At this point, I have to delete the thread.

As a software engineer who has 20 years experience designing software for cell phones and messaing devices, I see a few software bugs going one.

1) Clearly, there is a bug somewhere in the pipeline (either Spring network, Epic messaging application, android middleware, etc.) where the other party's full phone number is dropping the area code. (In this case, the person to whom I was messaging is using a Blackberry. Maybe the Blackberry is truncating their number, but I would bet that the problem is between Sprint network and the Epic messaging application. This needs to be fixed.

2) The second bug is that the Epic messaging application should be able to message 7 digit phone numbers. It should prepend the home area code to the 7 digit phone number. If I only stored the contact with 7 digits, I could still dial that number from the phone application and it would know to add my area code to the number. This is a common feature in most cell phones.  It is a cop out on Sprints end to expect end users to store all phone number with area codes. The messaging application should be able to send messages to 7 digit phone numbers.

The existing workarounds are temporary patches and poor ones at that. It causes us to lose our message history, which is an extrememly important feature. It makes the messaging application almost unusable. When I make a local phone call, I don't dial the area code. Why should I have to do this spefically for the messaging application? On a scale of 1-5, where 5 is red alert, I would rank these level 4 software bugs with respect to the messaging applicaton and am shocked that Sprint hasn't fixed this by now.

DO NOT RESET YOUR PHONE as a solution to this problem. You will still have the problem and unless you have all your contacts stored in your google account (which I did not), you will potentially lose a lot of information, which I did.  I am still recovering.

Master

Re: OMG ... if someone can't tell me how to fix this "9230: Message sent using invalid number of digits..." error, I'm going to scream. My husband and I both have Sprint Epic phones and love them EXCEPT for this one problem! Help!

Here is what you need to do inorder to fix 9230 message issues.You may not have to delete any contacts as long as they have 10 digits. 

Go to -Home - Menu - Settings - Applications - Manage Applications - All (at the top) - Dialer and Dialer Storage (this may delete your call history) - Clear Data. Repeat these steps for the "Phone" apps as well.  

Delete that call history for that contact (if it's not deleted already).  Delete the sms thread for that contact.  Ensure that the contact is programmed with 10 DIGITS and Reboot.  Start a new text message and send.  Add a direct dial shortcut to a home screen for that contact to ensure that you're not dialing that contact manually with only 7 digits.

Journeyman

Re: OMG ... if someone can't tell me how to fix this "9230: Message sent using invalid number of digits..." error, I'm going to scream. My husband and I both have Sprint Epic phones and love them EXCEPT for this one problem! Help!

thanks so much!!  i was going NUTS    

Journeyman

OMG ... if someone can't tell me how to fix this "9230: Message sent using invalid number of digits..." error, I'm going to scream. My husband and I both have Sprint Epic phones and love them EXCEPT for this one problem! Help!

I have been getting this error since a little before 9 AM yesterday.  Only, I'm NOT sending texts.  I get it EVERY single time I get a voicemail.  As soon as somebody leaves me a message, I get a text telling me "Message sent using invalid number of digits".  What that has to do with voicemail, I have yet to figure out. 

Obviously, it has nothing to do with my contacts, as I'm not texting anybody, and it doesn't matter who leaves the voice mail.  So I do not beleive deleting or changing contacts is the answer (not the least of which, I don't have a single contact in my phone that does not have an area code in front of it).  But it's driving me nuts, and is certainly enough to cause me to return this Samsung Epic and exchange it for something else.  I can not believe this problem has been a known issue for this long and Android and Samsung haven't figured out a fix yet?!

Highlighted
Journeyman

OMG ... if someone can't tell me how to fix this "9230: Message sent using invalid number of digits..." error, I'm going to scream. My husband and I both have Sprint Epic phones and love them EXCEPT for this one problem! Help!

THIS FIX WORKS!!!!

This is the only thing that would work for my phone and my daughter's phone.We tried everything. She got the facotory reset several times. What a pain. THIUS WORKS

You have to dial the area code when manually dialing contacts.............

My phone was doing the same thing. Apparently when you manually dial a number you  must use the area code or your phone's memory will memorize the number without the area code for all other functions.Wish I knew who originally posted this - becasue they deserve the credit - not me----- I found this fix and it worked for me:

Code drops off for messaging - Samsung Epic 4G

Here is the fix. I have tested it and it works.

First the issue is you once texted someone with a 7 digit number. Most likely becuase you stored them in your contacts that way. Even if you update the contact info it will always drop the area code from all future messages to that person. Everyone that was stored correctly will message correctly. Deleting the contact and reinstalling them will not work. Importing the contact again will not work. Deleting the message thread and starting a new thread will not work.

Here is what you need to do.

Clear data in the Dialer and Dialer storage.... under manage Applications> All.

That is Settings - Applications - Choose All to view All choices - then find Dialer and clear the Data. Repeat this for the Dialer Storage as well.

I personally also deleted the message thread first from the text message window and my log history which is a menu item from your call screen.

This process will not delete all your contacts.

The only other fix to this problem is to reset back to factory defaults. I don't suggest this at all.

Good to go afterwards!..

Journeyman

OMG ... if someone can't tell me how to fix this "9230: Message sent using invalid number of digits..." error, I'm going to scream. My husband and I both have Sprint Epic phones and love them EXCEPT for this one problem! Help!

Our account is under my husband's name BUT I PAY THE BILL every month. For what I pay a month and not be able to text my OWN husband is totally ridiculous and I shouldn't have to WAIT for Sprint to solve the problem. You should have already resolved this issue. AND for what we paid for these supposedly TOP OF THE LINE Sprint EPIC phones why is their ANY problems?

Journeyman

Re: OMG ... if someone can't tell me how to fix this "9230: Message sent using invalid number of digits..." error, I'm going to scream. My husband and I both have Sprint Epic phones and love them EXCEPT for this one problem! Help!

Our account is under my husband's name BUT I PAY THE BILL every month.  For what I pay a month and not be able to text my OWN husband is totally  ridiculous and I shouldn't have to WAIT for Sprint to solve the  problem. You should have already resolved this issue. AND for what we  paid for these supposedly TOP OF THE LINE Sprint EPIC phones why is  their ANY problems?

Um whoa there, slow down.  While this is frustrating the problem is fixed.  The reason you cannot text your husband is because your not using his full telephone number with area code when you do it.  You need to make sure that BOTH of you have your full mobile numbers with area code listed in your contacts (10 digits!) AND that in your SMS settings that your reply to number has 10 digits as well, that way when one sends a text to the other, and you hit reply to send back, it knows where to send it.  This is hardly a problem with the phone, or the sprint network as you would receive a fail message no matter WHAT network your sending the text to if you don't have the area code in there!

Journeyman

Re: OMG ... if someone can't tell me how to fix this "9230: Message sent using invalid number of digits..." error, I'm going to scream. My husband and I both have Sprint Epic phones and love them EXCEPT for this one problem! Help!

I agree with Jack. its not just your samsung.  it happened to me often a while back on my blackberry. You have to have all 10 digits regardless of the phone.

Journeyman

Re: OMG ... if someone can't tell me how to fix this "9230: Message sent using invalid number of digits..." error, I'm going to scream. My husband and I both have Sprint Epic phones and love them EXCEPT for this one problem! Help!

So I've read the information, scenarios and "fixes" in the previous posts but I want to through my situation into the mix.

My phone is rooted but, THAT ASIDE, I ASSURE you that I have NEVER had this problem until the past couple/few weeks.  I am VERY consistent with how I enter information into my contacts and address book MAKING SURE I am using the "proper" number of digits including area code, even for my local calls.  I got my EVO which is my current phone back on launch day, June 2010, and like I said, I have NEVER had this problem with the SAME contacts and phone number information except for the past few weeks....

In the Home Screen —> Menu —> Settings —> Call —> Phone  Settings area, one can set a default message to be sent via text to an  incoming phone call that you choose to reject.  The "Default Message"  can be edited (without editing it says "I am busy right now.  I will  call you later"), you can also choose a option to "Edit the Message  Before Sending" and, lastly (irrelevant to this bug issue) one can "Save  to Contacts" unknown numbers.  I do not see an option to "turn off" the  text message for a call reject.

It appears that, from the lock screen (at least on my phone), when there is an incoming call  and the option to "Answer" or "Decline" if you choose to DECLINE and  send the call to your voice mail, a text message is generated and sent  to the number that tried to get in touch with you.

HERE IS THE PROBLEM

...Within a minute or so, I receive an ERROR MESSAGE from my Sprint service indicating the following:

From: 9230
Message sent using invalid number of digits.  Please resend using 10 digit number or valid short code.  Msg 2114

And

HERE IS MY THEORY about what is going on...

I believe, upon "declining" to answer a phone call, the caller is sent  to voicemail and a text message is generated to that person's phone  number.  However, it appears from the text error message that I receive  that the text message that is automatically sent "behind the scenes"  does NOT have the proper number of digits. I have NO CLUE if the phone  is trying to send with a "1" in front of a 10-digit number including  area code....I don't know if they phone is trying to send ONLY a 7-digit  number without area code.

It also appears, as SHOULD BE the case, that this text error message  ONLY appears if you reject a phone call from a number marked as "mobile"  in your contacts.  That would make sense (and is a smart/good thing)  because the phone "knows" not to send a text to a "home" number or a  "work' number or the like.

And, if you simply ignore the phone call WITHOUT choosing "decline" then  the call gets routed to voice mail on its own, no text message is  generated (I assume) and NO ERROR MESSAGE results in the text message.

Now I do NOT KNOW if this is an "HTC/Sprint issue" or an issue with my fancy rooted ROM but wanted to post here because OTHER PEOPLE are obviously getting the same message.  ANOTHER thing that is weird...even though I have chosen  the checkbox to "Edit text messages before sending" I have NEVER been  prompted to do so.  Everything seems to happen automatically and "behind  the scenes"

Sooooo....NEVER EVER EVER having this issue before and then all of a sudden this pops up??...never had a problem with rejecting calls...never had a problem sending messages using my contacts...just ALL OF A SUDDEN....

Any thoughts???  THANKS!!!

(PS...I know this is NOT an EVO thread but I have heard of this issue across MANY different phone manufacturers and I found this thread as a recent and decent discussion)

Community News

Sprint S.M.A.R.T Agents
Sprint S.M.A.R.T Agent are here to help Monday through Sunday 6:00 AM CT - 6:00 PM CT. If you need to speak to an agent outside of these hours, please visit Sprint Chat